Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 03:50
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Сохранение всех картинок  (Прочитано 2876 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Воитель

  • *
  • Сообщений: 38
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-16
  • Сайт: 
  • Профессия: Бухгалтер
Закончил курсы, решил написать первый СВОЙ собственный код. Задача такая. Сохранить все картинки из номенклатуры в папку.
Но первый блин комом, ошибка:
начение не является значением объектного типа (Хранилище)

Функция МСАА() Экспорт

//{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
// Данный фрагмент построен конструктором.
// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| Номенклатура.Код,
| Номенклатура.ОсновноеИзображение,
| Номенклатура.Наименование
|ИЗ
| Справочник.Номенклатура КАК Номенклатура";

Результат = Запрос.Выполнить();

ВыборкаДетальныеЗаписи = Результат.Выбрать();
    ПеременнаяНаВозврат = "";

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл


КаталогФайла = "D:\WebServers\home\4atrix\www\cron\papka_s_kartinkami_iz_1s";
Картинка = ВыборкаДетальныеЗаписи.ОсновноеИзображение.Хранилище.Получить();
Если ТипЗнч(Картинка) = Тип("Картинка") Тогда
Картинка.Записать(КаталогФайла + "\" + ВыборкаДетальныеЗаписи.Наименование + ".jpg");
ПеременнаяНаВозврат = ПеременнаяНаВозврат + КаталогФайла + "\" + ВыборкаДетальныеЗаписи.Наименование + ".jpg<br />"
КонецЕсли;
КонецЦикла;

//}}КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
    Возврат ПеременнаяНаВозврат;
КонецФункции
Это функция в общем модуле, вызывается через COM соединение.
Если закоментировать то что связано с картинкой в переменную "ПеременнаяНаВозврат " всё правильно возвращается - адреса всех картинок, т.е. часть кода у меня всё таки верно работает )


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Картинка = Новый Картинка(ВыборкаДетальныеЗаписи.ОсновноеИзображение.Получить());
//может быть нужно так?
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Воитель

  • *
  • Сообщений: 38
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-16
  • Сайт: 
  • Профессия: Бухгалтер
Тоже ошибка:
Метод объекта не обнаружен(Получить)
Пробовал через хранилище, тоже с какой-то ошибкой.

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
	Запрос = Новый Запрос; //Вот так
    Запрос.Текст =
        "ВЫБРАТЬ
        |    Номенклатура.Код,
        |    Номенклатура.ОсновноеИзображение,
        |    Номенклатура.Наименование
        |ИЗ
        |    Справочник.Номенклатура КАК Номенклатура";

    Результат = Запрос.Выполнить();

    ВыборкаДетальныеЗаписи = Результат.Выбрать();
    ПеременнаяНаВозврат = "";
   
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
       
        КаталогФайла = "D:\WebServers\home\4atrix\www\cron\papka_s_kartinkami_iz_1s";
Если Не ЗначениеЗаполнено(ВыборкаДетальныеЗаписи.ОсновноеИзображение) Тогда
Продолжить;
КонецЕсли;
        Картинка = ВыборкаДетальныеЗаписи.ОсновноеИзображение.Хранилище.Получить();
        Если ТипЗнч(Картинка) = Тип("Картинка") Тогда
            Картинка.Записать(КаталогФайла + "\" + ВыборкаДетальныеЗаписи.Наименование + ".jpg");
            ПеременнаяНаВозврат = ПеременнаяНаВозврат + КаталогФайла + "\" + ВыборкаДетальныеЗаписи.Наименование + ".jpg<br />"
        КонецЕсли;
    КонецЦикла;
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Последний раз редактировалось: Dethmontt; 20 Дек 2011, 14:36

Оффлайн Воитель

  • *
  • Сообщений: 38
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-16
  • Сайт: 
  • Профессия: Бухгалтер
Сейчас попробую.

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Попробуй)))
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Воитель

  • *
  • Сообщений: 38
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-16
  • Сайт: 
  • Профессия: Бухгалтер
Процесс пошёл. Есть ещё некоторые непонятности, но картинки стали загружаться.


Теги:
 

В разделе "Перейти"панели навигации ВСЕХ управляемых форм (новых, старых, вновь создаваемых) конфигурации появляется одна и та же команда. Как избавиться?

Автор CrazyHorseРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1288
Последний ответ 23 Июн 2015, 16:49
от CrazyHorse
Для всех документов нужно сделать проверку при проведении. Где это можно сделать?

Автор ZeedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 632
Последний ответ 04 Сен 2016, 04:20
от cska-fanat-kz
Часть вторая: переход на «1С ЗУП» версии «3.0». Работа с «Параметрами учета» и проверка всех настроек программы после транспортировки из предыдущей редакции

Автор 1cwikiРаздел Зарплата и управление персоналом

Ответов: 0
Просмотров: 4249
Последний ответ 16 Мар 2015, 16:19
от 1cwiki
Если стоимость отгруженного товара изменилась, нужно выдавать корректировочную или обычную счет-фактуру с учетом всех изменений

Автор newsРаздел Новости

Ответов: 0
Просмотров: 1098
Последний ответ 17 Июл 2014, 12:25
от news
Сохранение документов в формате *.pdf с компьютеров, подключенных к серверу через удаленное подключение к рабочему столу

Автор NeutrinoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 691
Последний ответ 20 Июл 2016, 15:59
от Neutrino

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
166 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
36 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
28 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 207
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal