Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 09:42
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Переход и активация строки  (Прочитано 3298 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн donyab

  • *
  • Сообщений: 22
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-12-19
  • Сайт: 
  • Профессия: Программист 8.1
Процедура ТаблицаНЦенаКонецОткрытие(Элемент, СтандартнаяОбработка)

                СтандартнаяОбработка = Ложь;
                Пер1 = ТаблицаН.Получить(ТаблицаН.Индекс(ЭлементыФормы.ТаблицаН.ТекущаяСтрока)).ЦенаКонецРег;
                Попытка
                Форма = Пер1.ПолучитьФорму();
                Форма.Открыть();
                ФормаПодчиненная = Форма.Состав;
                СтрокаО = ФормаПодчиненная.Найти(ТаблицаН.Получить(ТаблицаН.Индекс(ЭлементыФормы.ТаблицаН.ТекущаяСтрока)).Номенклатура);

     
         

Исключение
                Сообщить("Нет документов");
                КонецПопытки;

КонецПроцедуры

В данной процедуре "Пер1" - документ(например приходная накладная)
"ФормаПодчененная" - табличная часть документа
"СтрокаО" искомая строка
Вопрос: Как сделать, что бы когда откроется данный документ(пер1) , была автоматически выбрана нужная строка(СтрокаО),т.е. курсор перешел на нее?


Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Что-то типа:
ТабПоле=Форма.ЭлементыФормы.Пер1;
ТабПоле.ТекущаяСтрока=ТабПоле[ИндексНужнойСтроки];
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн donyab

  • *
  • Сообщений: 22
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-12-19
  • Сайт: 
  • Профессия: Программист 8.1
Процедура ТаблицаНЦенаКонецОткрытие(Элемент, СтандартнаяОбработка)

                СтандартнаяОбработка = Ложь;

                Пер1 = ТаблицаН.Получить(ТаблицаН.Индекс(ЭлементыФормы.ТаблицаН.ТекущаяСтрока)).ЦенаКонецРег;

                Попытка

                Форма = Пер1.ПолучитьФорму();

                ФормаПодчиненная = Форма.ЭлементыФормы.Состав;

                СтрокаО = Форма.Состав.Найти(ТаблицаН.Получить(ТаблицаН.Индекс(ЭлементыФормы.ТаблицаН.ТекущаяСтрока)).Номенклатура);

               

                ФормаПодчиненная.ТекущаяСтрока = Форма.Состав[СтрокаО.НомерСтроки-1];

                Форма.Открыть();

Исключение

                Сообщить("Нет документов");

                КонецПопытки;

 КонецПроцедуры



Спасибо, понял свою ошибку, все заработало.

Оффлайн donyab

  • *
  • Сообщений: 22
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-12-19
  • Сайт: 
  • Профессия: Программист 8.1
Процедура ТаблицаНЦенаКонецОткрытие(Элемент, СтандартнаяОбработка)

                СтандартнаяОбработка = Ложь;

                Пер1 = ТаблицаН.Получить(ТаблицаН.Индекс(ЭлементыФормы.ТаблицаН.ТекущаяСтрока)).ЦенаКонецРег;

                Попытка

                Форма = Пер1.ПолучитьФорму();

                ФормаПодчиненная = Форма.ЭлементыФормы.Состав;

                СтрокаО = Форма.Состав.Найти(ТаблицаН.Получить(ТаблицаН.Индекс(ЭлементыФормы.ТаблицаН.ТекущаяСтрока)).Номенклатура);

               

                ФормаПодчиненная.ТекущаяСтрока = Форма.Состав[СтрокаО.НомерСтроки-1];

                Форма.Открыть();

 

                //ТабличноеПоле = Форма.ЭлементыФормы.Пер1;

                //ТабличноеПоле.ТекущаяСтрока = ТабличноеПоле[];

Исключение

                Сообщить("Нет документов");

                КонецПопытки;

 КонецПроцедуры

Спасибо. Все заработало.

Оффлайн donyab

  • *
  • Сообщений: 22
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-12-19
  • Сайт: 
  • Профессия: Программист 8.1
что то не получается целиком отправить сообщение.
Вобщем большое спасибо Klyacksa.
Все заработало.

           
   Форма = Пер1.ПолучитьФорму();

                ФормаПодчиненная = Форма.ЭлементыФормы.Состав;

                СтрокаО = Форма.Состав.Найти(ТаблицаН.Получить(ТаблицаН.Индекс(ЭлементыФормы.ТаблицаН.ТекущаяСтрока)).Номенклатура);

               

                ФормаПодчиненная.ТекущаяСтрока = Форма.Состав[СтрокаО.НомерСтроки-1];

                Форма.Открыть();


Теги:
 

Часть четвертая: переход на «1С» версии «3.0». Где в программе находятся «Параметры учета»? Алгоритм настройки кадрового учета в новой версии программы «1С»

Автор 1cwikiРаздел Зарплата и управление персоналом

Ответов: 0
Просмотров: 3972
Последний ответ 20 Мар 2015, 12:58
от 1cwiki
Как при вставке текста запроса с консоли запроса ив программный код конфигурации автоматически добавлять прямую черту в начале каждой строки

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2070
Последний ответ 16 Ноя 2015, 08:12
от KrivosheevEV
Возможно ли языком запросов без конкатенации текста запроса и без СКД преобразовать строки таблицы в столбцы (колонки) выходной таблицы?

Автор acces969Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 441
Последний ответ 29 Май 2017, 15:29
от alex0402
переход с зарплаты 7.7 бюджет на зарплату 8.2 бюджет

Автор SergeyDCZNРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 3043
Последний ответ 12 Янв 2012, 15:58
от SergeyDCZN
"Уникальность" строки таблиной части документа

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1941
Последний ответ 20 Авг 2014, 12:22
от has

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
40 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 770
  • Точка Скрытых: 0
  • Точка Пользователей: 13
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal