Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 00:34
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: УПП Управляемый интерфейс  (Прочитано 3222 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн leozx

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-14
  • Сайт: 
  • Профессия: Программист 1С
Здравствуйте.
Пишу внешнюю обработку заполнения табличных частей для УПП 1.3.19
Не получается создать её для управляемого интерфейса.
Если описывать как для УТ 11 и добавлять как внешнюю обработку заполнения табличных частей (под обычным интерфейсом)

Функция СведенияОВнешнейОбработке() Экспорт
   
   ПараметрыРегистрации = Новый Структура;
   МассивНазначений = Новый Массив;
   МассивНазначений.Добавить("Документ.РеализацияТоваровУслуг");
   МассивНазначений.Добавить("Документ.ПеремещениеТоваров");
   МассивНазначений.Добавить("Документ.ЗаказПокупателя");
   
   ПараметрыРегистрации.Вставить("Вид", "ЗаполнениеОбъекта");
   ПараметрыРегистрации.Вставить("Назначение", МассивНазначений);
   ПараметрыРегистрации.Вставить("Наименование", "Заполнить документ");
   ПараметрыРегистрации.Вставить("Версия", "1.0");
   ПараметрыРегистрации.Вставить("БезопасныйРежим", Истина);
   ПараметрыРегистрации.Вставить("Информация", "Дополнительная обработка табличной части через комплектыцию тары");
   
   ТаблицаКоманд = ПолучитьТаблицуКоманд();
   
   ДобавитьКоманду(ТаблицаКоманд,
   "Заполнить документ",
   "Заполнить документ",
   "ВызовКлиентскогоМетода",
   Истина);
   
   ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);
   
   Возврат ПараметрыРегистрации;
КонецФункции

Функция ПолучитьТаблицуКоманд()
   Команды = Новый ТаблицаЗначений;
   Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));
   Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка"));
   Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка"));
   Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
   Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));
   Возврат Команды;
КонецФункции

Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")
   НоваяКоманда = ТаблицаКоманд.Добавить();
   НоваяКоманда.Представление = Представление;
   НоваяКоманда.Идентификатор = Идентификатор;
   НоваяКоманда.Использование = Использование;
   НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
   НоваяКоманда.Модификатор = Модификатор;
КонецПроцедуры


 выдает ошибку. или вообще перестает на нее реагировать после перезапуска предприятия.
Может кто знает что можно сделать.


Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1376
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
Читайте про управляемые приложения! Там совсем по-другому.


Теги:
 

Интерфейс "такси"

Автор TATIZРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3476
Последний ответ 18 Июн 2014, 17:13
от НатальяС
Настройка кнопки "Переключить интерфейс"

Автор AmateRРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 27945
Последний ответ 28 Ноя 2014, 18:29
от Николай Зимин
Интерфейс "ТАКСИ". Управляемая форма как вкладка

Автор NikNivolopРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 10
Просмотров: 3703
Последний ответ 22 Окт 2015, 08:39
от Luzer1C
как программно по умолчанию загрузить нужный интерфейс при запуске 1с, обычное приложение

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 660
Последний ответ 21 Дек 2016, 13:13
от ktu78
Перенесено: Прием и передача смс-сообщений через интерфейс «1С:Предприятие 8.х»

Автор cska-fanat-kzРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1421
Последний ответ 06 Июн 2011, 12:02
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
133 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
61 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 196
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal