Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 12:34
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Не могу разобраться с модулем  (Прочитано 3665 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Stiven

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-09
  • Сайт: 
  • Профессия: Ученик 1С
Изучаю 1с 8.2 по книге Радченко М. 1C Предприятие 8.2 Практическое пособие разработчика
возникла проблема на 4 занятии "Документы" , с модулем , создал общий модул((по книге)расчёт суммы из количества * цену) с Приходная Накладная он работает отлично , но с Оказание Услуг он не считает сумму

3 раза переделывал всё с начала по книге, но увы та же проблема , версия моей платформы 1с .8.2.14.519

может быть какая то не состыкована из за доработки это версии платформы или это ошибка в книге?
любым советам буду очень рад,зарание всем спасибо


Оффлайн Vit1501

  • ****
  • Сообщений: 360
  • РЕПУТАЦИЯ: 60
  • КПД: 17%
  • Регистрация: 2010-06-05
  • Сайт: 
  • Профессия: Программист 1С
а ошибки выдаются какие-нибудь или просто не пересчитывается сумма?

Оффлайн Stiven

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-09
  • Сайт: 
  • Профессия: Ученик 1С
при отладке ошибок нет

Оффлайн Stiven

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-09
  • Сайт: 
  • Профессия: Ученик 1С
нашёл диск с готовыми конфигурациями к этой книге,сравнил их и свою,всё идентично)но их работает)уже не чего не понимаю,или глюк или где то мой косяк,но найти его не как не могу

Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1376
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
Хоть бы свой код выложили, а то ведь тут телепатов нет.

Оффлайн Stiven

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-09
  • Сайт: 
  • Профессия: Ученик 1С
извиняюсь,выкладываю

общий модуль

Процедура РассчитатьСумму(СтрокаТабличнойЧасти) Экспорт

   СтрокаТабличнойЧасти.Сумма = СтрокаТабличнойЧасти.Количество *   СтрокаТабличнойЧасти.Цена;

КонецПроцедуры


Приходная наклодная

&НаКлиенте
Процедура МатериалыКоличествоПриИзменении(Элемент)
   СтрокаТабличнойЧасти = Элементы.Материалы.ТекущиеДанные;
   РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);
КонецПроцедуры

&НаКлиенте
Процедура МатериалыЦенаПриИзменении(Элемент)
         СтрокаТабличнойЧасти = Элементы.Материалы.ТекущиеДанные;
        РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);
КонецПроцедуры

Оказание Услуг

&НаКлиенте
Процедура ПереченьНоменклатурыКоличествоПриИзменении(Элемент)
   
   СтрокаТабличнойЧасти = Элементы. ПереченьНоменклатуры.ТекущиеДанные;
   РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);

КонецПроцедуры

&НаКлиенте
Процедура ПереченьНоменклатурыЦенаПриИзменении(Элемент)
   
   СтрокаТабличнойЧасти = Элементы. ПереченьНоменклатуры.ТекущиеДанные;
   РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);
   
КонецПроцедуры

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Обработчики события ПриИзменении для Количества и Цена в документе ОказаниеУслуги создавал как в абзаце 2 стр 139 или просто код скопировал из Приходной Накладной и подкорректировал?
Кнопочка Спасибо - слева!

Оффлайн Stiven

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-09
  • Сайт: 
  • Профессия: Ученик 1С
я поставил обработчик только для количества , а для цены нет
сейчас всё работает , огромное спасибо


Теги:
 

не могу вывести отображение цен в "подборе" документ "Заявка покупателя" УТ 10.3

Автор Виталий ЕмельяновРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 3914
Последний ответ 05 Окт 2015, 19:22
от Виталий Емельянов
не могу заполнить поле "Соглашение"

Автор aprnРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3160
Последний ответ 05 Май 2011, 18:17
от Maxim
Не могу найти в 1С8.3 справочник "Организации"

Автор ГюзельРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 13613
Последний ответ 17 Сен 2014, 11:18
от Гюзель
Не могу найти "Удаление помеченных объектов"

Автор LeviathanРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 5375
Последний ответ 14 Янв 2016, 06:03
от cska-fanat-kz
Если у счёта есть признак учёта "Количество", то я могу писать Двж.КоличествоДт?

Автор DirecTwiXРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 5387
Последний ответ 25 Апр 2012, 10:39
от Vit1501

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
172 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 803
  • Точка Скрытых: 0
  • Точка Пользователей: 15
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal