Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 00:03
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Сохранение изображение в базу данных 1с 8.2 управляемое приложение  (Прочитано 10541 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн beztrud

Здравствуйте! Есть в документе 2 реквизита ВыборФайла - строка неограниченной длины и ОтсканированноеИзображение - строка неограниченной длины (на форме она выглядит как ПолеКартинки). Нужно чтобы при выборе изображения картинка появлялась в документе ну и сохранялась в базе данных. Вот мой код, которым я вставляю путь в реквизит ВыборФайла
&НаКлиенте
Процедура ЗагрузитьФотоНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
Диалог.Заголовок = "Выберите файл с фотографией";
Диалог.ПолноеИмяФайла = "";
Диалог.ПредварительныйПросмотр = Истина;
Диалог.Фильтр =
"Все картинки (*.bmp;*.dib;*.rle;*.jpg;*.jpeg;*.tif;*.gif;*.png;*.ico;*.wmf;*.emf)|*.bmp;*.dib;*.rle;*.jpg;*.jpeg;*.tif;*.gif;*.png;*.ico;*.wmf;*.emf|"
+ "Формат bmp (*.bmp;*.dib;*.rle)|*.bmp;*.dib;*.rle|"
+ "Формат JPEG (*.jpg;*.jpeg)|*.jpg;*.jpeg|"
+ "Формат TIFF (*.tif)|*.tif|"
+ "Формат GIF (*.gif)|*.gif|"
+ "Формат PNG (*.png)|*.png|"
+ "Формат icon (*.ico)|*.ico|"
+ "Формат метафайл (*.wmf;*.emf)|*.wmf;*.emf|";
Если Диалог.Выбрать() Тогда
    ВыбранноеФото = Новый Картинка(Диалог.ПолноеИмяФайла,Ложь);
Объект.ЗагрузитьФото = Диалог.ПолноеИмяФайла;
Иначе
    Отказ = Истина;
    Возврат;
КонецЕсли;
КонецПроцедуры

А вот что делать дальше - не знаю. В управляемом приложении я должен еще что-то записать
 &НаСервере

Что- конечно не знаю. Прошу Вашей помощи.


Оффлайн Vit1501

  • ****
  • Сообщений: 360
  • РЕПУТАЦИЯ: 60
  • КПД: 17%
  • Регистрация: 2010-06-05
  • Сайт: 
  • Профессия: Программист 1С
посмотри книгу М.Радченко "Практическое пособие разработчика" там есть небольшая глава с примером.

Оффлайн beztrud

посмотри книгу М.Радченко "Практическое пособие разработчика" там есть небольшая глава с примером.

Странно, но в этой книге я не нашел примеры работы с изображениями

Оффлайн Vit1501

  • ****
  • Сообщений: 360
  • РЕПУТАЦИЯ: 60
  • КПД: 17%
  • Регистрация: 2010-06-05
  • Сайт: 
  • Профессия: Программист 1С
Извиняюсь книга Хрусталевой "Разработка управляемого интерфейса", стр 547 глава 3,18

Оффлайн beztrud

Получилось открыть и видеть изображение, но так и не удалось его сохранить (не отображается). Ошибок не выдает, но и не выводит. Где ошибка?
&НаКлиенте
Процедура ЗагрузитьФотоНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
АдресВХранилище="";
ВыбранноеИмяФайла="";
Если ПоместитьФайл(АдресВХранилище, , ВыбранноеИмяФайла, ,УникальныйИдентификатор) Тогда
Файл=Новый Файл(ВыбранноеИмяФайла);
Объект.ЗагрузитьФото=Файл.Имя;
Объект.ОтсканированноеИзображение=АдресВХранилище;
Модифицированность=Истина;
КонецЕсли;
КонецПроцедуры

&НаСервере
Процедура ПередЗаписьюНаСервере (Отказ, ТекущийОбъект, ПараметрыЗаписи);
Если ЭтоАдресВременногоХранилища(Объект.ОтсканированноеИзображение) Тогда
ДвоичныеДанные=ПолучитьИзВременногоХранилища(Объект.ОтсканированноеИзображение);
Объект.ОтсканированноеИзображение = Новый ХранилищеЗначения(ДвоичныеДанные, Новый СжатиеДанных(9));
КонецЕсли;
КонецПроцедуры

Процедура ПриЗаписиНаСервере (Отказ, ТекущийОбъект, ПараметрыЗаписи);
Если ЭтоАдресВременногоХранилища(Объект.ОтсканированноеИзображение) Тогда
УдалитьИзВременногоХранилища(Объект.ОтсканированноеИзображение);
Объект.ОтсканированноеИзображение=ПолучитьНавигационнуюСсылку(ТекущийОбъект.Ссылка, "ОтсканрованноеИзображение");
КонецЕсли;
КонецПроцедуры

Процедура ПриСозданииНаСервере (Отказ, СтандартнаяОбработка);
Если Объект.ЗагрузитьФото <> "" Тогда
Объект.ОтсканированноеИзображение=ПолучитьНавигационнуюСсылку(Объект.Ссылка, "ОтсканрованноеИзображение");
КонецЕсли;
КонецПроцедуры;


Оффлайн beztrud

По примеру Хрусталевой все получается в справочнике, а в документе не удается.

Оффлайн Vit1501

  • ****
  • Сообщений: 360
  • РЕПУТАЦИЯ: 60
  • КПД: 17%
  • Регистрация: 2010-06-05
  • Сайт: 
  • Профессия: Программист 1С
хм.... по функционалу и поведению справочник и документ практически не отличаются. Есть конечно индивидуальные методы и свойства, но к данному примеру они отношения не имеют. Вывод - где то есть различия в коде или реквизитах. Сравни еще раз все что сделал в документе и в справочнике. Ошибки выдает?

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
ТекущийОбъект.Файл = Новый ХранилищеЗначения(ДвоичныеДанные, Новый СжатиеДанных(9));
//Нужно сделать реквизит Объекта с типом "ХранилищеЗначения" и туда сохранять значение, а не в строку!!!
//Нужно писать в ТекукщийОбъект, т.к. объект это структура формы!
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

Перенос данных из 1с 82 БП (базовая) в 1с 82 БГУ (базовая)

Автор Владимир87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7428
Последний ответ 06 Дек 2014, 17:40
от дфтын
Поиск по бае данных,(полнотекстовый поиск)

Автор kot_ooРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3879
Последний ответ 19 Май 2014, 15:40
от kot_oo
Как исправить при обновлении ИБ: Ошибка в запросе набора данных по причине: {(58, 2)}: Несовместимые типы "ВЫБОР" <<?>>ВЫБОР

Автор dollРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2109
Последний ответ 01 Янв 2017, 20:27
от Геннадий ОбьГЭС
"Задваивание" данных в отчете

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 7318
Последний ответ 15 Окт 2015, 11:21
от Mari_beginner
Куда сохраняются данные в режиме работы клиент при выгрузке данных обработкой "Универсальный обмен данными в формате XML"

Автор xDDРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 6945
Последний ответ 13 Ноя 2014, 08:23
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
166 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
36 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 267
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal