Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
25 Май 2018, 09:43
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: FTPСоединение  (Прочитано 6701 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Фесс

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-12-15
  • Сайт: 
  • Профессия: Программист 1С
Доброго времени суток! Имеется задача переименовывания файлов на фтп-сервере, использую копрование и удаление старого, ругается, что не обнаружен каталог. Подскажите в чем может быть проблема или предложите альтернативу. Заранее спасибо

Процедура ИзменитьНаФТПНажатие(Элемент)
   Server = "**********";
   Port=******;
   User="*******";
   Password="*******";
   Сервер = Новый FTPСоединение(Server,Port,User,Password);
   FTPФайл = Сервер.НайтиФайлы("/public_html/Catalogue/Data/Image/",СтароеИмя+".jpg",Истина);
   Если FTPФайл.Количество() > 0 Тогда
      КопироватьФайл(FTPФайл[0].ПолноеИмя,FTPФайл[0].Путь+ЭтотОбъект.ИмяФайла+".jpg");
      УдалитьФайлы(Файлы[0].Путь,Файлы[0].Имя);
   КонецЕсли;
КонецПроцедуры


Оффлайн Фесс

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-12-15
  • Сайт: 
  • Профессия: Программист 1С
Re: FTPСоединение
« Ответ #1: 15 Дек 2011, 13:42 »
Процедура ИзменитьНаФТПНажатие(Элемент)
   Server = "platina-kostroma.ru";
   Port=21;
   User="cp349951";
   Password="icFHwcap";
   Сервер = Новый FTPСоединение(Server,Port,User,Password);
   FTPФайл = Сервер.НайтиФайлы("/public_html/Catalogue/Data/Image/01/",СтароеИмя+".jpg");
   Если FTPФайл.Количество() > 0 Тогда
      КопироватьФайл(FTPФайл[0].ПолноеИмя,FTPФайл[0].Путь+ЭтотОбъект.ИмяФайла+".jpg");
      //Сервер.Записать("/public_html/Catalogue/Data/Image/01/01011112022000023.jpg",FTPФайл[0].Путь+ЭтотОбъект.ИмяФайла+".jpg");
   //   УдалитьФайлы(Файлы[0].Путь,Файлы[0].Имя);
   КонецЕсли;
КонецПроцедуры

Оффлайн Фесс

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-12-15
  • Сайт: 
  • Профессия: Программист 1С
Re: FTPСоединение
« Ответ #2: 15 Дек 2011, 14:00 »
Процедура ИзменитьНаФТПНажатие(Элемент)
Server = "";
Port=21;
User="";
Password="";
Сервер = Новый FTPСоединение(Server,Port,User,Password);
FTPФайл = Сервер.НайтиФайлы("/public_html/Catalogue/Data/Image/01/",СтароеИмя+".jpg");
Если FTPФайл.Количество() > 0 Тогда
КопироватьФайл(FTPФайл[0].ПолноеИмя,FTPФайл[0].Путь+ЭтотОбъект.ИмяФайла+".jpg");
УдалитьФайлы(Файлы[0].Путь,Файлы[0].Имя);
КонецЕсли;
КонецПроцедуры

Последний раз редактировалось: Admin; 17 Дек 2011, 02:39

Оффлайн Фесс

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-12-15
  • Сайт: 
  • Профессия: Программист 1С
Re: FTPСоединение
« Ответ #3: 15 Дек 2011, 14:01 »
Извиняюсь, первый раз тут, не могу в спешке нормально код вставить

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1310
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Re: FTPСоединение
« Ответ #4: 15 Дек 2011, 14:25 »
Давно с фтп работал, но на сколько помню, то там надо сначала использоватье метод УстановитьТекущийКаталог.
ЗЫ: Зря учетные данные показываете, себя же подвергаете риску...

Оффлайн Фесс

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-12-15
  • Сайт: 
  • Профессия: Программист 1С
Re: FTPСоединение
« Ответ #5: 15 Дек 2011, 14:28 »
просьба удалить сообщения кроме первого....все из-за спешки


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
170 Сообщений
alex0402
74 Сообщений
oleg-x
67 Сообщений
AIFrame AIFrame
60 Сообщений
buketov.av buketov.av
47 Сообщений
ilyay ilyay
39 Сообщений
wise wise
39 Сообщений
Анюта17
33 Сообщений
KOI8-R
32 Сообщений
Alter
30 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal