Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 12:15
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите пожалуйста новичку с отчетом!  (Прочитано 2028 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Лейсан

  • ***
  • Сообщений: 142
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-12
  • Сайт: 
  • Профессия: Ученик 1С
Делаю отчет следующим образом: Мне надо получить данные из 2 документов:Делаю набор данных-объединение:в нем 2 запроса.Отчет выводится правильно.Но одно НО!!Добавила форму выбор периода.все там прописала-но когда выбираю период-данные выводятся не за тот период который я выбрала:(как мне исправить это((


Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Отчет на СКД я так понял. Зачем объединение? Можно же из двух документов одним запросом получить. Вобщем текст запроса в студию.

Оффлайн Лейсан

  • ***
  • Сообщений: 142
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-12
  • Сайт: 
  • Профессия: Ученик 1С
//Так период выбираю
Процедура УстановитьПараметрыПериода()
Параметр = КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных("КонецПериода"));;
Параметр.Значение = КонецДня(КонПериода);
Параметр.Использование = Истина;
Параметр = КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных("НачалоПериода"));;
Параметр.Значение = НачПериода;
Параметр.Использование = Истина;
КонецПроцедуры
Процедура ПриОткрытии()
УстановитьПараметрыПериода();
КонецПроцедуры
Процедура НачПериодаПриИзменении(Элемент)
УстановитьПараметрыПериода();
КонецПроцедуры
Процедура КонПериодаПриИзменении(Элемент)
УстановитьПараметрыПериода();
КонецПроцедуры



Процедура ПериодНажатие(Элемент)
НастройкаПериода = Новый НастройкаПериода;
НастройкаПериода.УстановитьПериод(НачПериода, ?(КонПериода='0001-01-01', КонПериода, КонецДня(КонПериода)));
НастройкаПериода.РедактироватьКакИнтервал = Истина;
НастройкаПериода.РедактироватьКакПериод = Истина;
НастройкаПериода.ВариантНастройки = ВариантНастройкиПериода.Период;
Если НастройкаПериода.Редактировать() Тогда
НачПериода = НастройкаПериода.ПолучитьДатуНачала();
КонПериода = НастройкаПериода.ПолучитьДатуОкончания();
КонецЕсли;
УстановитьПараметрыПериода();
   // Вставить содержимое обработчика.
КонецПроцедуры

//Выбор данных из документа событие
ВЫБРАТЬ
   Событие.Ссылка КАК ДокументСобытие,
   Событие.ВидСобытия,
   Событие.Контрагент,
   Событие.НачалоСобытия,
   Событие.ОкончаниеСобытия,
   Событие.ГруппаСобытия,
   Событие.Ответственный,
   Событие.СуммаДокумента КАК ЗапланированнаяСумма
ИЗ
   Документ.Событие КАК Событие

//Выбор данных из документа Счет на оплату
ВЫБРАТЬ
   СчетНаОплатуПокупателю.Ссылка КАК ДокументСчет,
   СчетНаОплатуПокупателю.ДатаОплаты,
   СчетНаОплатуПокупателю.Контрагент КАК Контрагент,
   СчетНаОплатуПокупателю.Ответственный КАК Ответственный,
   СчетНаОплатуПокупателю.СуммаДокумента КАК СуммаДокументаСчет,
   СчетНаОплатуПокупателю.СуммаОплаты
ИЗ
   Документ.СчетНаОплатуПокупателю КАК СчетНаОплатуПокупателю


отчет у меня не сложный.но как новичку встретились сложности.спасибо за помощь

Оффлайн Лейсан

  • ***
  • Сообщений: 142
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-12
  • Сайт: 
  • Профессия: Ученик 1С
да.отчет на скд

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Ну в запросе условие добавь попробуй на отбор периода. Т.е.
ГДЕ Документ.Событие.Дата Между &НачалоПериода И &КонецПериода
Ну и по второму документу также.
ЗЫ: Код лучше оформлять тегами, так читабельнее

Оффлайн Лейсан

  • ***
  • Сообщений: 142
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-12
  • Сайт: 
  • Профессия: Ученик 1С
спасибо:)помогло:)


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4295
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5554
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5892
Последний ответ 28 Мар 2012, 13:02
от chum710
помогите разбораться в обработке документов "ЗаказТоваров"

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 10
Просмотров: 7962
Последний ответ 18 Май 2011, 09:50
от cska-fanat-kz
Помогите с созданием обработки "Работа со справочниками"

Автор ИдзумиРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3472
Последний ответ 06 Сен 2012, 15:45
от Идзуми

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 281
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal