Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 20:59
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Ошибка в коде  (Прочитано 3981 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн v_kuzmin

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 2
  • КПД: 2%
  • Регистрация: 2011-11-09
  • Сайт: 
  • Профессия: Ученик 1С
Здраствуйте!Помоги исправить ошибку в процедуре я точно не знаю как её назвать и что писать в скобочках и зачем это вообще)))))

Процедура выводСообщения (Элемент)
Если Товары.Сумма>1000 Тогда
Сообщить("Возможна бесплатная доставка", СтатусСообщения.Важное);
КонецЕсли;
Товары.Сумма<1000 тогда
КонецПроцедуры


Оффлайн Vit1501

  • ****
  • Сообщений: 360
  • РЕПУТАЦИЯ: 60
  • КПД: 17%
  • Регистрация: 2010-06-05
  • Сайт: 
  • Профессия: Программист 1С
Re: Ошибка в коде
« Ответ #1: 12 Дек 2011, 16:40 »
Первое что нужно сделать - определиться "зачем это воообще)))", т е что процедура должна делать. И уж от этого отталкиваться.

Оффлайн v_kuzmin

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 2
  • КПД: 2%
  • Регистрация: 2011-11-09
  • Сайт: 
  • Профессия: Ученик 1С
Re: Ошибка в коде
« Ответ #2: 12 Дек 2011, 16:42 »
процедура должна выводить сообщение если сумма документа больше 1000

Оффлайн Vit1501

  • ****
  • Сообщений: 360
  • РЕПУТАЦИЯ: 60
  • КПД: 17%
  • Регистрация: 2010-06-05
  • Сайт: 
  • Профессия: Программист 1С
Re: Ошибка в коде
« Ответ #3: 12 Дек 2011, 16:50 »
Если процедура в модуле объекта самого документа находится, то параметры (Это то что в скобочках находится) ей  вообще не нужны.
 
Процедура выводСообщения () Экспорт
Если Товары.Итог("Сумма")>1000 Тогда
Сообщить("Возможна бесплатная доставка", СтатусСообщения.Важное);
КонецЕсли;
КонецПроцедуры

Если же процедура где то в общем модуле находится Тогда в качестве параметра нужно передавать ссылку на этот документ.

Процедура выводСообщения (Док) Экспорт
Если Док.Товары.Итог("Сумма")>1000 Тогда
Сообщить("Возможна бесплатная доставка", СтатусСообщения.Важное);
КонецЕсли;
КонецПроцедуры

Оффлайн v_kuzmin

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 2
  • КПД: 2%
  • Регистрация: 2011-11-09
  • Сайт: 
  • Профессия: Ученик 1С
Re: Ошибка в коде
« Ответ #4: 12 Дек 2011, 16:54 »
я попробовал  написать в модуле объекта сообщение не выводится((

Оффлайн Vit1501

  • ****
  • Сообщений: 360
  • РЕПУТАЦИЯ: 60
  • КПД: 17%
  • Регистрация: 2010-06-05
  • Сайт: 
  • Профессия: Программист 1С
Re: Ошибка в коде
« Ответ #5: 12 Дек 2011, 17:12 »
синтаксические ошибки появляются? поставь точку останова, проверь вызывается ли вообще эта процедура, заходит ли в внутрь условия если

Оффлайн v_kuzmin

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 2
  • КПД: 2%
  • Регистрация: 2011-11-09
  • Сайт: 
  • Профессия: Ученик 1С
Re: Ошибка в коде
« Ответ #6: 12 Дек 2011, 17:16 »
синтаксических нет.не совсем понимаю  как в 1с точку останова сделать.вроде я её поставил а как листать?

Оффлайн Vit1501

  • ****
  • Сообщений: 360
  • РЕПУТАЦИЯ: 60
  • КПД: 17%
  • Регистрация: 2010-06-05
  • Сайт: 
  • Профессия: Программист 1С
Re: Ошибка в коде
« Ответ #7: 12 Дек 2011, 17:25 »
В какой момент это сообщение должно выводиться? при записи? при проведении?

Оффлайн v_kuzmin

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 2
  • КПД: 2%
  • Регистрация: 2011-11-09
  • Сайт: 
  • Профессия: Ученик 1С
Re: Ошибка в коде
« Ответ #8: 12 Дек 2011, 17:28 »
при оформлении документа «Расходная», в случае, если сумма покупки превышает 1000 рублей, должно выдаваться сообщение о возможности предоставления бесплатной доставки, и только в этом случае менеджер может выписать па основании расходного документа документ «Заявка на транспорт». В данном документе указывается покупатель, контактное лицо (в диалоге должен быть виден телефон), дата и время доставки (оно может быть любым, но не раньше текущей даты). Документ не имеет табличной части, но хранит ссылку на документ основание.

Оффлайн Vit1501

  • ****
  • Сообщений: 360
  • РЕПУТАЦИЯ: 60
  • КПД: 17%
  • Регистрация: 2010-06-05
  • Сайт: 
  • Профессия: Программист 1С
Re: Ошибка в коде
« Ответ #9: 12 Дек 2011, 17:49 »
Значит в модуле объекта документа "Расходная" в предопределенной процедуре
ПриЗаписи()
Если Товары.Итог("Сумма")>1000 Тогда
Сообщить("Возможна бесплатная доставка", СтатусСообщения.Важное);
КонецЕсли;
КонецПроцедуры

а в модуле объекта документа "Заявка на транспорт" в предопределенной процедуре
ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
Если ДокументОснование.Товары.Итог("Сумма")<1000 Тогда
Отказ = истина;
КонецЕсли;
КонецПроцедуры



Теги:
 

При открытии обр-ки в "Предприятии" есть ошибка, а в "Отладке" нет

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4556
Последний ответ 21 Сен 2011, 17:35
от proofet
ошибка "Невозможно обработать параметр "ПрофильПолномочийПользователя""

Автор lindeluРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 6118
Последний ответ 06 Июн 2012, 09:15
от lindelu
Синтаксическая ошибка "В" Номенклатура.Ссылка = <<?>> В ИЕРАРХИИ(&Ссылка)

Автор maskitoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4223
Последний ответ 28 Апр 2014, 15:53
от maskito
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8559
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Ошибка при загрузке данных через (Обработка "Выгрузка и загрузка данных XML")

Автор Сергей_87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 8579
Последний ответ 26 Апр 2012, 23:08
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
AIFrame
64 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
alexandr_ll
24 Сообщений

* Кто онлайн

  • Точка Гостей: 277
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal