Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 07:12
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Напоминание о днях рождения  (Прочитано 12230 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн beztrud

Версия 8.2 управляемое приложение. Конфигурация пишется с нуля. Есть задача сделать напоминание о днях рождения. Вообще не знаю как реализовать. Видел в ЗУП, что реализовано в виде обработки, но с кодом так и не смог разобраться. Пока не понятно куда записывать сотрудников - в справочники или регистры сведений - это не принципиально, т.к. кадровый учет в конфигурации не нужен. Если можно скинте простенький пример или укажите на литературу. Заранее спасибо.


Оффлайн evialen

  • *
  • Сообщений: 35
  • РЕПУТАЦИЯ: 7
  • КПД: 20%
  • Регистрация: 2011-10-21
  • Сайт: 
  • Профессия: Программист 1С
дата рождения никак меняться со временем не будет =) поэтому хранить ее можно в справочнике "Сотрудники". Напоминание должно выскакивать после запуска приложения, из чего следует, что вызов напоминания надо прописать в процедуре "ПриНачалеРаботыСистемы" в модуле управляемого приложения. Напоминание можно по-разному реализовать, но самый примитивный метод Сообщить(""). Теперь надо отобрать сотрудников, у которых дата рождения = текущей дате (ну за исключением года канешн хД ). Это можно сделать запросом, причем отдельной функцией, которая будет вызываться в упомянутой выше процедуре. Затем обходя результат запроса, выдавать сообщение по типу "Сегодня день рожденья у.." + РезультатВыборка.Сотрудник 

Оффлайн beztrud

Делал по Чистову. Но вот как вызвать серверную процедуру?
Процедура ПриНачалеРаботыСистемы()
СформироватьНаСервере();
КонецПроцедуры

&НаСервере
Процедура СформироватьНаСервере() Экспорт
Выборка=Справочники.Сотрудники.Выбрать();
Пока Выборка.Следующий() Цикл
Если Выборка.ЭтоГруппа Тогда Продолжить;
КонецЕсли;

Если Месяц(ТекущаяДата())= Месяц(Выборка.ДатаРождения) Тогда
Сообщить(Выборка.Наименование);
КонецЕсли;
КонецЦикла;
КонецПроцедуры

В свойствах общего модуля СформироватьНаСервере() галки Сервер и вызов сервера стоят.

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
<ИмяМодуля>.СформироватьНаСервере(); ?
Кнопочка Спасибо - слева!

Оффлайн beztrud

<ИмяМодуля>.СформироватьНаСервере(); ?
О, да! Ну конечно же.....!!!!


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
50 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 118
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal