Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 23:09
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Печать Регламентированных Форм  (Прочитано 1544 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн andrew_cher

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-12-06
  • Сайт: 
  • Профессия: Программист 8.1
В 1С 8.2 Бюджетная отчетность, редакция 1.1 (1.1.4.2)  при печати формы Ф.0503127 появляется ошибка " {ОбщийМодуль.ПечатьРегламентированныхФорм.Модуль(235)}: Значение не является значением объектного типа (ПолучитьОбласть)     Макет = МакетыРаскрытия.Строка.ПолучитьОбласть();
" подскажите в чем проблема )
листинг цикла :
Пока Выборка.Следующий() Цикл
       
        МакетыРаскрытия = ЭкземплярОтчета.ВернутьМассивМакетовРаскрытия(СокрП(Выборка.КодГруппыРаскрытия)+"_"+СокрП(Выборка.КодСтроки));
        ИскомаяСтрока = СокрП(Выборка.КодГруппыРаскрытия)+"_"+СокрП(Выборка.КодСтроки)+"_РазметкаПустойСтроки";
        Обл = ТабДокВывода.Области.Найти(ИскомаяСтрока);
 
        Если МакетыРаскрытия<> Неопределено Тогда
               
            Макет = МакетыРаскрытия.Строка.ПолучитьОбласть();
       
        // точечные границы в раскрытии - условно невидимы при печати
            ЯчейкаСЛевойГраницей  = Новый Массив;
            ЯчейкаСПравойГраницей = Новый Массив;
           
                Для Каждого ОблМакета Из Макет.Области Цикл
 
                Если ОблМакета.ТипОбласти <> ТипОбластиЯчеекТабличногоДокумента.Прямоугольник Тогда
ТипОбластиЯчеекТабличногоДокумента.Прямоугольник Тогда
                    Продолжить;
                КонецЕсли;
               
                Если ОблМакета.ГраницаСлева.ТипЛинии = ТипЛинииЯчейкиТабличногоДокумента.Точечная Тогда
                    ОблМакета.ГраницаСлева = Новый Линия(ТипЛинииЯчейкиТабличногоДокумента.НетЛинии);
                    ЯчейкаСЛевойГраницей.Добавить(ОблМакета.Имя);
                КонецЕсли;
               
                Если ОблМакета.ГраницаСправа.ТипЛинии = ТипЛинииЯчейкиТабличногоДокумента.Точечная Тогда
                    ОблМакета.ГраницаСправа = Новый Линия(ТипЛинииЯчейкиТабличногоДокумента.НетЛинии);
                    ЯчейкаСПравойГраницей.Добавить(ОблМакета.Имя);
                КонецЕсли;
               
            КонецЦикла;


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Так тут скорее всего вот эта функция работает не правильно
МакетыРаскрытия = ЭкземплярОтчета.ВернутьМассивМакетовРаскрытия(СокрП(Выборка.КодГруппыРаскрытия)+"_"+СокрП(Выборка.КодСтроки));
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
170 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
49 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 296
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal