Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
25 Май 2018, 14:07
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Склонение по падежам в УПП (1с 8.2)  (Прочитано 28283 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
Есть управляемая форма (1с 8.2.), в модуле менеджера процедура печать, в печатной форме нужно сделать, чтобы выводилась ФИО в родительном падеже, пыталась сделать через процедуру общего модуля "УниверсальныеМеханизмы.Просклонять()" выводит ошибку что компонента не обнаружена, подскажите как сделать?
Тазовод)


Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1310
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С

Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
has, спасибо, это я уже читала, дело в том, что в документе приказ о приеме работает все, а в новом документе компоненту эту не видит
Тазовод)

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1310
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
А ошибка то выходит из документа или общего модуля? Тут только отладчиком смотреть наверно, если в одном работает, в другом нет.

Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
из общего модуля выходит с пустым результатом (добавила сообщение в нем - и вижу компонента не работает), я разрабатываю форму на тонком клиенте... как отладчик в нем запустить?
Тазовод)

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1310
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
А вобще где подключение ВК происходит?

Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
вот функция (она располагается в модуле менеджера и вызывается в форме печати)
Функция ПредставлениеРаботника(Работник, Падеж, Пол, ФИО) Экспорт

   ФИО = Работник;
   Падеж = 2;
   РезультатСклонения = "";
   Сообщить(глЗначениеПеременной("глКомпонентаСклоненияФИО"));
   Если УниверсальныеМеханизмы.Просклонять(глЗначениеПеременной("глКомпонентаСклоненияФИО"),ФИО, Падеж, Пол, РезультатСклонения) Тогда
      ФИО = РезультатСклонения;
   Иначе
      Сообщить("Что то случилось");
   КонецЕсли;
   
   Возврат ФИО
   
КонецФункции

Процедура ПечатьДок(ТабДок, Ссылка) Экспорт
   Перем ФамилияИО,РезФИО;
   Макет=Документы.СчетЗаТранспортноеОбслуживание.ПолучитьМакет("Макет");
   Запрос = Новый Запрос;
   Запрос.Текст =
   "ВЫБРАТЬ
   |   СчетЗаТранспортноеОбслуживание.Водитель,
   |   СчетЗаТранспортноеОбслуживание.Дата,
   |   СчетЗаТранспортноеОбслуживание.ДатаПо,
   |   СчетЗаТранспортноеОбслуживание.ДатаС,
   |   СчетЗаТранспортноеОбслуживание.Куда,
   |   СчетЗаТранспортноеОбслуживание.Номер,
   |   СчетЗаТранспортноеОбслуживание.Сумма,
   |   СчетЗаТранспортноеОбслуживание.Фирма,
   |   СчетЗаТранспортноеОбслуживание.Работы.(
   |      НомерСтроки,
   |      Работа,
   |      Еи,
   |      Км
   |   ),
   |   СчетЗаТранспортноеОбслуживание.Водитель.ИНН,
   |   СчетЗаТранспортноеОбслуживание.Водитель.ДатаРождения,
   |   СчетЗаТранспортноеОбслуживание.Км_Итог
   |ИЗ
   |   Документ.СчетЗаТранспортноеОбслуживание КАК СчетЗаТранспортноеОбслуживание
   |ГДЕ
   |   СчетЗаТранспортноеОбслуживание.Ссылка В(&Ссылка)";
   Запрос.Параметры.Вставить("Ссылка", Ссылка);
   Выборка = Запрос.Выполнить().Выбрать();
   ТабДок.Очистить();
   Пока Выборка.Следующий() Цикл
      ПредставлениеРаботника(Выборка.Водитель,2,Выборка.Водитель.Пол,ФамилияИО);
   КонецЦикла;

   //}}
КонецПроцедуры

Тазовод)

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1310
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
УПП под рукой нет, поэтому тут не подскажу. Посмотрите где идет именно подключение внешней компоненты.

Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
глЗначениеПеременной("глКомпонентаСклоненияФИО" - я подозреваю, что подключение вот тут, потому что далее вызывается уже сама процедура и компонента там определяется как - глЗначениеПеременной("глКомпонентаСклоненияФИО"
Тазовод)

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1310
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Ну глобальным поиском можно посмотреть где идет подключение NameDecl.dll


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
171 Сообщений
alex0402
74 Сообщений
oleg-x
67 Сообщений
AIFrame AIFrame
60 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
42 Сообщений
ilyay ilyay
39 Сообщений
Анюта17
33 Сообщений
KOI8-R
32 Сообщений
Alter
31 Сообщений

* Кто онлайн

  • Точка Гостей: 692
  • Точка Скрытых: 0
  • Точка Пользователей: 19
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal