Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 20:08
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Из Excel в 1с 8.2.  (Прочитано 21839 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн beztrud

Здравствуйте! Помогите пожалуйста нужно из файла Excel импортировать в табличную часть документа (ЗаказыМДФ) данные. 1с 8.2. управляемое приложение. Есть табличная часть Пленка с реквизитами Высота, Ширина, Количество, Примечание. ИмяФайла - строка неограниченной длины. Вот что делаю я:


&НаКлиенте
Процедура ИмяФайлаНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
ВыборФайла = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
ВыборФайла.ПроверятьСуществованиеФайла = Истина;
ВыборФайла.Фильтр = "Excel (*.xls)|*.xls";
ВыборФайла.МножественныйВыбор = Ложь;
Если НЕ ВыборФайла.Выбрать() Тогда
        Предупреждение("Файлы не выбраны");
Возврат
КонецЕсли;
НайтиФайл = ВыборФайла.ВыбранныеФайлы[0];
Поле = Строка(НайтиФайл);
Объект.ИмяФайла=НайтиФайл;
Объект.Пленка.Очистить();
Попытка
      Эксель = Новый COMОбъект("Excel.Application");
      Исключение
      Сообщить(ОписаниеОшибки());
      Возврат;
КонецПопытки;
Книга = Эксель.WorkBooks.Open(НайтиФайл);
Лист = Книга.WorkSheets(1);
ВсегоКолонок = Лист.Cells(1,1).SpecialCells(11).Column;
ВсегоСтрок = Лист.Cells(1,1).SpecialCells(11).Row;     
   Для Строка = 1 По ВсегоСтрок Цикл   
   Для Колонка = 1 По ВсегоКолонок Цикл
   Значение = Лист.Cells(Строка,Колонка).Value;
        СтрокаТабличнойЧасти=Объект.Пленка.Вставить("Высота");
   СтрокаТабличнойЧасти=Объект.Пленка.Вставить("Ширина");
        СтрокаТабличнойЧасти=Объект.Пленка.Вставить("Количество");
   СтрокаТабличнойЧасти=Объект.Пленка.Вставить("Примечание");
КонецЦикла;
КонецЦикла;

   Эксель.Application.Quit();
КонецПроцедуры

Пишет при отладке Несоответствие типов (параметр '1')


Оффлайн beztrud

Re: Из Excel в 1с 8.2.
« Ответ #1: 02 Дек 2011, 11:23 »
Что -то не вставилось попробую еще раз.

&НаКлиенте
Процедура ИмяФайлаНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
ВыборФайла = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
ВыборФайла.ПроверятьСуществованиеФайла = Истина;
ВыборФайла.Фильтр = "Excel (*.xls)|*.xls";
ВыборФайла.МножественныйВыбор = Ложь;
Если НЕ ВыборФайла.Выбрать() Тогда
        Предупреждение("Файлы не выбраны");
Возврат
КонецЕсли;
НайтиФайл = ВыборФайла.ВыбранныеФайлы[0];
Поле = Строка(НайтиФайл);
Объект.ИмяФайла=НайтиФайл;
Объект.Пленка.Очистить();
Попытка
      Эксель = Новый COMОбъект("Excel.Application");
      Исключение
      Сообщить(ОписаниеОшибки());
      Возврат;
КонецПопытки;
Книга = Эксель.WorkBooks.Open(НайтиФайл);
Лист = Книга.WorkSheets(1);
ВсегоКолонок = Лист.Cells(1,1).SpecialCells(11).Column;
ВсегоСтрок = Лист.Cells(1,1).SpecialCells(11).Row;     
   Для Строка = 1 По ВсегоСтрок Цикл   
   Для Колонка = 1 По ВсегоКолонок Цикл
   Значение = Лист.Cells(Строка,Колонка).Value;
    СтрокаТабличнойЧасти=Объект.Пленка.Вставить("Высота");
   СтрокаТабличнойЧасти=Объект.Пленка.Вставить("Ширина");
    СтрокаТабличнойЧасти=Объект.Пленка.Вставить("Количество");
   СтрокаТабличнойЧасти=Объект.Пленка.Вставить("Примечание");
КонецЦикла;
КонецЦикла;

   Эксель.Application.Quit();
КонецПроцедуры

Пишет при отладке несоответствие типов (параметр '1')

Оффлайн beztrud

Re: Из Excel в 1с 8.2.
« Ответ #2: 02 Дек 2011, 11:24 »
попробую по частям:


&НаКлиенте
Процедура ИмяФайлаНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
ВыборФайла = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
ВыборФайла.ПроверятьСуществованиеФайла = Истина;
ВыборФайла.Фильтр = "Excel (*.xls)|*.xls";
ВыборФайла.МножественныйВыбор = Ложь;
Если НЕ ВыборФайла.Выбрать() Тогда
        Предупреждение("Файлы не выбраны");
Возврат
КонецЕсли;
НайтиФайл = ВыборФайла.ВыбранныеФайлы[0];
Поле = Строка(НайтиФайл);
Объект.ИмяФайла=НайтиФайл;
Объект.Пленка.Очистить();
Попытка
      Эксель = Новый COMОбъект("Excel.Application");
      Исключение
      Сообщить(ОписаниеОшибки());
      Возврат;
КонецПопытки;

Оффлайн beztrud

Re: Из Excel в 1с 8.2.
« Ответ #3: 02 Дек 2011, 11:26 »
часть 2


Поле = Строка(НайтиФайл);
Объект.ИмяФайла=НайтиФайл;
Объект.Пленка.Очистить();
Попытка
      Эксель = Новый COMОбъект("Excel.Application");
      Исключение
      Сообщить(ОписаниеОшибки());
      Возврат;
КонецПопытки;
Книга = Эксель.WorkBooks.Open(НайтиФайл);
Лист = Книга.WorkSheets(1);
ВсегоКолонок = Лист.Cells(1,1).SpecialCells(11).Column;
ВсегоСтрок = Лист.Cells(1,1).SpecialCells(11).Row;     
   Для Строка = 1 По ВсегоСтрок Цикл   
   Для Колонка = 1 По ВсегоКолонок Цикл
   Значение = Лист.Cells(Строка,Колонка).Value;
    СтрокаТабличнойЧасти=Объект.Пленка.Вставить("Высота");
   СтрокаТабличнойЧасти=Объект.Пленка.Вставить("Ширина");
    СтрокаТабличнойЧасти=Объект.Пленка.Вставить("Количество");
   СтрокаТабличнойЧасти=Объект.Пленка.Вставить("Примечание");
КонецЦикла;
КонецЦикла;

   Эксель.Application.Quit();
КонецПроцедуры

Оффлайн beztrud

Re: Из Excel в 1с 8.2.
« Ответ #4: 02 Дек 2011, 11:34 »
Вот полная картинка

Оффлайн beztrud

Re: Из Excel в 1с 8.2.
« Ответ #5: 02 Дек 2011, 12:05 »
Вот что пишет

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Re: Из Excel в 1с 8.2.
« Ответ #6: 02 Дек 2011, 12:58 »
На какую строку ругается то?

Оффлайн beztrud

Re: Из Excel в 1с 8.2.
« Ответ #7: 02 Дек 2011, 13:06 »
{Документ.ФаксыМДФ.Форма.ФормаДокумента.Форма(70)}: Ошибка при вызове метода контекста (Вставить)
    СтрокаТабличнойЧасти=Объект.Пленка.Вставить("Высота");
по причине:
Несоответствие типов (параметр номер '1')

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Re: Из Excel в 1с 8.2.
« Ответ #8: 02 Дек 2011, 13:17 »
Какой тип у Пленка?

Оффлайн beztrud

Re: Из Excel в 1с 8.2.
« Ответ #9: 02 Дек 2011, 13:20 »
Пленка- табличная часть документа


Теги:
 

Круглый стол "Автоматизация учета и отчетности по МСФО: Excel против программных продуктов"

Автор mixqnРаздел Мероприятия

Ответов: 0
Просмотров: 1691
Последний ответ 10 Сен 2014, 10:25
от mixqn
работа с файлами excel открытие файла xls, чтение данных и запись нового файла xls

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2797
Последний ответ 11 Фев 2016, 12:49
от Rasty
Внешняя компонента для прямого чтения файлов Excel всех версий

Автор CrazyDaveРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 2100
Последний ответ 01 Мар 2012, 16:23
от CrazyDave
Не создается COM объект Excel.Application, хотя всё установлено и права есть

Автор ИстребительРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 7164
Последний ответ 23 Июл 2015, 14:25
от vitasw
Алгоритм загрузки изображений из excel по ссылке URL в реквизит основное изображение

Автор nikioioioРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 992
Последний ответ 23 Мар 2016, 05:43
от nikioioio

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
184 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
50 Сообщений
andron81_81
40 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 343
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal