Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Май 2018, 09:41
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Округдение до 50  (Прочитано 1514 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн sergeevds

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 38
  • КПД: 19%
  • Регистрация: 2011-08-18
  • Сайт: 
  • Профессия: Программист 8.1
Я из Минска (это просто чтобы не было вопросов по следующему факту) и вчера появилось задание предвсмотреть округление розничных ценников, сумм (у нас количества продукции отпускается до 4-го знака полсе запятой) и сумм скидок до 50 рублей. Я то уже все сделал, но вот появился вопрос. Я просто написал функцию для округления до 50:

Функция ОкруглитьЧислоДо50(Число) Экспорт

   Число = Окр(Число,-1);
   ДляОкругления = Число(Прав(Строка(Число),2));
   Если ДляОкругления<75 И ДляОкругления>25 Тогда
      Добавить = 50 - ДляОкругления;
      ИтоговоеЧисло = Число + Добавить;
   ИначеЕсли ДляОкругления>75 Тогда
      Добавить = 100 - ДляОкругления;
      ИтоговоеЧисло = Число + Добавить;
   ИначеЕсли ДляОкругления<25 Тогда
      Добавить = 0 - ДляОкругления;
      ИтоговоеЧисло = Число + Добавить;
   КонецЕсли;
   
   Возврат ИтоговоеЧисло;
   
КонецФункции

Но никак не могу избавится от мысли, что это забивание гвоздей микроскопом.
Как можно округлить число до 50 другим способом, может при помощи встроенных методов?


Онлайн has

  • Модератор
  • *****
  • Сообщений: 1310
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Re: Округдение до 50
« Ответ #1: 01 Дек 2011, 13:03 »
Вот так попробуй?
Функция ОкруглитьЧислоДо50(Число) Экспорт
   
   ИтоговоеЧисло = Окр(Число / 50);
   
   Возврат  ИтоговоеЧисло * 50;
   
КонецФункции

Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1377
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
Re: Округдение до 50
« Ответ #2: 01 Дек 2011, 14:02 »
Функция ОкруглитьЧислоДо50(Число) Экспорт
   
   ИтоговоеЧисло = Цел(Число / 50);
   
   Возврат  ИтоговоеЧисло * 50;
   
КонецФункции

Оффлайн sergeevds

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 38
  • КПД: 19%
  • Регистрация: 2011-08-18
  • Сайт: 
  • Профессия: Программист 8.1
Re: Округдение до 50
« Ответ #3: 01 Дек 2011, 18:53 »
Ну да, как я и говорил, забивание гвоздей микроскопом. Has, спасибо.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
152 Сообщений
oleg-x
64 Сообщений
alex0402
61 Сообщений
AIFrame AIFrame
52 Сообщений
wise wise
37 Сообщений
KOI8-R
33 Сообщений
buketov.av buketov.av
33 Сообщений
Alter
23 Сообщений
alexandr_ll
20 Сообщений
BuhRust
19 Сообщений

* Кто онлайн

  • Точка Гостей: 704
  • Точка Скрытых: 0
  • Точка Пользователей: 14
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal