Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 00:03
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Внимание вопрос.  (Прочитано 8228 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Лейсан

  • ***
  • Сообщений: 142
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-12
  • Сайт: 
  • Профессия: Ученик 1С
При каждой новой загрузке из дбф файла,нужно чтобы старые записи обходились,а новые записывались.Я допустила ошибку...у меня только старые записи видит,а новые нет..


Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Re: Внимание вопрос.
« Ответ #1: 30 Ноя 2011, 12:00 »
Записи видит где? В дбф или 1с? Вопрос конкретней задай.

Оффлайн Лейсан

  • ***
  • Сообщений: 142
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-12
  • Сайт: 
  • Профессия: Ученик 1С
Re: Внимание вопрос.
« Ответ #2: 30 Ноя 2011, 12:04 »
не видит записи в новые в дбф

Оффлайн sergeevds

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 38
  • КПД: 19%
  • Регистрация: 2011-08-18
  • Сайт: 
  • Профессия: Программист 8.1
Re: Внимание вопрос.
« Ответ #3: 30 Ноя 2011, 12:41 »
Третий день с дбф-кой воюешь? Я же говорил, скинь свою дбф-ку и модуль загрузки, сейчас скину емэйл в личку.

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Re: Внимание вопрос.
« Ответ #4: 30 Ноя 2011, 12:44 »
не видит записи в новые в дбф
а как определяется новая запись в файле или нет?

Оффлайн Лейсан

  • ***
  • Сообщений: 142
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-12
  • Сайт: 
  • Профессия: Ученик 1С
Re: Внимание вопрос.
« Ответ #5: 30 Ноя 2011, 13:04 »
да.третий день воюю с дбф.это мой первый проект просто.опыта маловато.сейчас скину

Оффлайн Лейсан

  • ***
  • Сообщений: 142
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-12
  • Сайт: 
  • Профессия: Ученик 1С
Re: Внимание вопрос.
« Ответ #6: 30 Ноя 2011, 13:10 »
думаю надо определять так.если уже есть запись с определенным кодом,проходим ее и смотрим,если появилась запись с новым кодом-записываем ее

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Re: Внимание вопрос.
« Ответ #7: 30 Ноя 2011, 13:51 »
думаю надо определять так.если уже есть запись с определенным кодом,проходим ее и смотрим,если появилась запись с новым кодом-записываем ее
Если в файле записей много то времени больше надо будет

Оффлайн Лейсан

  • ***
  • Сообщений: 142
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-12
  • Сайт: 
  • Профессия: Ученик 1С
Re: Внимание вопрос.
« Ответ #8: 30 Ноя 2011, 13:58 »
ДБФ.Первая();
      Пока Истина Цикл
        Номенклатура = Справочники.Номенклатура.СоздатьЭлемент();
      Код=СокрЛП(ДБФ.KOD);
         Если Код.Существует() Тогда
          Номенклатура.Наименование = СокрЛП(ДБФ.NAMEN);
        Номенклатура.Артикул = СокрЛП(ДБФ.ART);
      Номенклатура.ВидНоменклатуры = Справочники.ВидыНоменклатуры.НайтиПоНаименованию(СокрЛП(ДБФ.VID));
      Номенклатура.БазоваяЕдиницаИзмерения=Справочники.КлассификаторЕдиницИзмерения.НайтиПоНаименованию(СокрЛП(ДБФ.ED));   
      Номенклатура.Код=Код;
         КонецЕсли;
      Номенклатура.Записать();
      Если Не ДБФ.Следующая()Тогда
         Прервать;
      КонецЕсли;
      КонецЦикла;
Вот так можно?

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Re: Внимание вопрос.
« Ответ #9: 30 Ноя 2011, 14:02 »
Это откуда?
Если Код.Существует() Тогда
В синтакс-помощние посмотри, нет такого метода у строкового типа. Вобще я думал искать надо в самом файле ДБФ, а надо оказывается в справочнике. Тогда просто ищи номенклатуру по коду, если найдена, пропускаем. С другой стороны номенклатура может быть изменена, тут уже надо сравнивать другие поля. Все зависит от условия задачи.


Теги:
 

Возможно ли получение эталонного файла конфигурации *.cf из измененной стандартной, например (УТ 11.1, БП 3.0) или вопрос о том как убрать лишние доработки и привести конфигурацию базы максимально к стандартной после варварских "доработок"?

Автор kostyaomskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 9197
Последний ответ 30 Дек 2015, 22:14
от 1Cnastroika
Вопрос по РИБ "ПоОрганизации"

Автор andi_xРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 5842
Последний ответ 15 Мар 2013, 21:38
от Besart
Вопрос по "Отчеты о Розничных продажах".

Автор GerCerberРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3288
Последний ответ 26 Июл 2010, 16:06
от crow1983
Вопрос о действии кнопки "Записать"

Автор jenya1111Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 3433
Последний ответ 06 Окт 2014, 15:23
от jenya1111
Вопрос по отчету "Материалы в эксплуатации".

Автор mitauskasРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 2360
Последний ответ 04 Мар 2015, 11:07
от Дмитрий@

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
170 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
alex0402
44 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 205
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal