Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 07:09
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Доброе утро!Дайте пожалуйста дельный совет:)  (Прочитано 10612 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Лейсан

  • ***
  • Сообщений: 142
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-12
  • Сайт: 
  • Профессия: Ученик 1С
Я хочу сделать следующее:у меня есть дбф файл.В этом файле данные документа Счет на оплату покупателю.Из дбф-ки загружаю в табличную часть Товары.Товаров много.мне надо загрузить все.Получается мне надо проходить по дбф до тех пор пока номер документа значение N.Если значение не N,значит все загрузили по данному документу и переходим к следующему.У меня будет цикл в цикле.

вот моя функция загрузки счетов:


Функция загрузитьСчетаНаОплату()
      ДБФ = Новый XBase;
      ДБФ.ОткрытьФайл(ПутьКФайлу);
      ДБФ.Кодировка=КодировкаXBase.OEM;
      //Проверка на наличие записей
   Если ДБФ.КоличествоЗаписей() = 0 Тогда
      Сообщить("Файл данных пуст");
      ДБФ.ЗакрытьФайл();
      //Возврат                    
   КонецЕсли;
              //Переходим на первую строку файла
          
    ДБФ.Первая();
   
    Пока Истина Цикл

    //Запускаем цикл
   //Пока Истина Цикл
   ТекущийНомер=ДБФ.NUMBERD;
    Пока ТекущийНомер Цикл
      //Создадим новый документ
        Док = Документы.СчетНаОплатуПокупателю.СоздатьДокумент();
      
      //Заполним реквизиты
      Док.Номер=СокрЛП(ДБФ.NUMBERD);
      Док.Дата = СокрЛП(ДБФ.DATE);
      Док.Организация = Справочники.Организации.НайтиПоНаименованию(СокрЛП(ДБФ.ORG));
      Док.ВалютаДокумента =Справочники.Валюты.НайтиПоНаименованию(СокрЛП(ДБФ.VALD));
      Док.Контрагент=Справочники.Контрагенты.НайтиПоНаименованию(СокрЛП(ДБФ.KONTR));
       Док.СтруктурнаяЕдиница = Справочники.БанковскиеСчета.НайтиПоНаименованию(СокрЛП(ДБФ.NAMEBS));         
      ДоговорКонтрагента=Справочники.ДоговорыКонтрагентов.СоздатьЭлемент();
      ДоговорКонтрагента.Владелец = Док.Контрагент.Ссылка;
      ДоговорКонтрагента.Наименование = СокрЛП(ДБФ.NAMED);
       ДоговорКонтрагента.Номер = СокрЛП(ДБФ.NUMBER);
      ДоговорКонтрагента.ВидДоговора = Вычислить("Перечисления.ВидыДоговоровКонтрагентов."+СокрЛП(ДБФ.VID));
      ДоговорКонтрагента.Дата = СокрЛП(ДБФ.DATED);
      ДоговорКонтрагента.ВалютаВзаиморасчетов=Справочники.Валюты.НайтиПоНаименованию(СокрЛП(ДБФ.VAL));
       ДоговорКонтрагента.Организация =Справочники.Организации.НайтиПоНаименованию(СокрЛП(ДБФ.ORG));
      ДоговорКонтрагента.Записать();
      Док.ДоговорКонтрагента=ДоговорКонтрагента.Ссылка;
      Док.КратностьВзаиморасчетов=1;
       Банк= Справочники.Банки.СоздатьЭлемент();
       //Банк.КоррСчет=СокрЛП(ДБФ.KORS);
       //Банк.Код=СокрЛП(ДБФ.BIK);
       Банк.Наименование=СокрЛП(ДБФ.NAMEB);
       Банк.Записать();

      
       БанкСчет=Справочники.БанковскиеСчета.СоздатьЭлемент();
        БанкСчет.Владелец=Справочники.Организации.НайтиПоНаименованию(СокрЛП(ДБФ.ORG));
        БанкСчет.Банк=Справочники.Банки.НайтиПоКоду(ДБФ.BIK);
       БанкСчет.Наименование=СокрЛП(ДБФ.NAMEBS);
       БанкСчет.ВалютаДенежныхСредств=Справочники.Валюты.НайтиПоНаименованию(СокрЛП(ДБФ.VAL));
       //БанкСчет.НомерСчета=СокрЛП(ДБФ.COUNT);
       Банк.Записать();
       БанкСчет.Записать();
      
      //Заполним табличную часть "Товары"
       НоваяСтрока=Док.Товары.Добавить();
       НоваяСтрока.Номенклатура=Справочники.Номенклатура.НайтиПоНаименованию(СокрЛП(ДБФ.NOM));
       НоваяСтрока.ЕдиницаИзмерения= Справочники.КлассификаторЕдиницИзмерения.НайтиПоНаименованию(СокрЛП(ДБФ.ED));
         НоваяСтрока.Количество=СокрЛП(ДБФ.KOL);
       НоваяСтрока.Цена=СокрЛП(ДБФ.PRICE);
       НоваяСтрока.СтавкаНДС=СокрЛП(ДБФ.NDS);
       //НоваяСтрока.Записать();
       //НоваяСтрока.Сумма=НоваяСтрока.СуммаБезСкидок;
       //НоваяСтрока.СуммаНДС
       //НоваяСтрока.ЕдиницаИзмерения=Номенклатура.БазоваяЕдиницаИзмерения;
      
       //Заполним табличную часть "Оплачено"
       НоваяОплачено= Док.Оплата.Добавить();
       НоваяОплачено.ДатаОплаты=СокрЛП(ДБФ.DATEO);
       НоваяОплачено.Сумма=СокрЛП(ДБФ.SUM);
       НоваяОплачено.НомерДокумента=СокрЛП(ДБФ.NDOK);
            
       //Заполним табличную часть "Отгружено"
       НоваяОтгружено= Док.Отгрузка.Добавить();
       НоваяОтгружено.ДатаОтгрузки=СокрЛП(ДБФ.DATEOT);
       НоваяОтгружено.Номенклатура=Справочники.Номенклатура.НайтиПоНаименованию(СокрЛП(ДБФ.NOM));
       НоваяОтгружено.Количество=СокрЛП(ДБФ.KOL);
       НоваяОтгружено.Цена=СокрЛП(ДБФ.PRICE);
       НоваяОтгружено.Сумма=СокрЛП(ДБФ.SUMOT);
      
   Док.Записать();
   
   Если Не ДБФ.Следующая()Тогда
         Прервать;
      КонецЕсли;
      КонецЦикла;
   КонецЦикла;


Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
А где проверка на текущий номер? Он, если я правильно понял, сейчас у Вас должен вобще создавать на каждую строку новый документ.
Вобще лучше все данные загрузить в таблицу значений, а в ней отбор по нужному номеру документа делать, создавать документ и загружать в табличную часть.

Оффлайн Лейсан

  • ***
  • Сообщений: 142
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-12
  • Сайт: 
  • Профессия: Ученик 1С
да.на каждую строку новый документ.
вот проверка на текущий номер
НомерДок=СокрЛП(ДБФ.NUMBERD);      
Если ТекНомер=НомерДок Тогда
Док.Номер=НомерДок;

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Для простоты эксперимента так попробуй
Функция загрузитьСчетаНаОплату()
ДБФ = Новый XBase;
ДБФ.ОткрытьФайл(ПутьКФайлу);
ДБФ.Кодировка=КодировкаXBase.OEM;
//Проверка на наличие записей
Если ДБФ.КоличествоЗаписей() = 0 Тогда
Сообщить("Файл данных пуст");
ДБФ.ЗакрытьФайл();
//Возврат                   
КонецЕсли;
//Переходим на первую строку файла

ДБФ.Первая();
ПредыдущийНомер = 0; //!!!!!!!!!!!!!!!!!

Пока Истина Цикл

//Запускаем цикл
//Пока Истина Цикл
ТекущийНомер=ДБФ.NUMBERD;
//Пока ТекущийНомер Цикл   //!!!!!!!!!!!!!!
Если ТекущийНомер <> ПредыдущийНомер Тогда    //!!!!!!!!!!!!!!!!!!!
//Создадим новый документ

Док = Документы.СчетНаОплатуПокупателю.СоздатьДокумент();

//Заполним реквизиты
Док.Номер=СокрЛП(ДБФ.NUMBERD);
Док.Дата = СокрЛП(ДБФ.DATE);
Док.Организация = Справочники.Организации.НайтиПоНаименованию(СокрЛП(ДБФ.ORG));
Док.ВалютаДокумента =Справочники.Валюты.НайтиПоНаименованию(СокрЛП(ДБФ.VALD));
Док.Контрагент=Справочники.Контрагенты.НайтиПоНаименованию(СокрЛП(ДБФ.KONTR));
Док.СтруктурнаяЕдиница = Справочники.БанковскиеСчета.НайтиПоНаименованию(СокрЛП(ДБФ.NAMEBS));         
ДоговорКонтрагента=Справочники.ДоговорыКонтрагентов.СоздатьЭлемент();
ДоговорКонтрагента.Владелец = Док.Контрагент.Ссылка;
ДоговорКонтрагента.Наименование = СокрЛП(ДБФ.NAMED);
ДоговорКонтрагента.Номер = СокрЛП(ДБФ.NUMBER);
ДоговорКонтрагента.ВидДоговора = Вычислить("Перечисления.ВидыДоговоровКонтрагентов."+СокрЛП(ДБФ.VID));
ДоговорКонтрагента.Дата = СокрЛП(ДБФ.DATED);
ДоговорКонтрагента.ВалютаВзаиморасчетов=Справочники.Валюты.НайтиПоНаименованию(СокрЛП(ДБФ.VAL));
ДоговорКонтрагента.Организация =Справочники.Организации.НайтиПоНаименованию(СокрЛП(ДБФ.ORG));
ДоговорКонтрагента.Записать();
Док.ДоговорКонтрагента=ДоговорКонтрагента.Ссылка;
Док.КратностьВзаиморасчетов=1;
Банк= Справочники.Банки.СоздатьЭлемент();
//Банк.КоррСчет=СокрЛП(ДБФ.KORS);
//Банк.Код=СокрЛП(ДБФ.BIK);
Банк.Наименование=СокрЛП(ДБФ.NAMEB);
Банк.Записать();


БанкСчет=Справочники.БанковскиеСчета.СоздатьЭлемент();
БанкСчет.Владелец=Справочники.Организации.НайтиПоНаименованию(СокрЛП(ДБФ.ORG));
БанкСчет.Банк=Справочники.Банки.НайтиПоКоду(ДБФ.BIK);
БанкСчет.Наименование=СокрЛП(ДБФ.NAMEBS);
БанкСчет.ВалютаДенежныхСредств=Справочники.Валюты.НайтиПоНаименованию(СокрЛП(ДБФ.VAL));
//БанкСчет.НомерСчета=СокрЛП(ДБФ.COUNT);
Банк.Записать();
БанкСчет.Записать();
КонецЕсли;   //!!!!!!!!!!!!!!!!!!!!
//Заполним табличную часть "Товары"
НоваяСтрока=Док.Товары.Добавить();
НоваяСтрока.Номенклатура=Справочники.Номенклатура.НайтиПоНаименованию(СокрЛП(ДБФ.NOM));
НоваяСтрока.ЕдиницаИзмерения= Справочники.КлассификаторЕдиницИзмерения.НайтиПоНаименованию(СокрЛП(ДБФ.ED));
НоваяСтрока.Количество=СокрЛП(ДБФ.KOL);
НоваяСтрока.Цена=СокрЛП(ДБФ.PRICE);
НоваяСтрока.СтавкаНДС=СокрЛП(ДБФ.NDS);
//НоваяСтрока.Записать();
//НоваяСтрока.Сумма=НоваяСтрока.СуммаБезСкидок;
//НоваяСтрока.СуммаНДС
//НоваяСтрока.ЕдиницаИзмерения=Номенклатура.БазоваяЕдиницаИзмерения;

//Заполним табличную часть "Оплачено"
НоваяОплачено= Док.Оплата.Добавить();
НоваяОплачено.ДатаОплаты=СокрЛП(ДБФ.DATEO);
НоваяОплачено.Сумма=СокрЛП(ДБФ.SUM);
НоваяОплачено.НомерДокумента=СокрЛП(ДБФ.NDOK);

//Заполним табличную часть "Отгружено"
НоваяОтгружено= Док.Отгрузка.Добавить();
НоваяОтгружено.ДатаОтгрузки=СокрЛП(ДБФ.DATEOT);
НоваяОтгружено.Номенклатура=Справочники.Номенклатура.НайтиПоНаименованию(СокрЛП(ДБФ.NOM));
НоваяОтгружено.Количество=СокрЛП(ДБФ.KOL);
НоваяОтгружено.Цена=СокрЛП(ДБФ.PRICE);
НоваяОтгружено.Сумма=СокрЛП(ДБФ.SUMOT);

Если (ПредыдущийНомер<>ТекущийНомер) и (ПредыдущийНомер<>0)  тогда  //!!!!!!
Док.Записать();   //!!!!!!!!!!!!!!!!!
КонецЕсли;     //!!!!!!!!!

Если Не ДБФ.Следующая()Тогда
Прервать;
КонецЕсли;
//КонецЦикла; //!!!!!!!!!!!!!
ПредыдущийНомер = ТекущийНомер;  //!!!!!!!!!!!!!
КонецЦикла;
Кнопочка Спасибо - слева!

Оффлайн Лейсан

  • ***
  • Сообщений: 142
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-12
  • Сайт: 
  • Профессия: Ученик 1С
не корректно получается...предыдущий номер не записывается...записывается только  текущий...

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
    ..................
    ДБФ.Первая();
    ПредыдущийНомер = 0;
    Док=Неопределено;

    Пока Истина Цикл
       
        ТекущийНомер=ДБФ.NUMBERD;
        Если ТекущийНомер <> ПредыдущийНомер Тогда   
            // записываем предыдущий документ
            Если Док<>Неопределено тогда
                  Док.Записать();
            КонецЕсли;

            // переходим к следующему
            Док = Документы.СчетНаОплатуПокупателю.СоздатьДокумент();
           
            //Заполним реквизиты
            Док.Номер=СокрЛП(ДБФ.NUMBERD);
     .........
        КонецЕсли;     
            //Заполним табличную часть "Товары"
            НоваяСтрока=Док.Товары.Добавить();
            НоваяСтрока.Номенклатура=Справочники.Номенклатура.НайтиПоНаименованию(СокрЛП(ДБФ.NOM));
     .........
            НоваяОтгружено.Сумма=СокрЛП(ДБФ.SUMOT);
           
            Если Не ДБФ.Следующая()Тогда
                Прервать;
            КонецЕсли;
        ПредыдущийНомер = ТекущийНомер; 
    КонецЦикла;

    // записываем последний док
    Если Док<>Неопределено тогда
        Док.Записать();
    КонецЕсли;
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн Лейсан

  • ***
  • Сообщений: 142
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-12
  • Сайт: 
  • Профессия: Ученик 1С
 При каждой новой загрузке из дбф файла,необходимо чтобы старые записи обходились,а новые записывались.Я к если добавила условие...но похоже опять где то косяк...

Функция загрузитьСчетаНаОплату()
      ДБФ = Новый XBase;
      ДБФ.ОткрытьФайл(ПутьКФайлу);
      ДБФ.Кодировка=КодировкаXBase.OEM;
      //Проверка на наличие записей
   Если ДБФ.КоличествоЗаписей() = 0 Тогда
      Сообщить("Файл данных пуст");
      ДБФ.ЗакрытьФайл();
      //Возврат                    
   КонецЕсли;
        //Переходим на первую строку файла
      ДокСчет=Документы.СчетНаОплатуПокупателю;    
    ДБФ.Первая();
    ПредыдущийНомер = 0;
   Док=Неопределено;
   
    Пока Истина Цикл

    //Создадим новый документ
         
      ТекущийНомер=ДБФ.NUMBERD;
      Если ТекущийНомер <> ПредыдущийНомер И  ДокСчет.НайтиПоНомеру(ТекущийНомер)=ДокСчет.ПустаяСсылка() Тогда
         
         //записываем предыдущий документ
      Если Док<>Неопределено тогда
         Док.Записать();
      КонецЕсли;   

        //переходим к следующему документу
        Док = ДокСчет.СоздатьДокумент();
      Док.Номер= ТекущийНомер;
      Док.Дата = СокрЛП(ДБФ.DATE);
      Док.Организация = Справочники.Организации.НайтиПоНаименованию(СокрЛП(ДБФ.ORG));
      Док.ВалютаДокумента =Справочники.Валюты.НайтиПоНаименованию(СокрЛП(ДБФ.VALD));
      Док.Контрагент=Справочники.Контрагенты.НайтиПоНаименованию(СокрЛП(ДБФ.KONTR));
       Док.СтруктурнаяЕдиница = Справочники.БанковскиеСчета.НайтиПоНаименованию(СокрЛП(ДБФ.NAMEBS));         
      ДоговорКонтрагента=Справочники.ДоговорыКонтрагентов.СоздатьЭлемент();
      ДоговорКонтрагента.Владелец = Док.Контрагент.Ссылка;
      ДоговорКонтрагента.Наименование = СокрЛП(ДБФ.NAMED);
       ДоговорКонтрагента.Номер = СокрЛП(ДБФ.NUMBER);
      ДоговорКонтрагента.ВидДоговора = Вычислить("Перечисления.ВидыДоговоровКонтрагентов."+СокрЛП(ДБФ.VID));
      ДоговорКонтрагента.Дата = СокрЛП(ДБФ.DATED);
      ДоговорКонтрагента.ВалютаВзаиморасчетов=Справочники.Валюты.НайтиПоНаименованию(СокрЛП(ДБФ.VAL));
       ДоговорКонтрагента.Организация =Справочники.Организации.НайтиПоНаименованию(СокрЛП(ДБФ.ORG));
      ДоговорКонтрагента.Записать();
      Док.ДоговорКонтрагента=ДоговорКонтрагента.Ссылка;
      Док.КратностьВзаиморасчетов=1;
       Банк= Справочники.Банки.СоздатьЭлемент();
       //Банк.КоррСчет=СокрЛП(ДБФ.KORS);
       //Банк.Код=СокрЛП(ДБФ.BIK);
       Банк.Наименование=СокрЛП(ДБФ.NAMEB);
       Банк.Записать();

      
       БанкСчет=Справочники.БанковскиеСчета.СоздатьЭлемент();
        БанкСчет.Владелец=Справочники.Организации.НайтиПоНаименованию(СокрЛП(ДБФ.ORG));
        БанкСчет.Банк=Справочники.Банки.НайтиПоКоду(ДБФ.BIK);
       БанкСчет.Наименование=СокрЛП(ДБФ.NAMEBS);
       БанкСчет.ВалютаДенежныхСредств=Справочники.Валюты.НайтиПоНаименованию(СокрЛП(ДБФ.VAL));
       //БанкСчет.НомерСчета=СокрЛП(ДБФ.COUNT);
       Банк.Записать();
       БанкСчет.Записать();
    КонецЕсли;
   //Заполним табличную часть "Товары"

       НоваяСтрока=Док.Товары.Добавить();
       НоваяСтрока.Номенклатура=Справочники.Номенклатура.НайтиПоНаименованию(СокрЛП(ДБФ.NOM));
       НоваяСтрока.ЕдиницаИзмерения= Справочники.КлассификаторЕдиницИзмерения.НайтиПоНаименованию(СокрЛП(ДБФ.ED));
         НоваяСтрока.Количество=СокрЛП(ДБФ.KOL);
       НоваяСтрока.Цена=СокрЛП(ДБФ.PRICE);
       НоваяСтрока.СтавкаНДС=СокрЛП(ДБФ.NDS);
      
   //Заполним табличную часть "Оплачено"
       НоваяОплачено= Док.Оплата.Добавить();
       НоваяОплачено.ДатаОплаты=СокрЛП(ДБФ.DATEO);
       НоваяОплачено.Сумма=СокрЛП(ДБФ.SUM);
       НоваяОплачено.НомерДокумента=СокрЛП(ДБФ.NDOK);
            
   //Заполним табличную часть "Отгружено"
       НоваяОтгружено= Док.Отгрузка.Добавить();
       НоваяОтгружено.ДатаОтгрузки=СокрЛП(ДБФ.DATEOT);
       НоваяОтгружено.Номенклатура=Справочники.Номенклатура.НайтиПоНаименованию(СокрЛП(ДБФ.NOM));
       НоваяОтгружено.Количество=СокрЛП(ДБФ.KOL);
       НоваяОтгружено.Цена=СокрЛП(ДБФ.PRICE);
       НоваяОтгружено.Сумма=СокрЛП(ДБФ.SUMOT);
      
   Если Не ДБФ.Следующая()Тогда
         Прервать;
      КонецЕсли;
      ПредыдущийНомер = ТекущийНомер;
   КонецЦикла;
   
   //записываем последний док
   Если Док<>Неопределено тогда
      Док.Записать();
   КонецЕсли;   

         
   КонецФункции

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Так что за косяк-то? что не работает?
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн Лейсан

  • ***
  • Сообщений: 142
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-12
  • Сайт: 
  • Профессия: Ученик 1С
вот здесь по идее  Если ТекущийНомер <> ПредыдущийНомер И  ДокСчет.НайтиПоНомеру(ТекущийНомер)=ДокСчет.ПустаяСсылка() Тогда  должен обходиться документ с номером который уже записан..а он пытается заново записаться...

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Если такого документа нет, то записываем предыдущий (который у нас в Док находится), и создаем новый.
А вот если документ с номером ТекущийНомер уже есть, то лучше написать так:
      ТекущийНомер=ДБФ.NUMBERD;
      Если ТекущийНомер <> ПредыдущийНомер Тогда
         
            //записываем предыдущий документ
            Если Док<>Неопределено тогда
                  Док.Записать();
            КонецЕсли;   

            Если ДокСчет.НайтиПоНомеру(ТекущийНомер)=ДокСчет.ПустаяСсылка() тогда
                 //переходим к следующему документу
                 Док = ДокСчет.СоздатьДокумент();
                 Док.Номер= ТекущийНомер;
                 ........ // дальше все, что относится к новому
            иначе
                 Док=ДокСчет.НайтиПоНомеру(ТекущийНомер);
            конецЕсли;
    КонецЕсли;
..... // и далее по тексту
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать


Теги:
 

Подскажите пожалуйста код проверки заполнения реквизита док или реквизита ТЧ

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 968
Последний ответ 22 Июл 2016, 16:17
от Fedor_Safonchik
Здраствуйте! Помогите пожалуйста мне ! - "Очёт Валовая Прибыль"

Автор lipvРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2057
Последний ответ 05 Июн 2014, 16:30
от ADMBD
Помогите пожалуйста сделать итог по колонке "начислено"

Автор kot-1012Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2136
Последний ответ 05 Сен 2011, 10:14
от has
Перешли на 8УТ с ТИСа, работаем первую неделю. Есть много вопросов. На те, что не нашел ответы в интернете подскажите пожалуйста, опытом поделитесь))

Автор KofffeРаздел Пользователям "1С - Предприятие 8"

Ответов: 4
Просмотров: 1190
Последний ответ 02 Ноя 2015, 12:34
от AIFrame
Всем привет, подскажите пожалуйста как загрузить в БП 3.0 стандартные справочники(например виды номенклатур), буду премного благодарен

Автор DemlifeРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 693
Последний ответ 21 Мар 2016, 11:37
от Demlife

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
50 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 113
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal