Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Авг 2019, 00:57
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Синтаксис обращения из 1С 7.7 к 1С 8  (Прочитано 3762 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн wees

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-09-13
  • Сайт: 
  • Профессия: Программист 8.1
    Возникло острая необходимость загрузки из базы 1С 8 в базу 1С 7.7. Подключение идет нормально, но дальше что-то не идет. Начиная с простейшего не могу перебрать элементы справочника из 1С 8. Код следующий:

   Com = "";
   Com = СоздатьОбъект("V81.COMConnector"); 
   Состояние("Подключение к базе");    
   Попытка
      База = Com.Connect("Usr=""Закачка"";Pwd=""123"";File=""" + СокрЛП(ПутьКБазе) + """");
      ЕстьПодключение = 1;
   Исключение
      ЕстьПодключение = 0;
      Сообщить("Не удалось подключиться к базе данных!!! " + СокрЛП(ОписаниеОшибки()));
      Предупреждение("Не удалось подключиться к базе данных!!!");
      Возврат;
   КонецПопытки;   
   
   Если ЕстьПодключение = 1 Тогда 
      СпрКонтр = База.Справочники.Контрагенты;
      ВыбКонтр = СпрКонтр.Выбрать();
      Пока ВыбКонтр.Следующий() = 1 Цикл 
         Сообщить("Бла бла бла");
      КонецЦикла; 
   КонецЕсли;

   Сообщение не выводится, хотя и не ругается. В инете не нашел нормального примера по обращению из 7.7 к 8, помогите пожалуйста кто-чем может. Выгрузку в DBF и подключение из восьмерки не предлагать, просто этим будет заниматься человек которому лишнее телодвижение смерти подобно, поэтому стараюсь максимально упростить.



Оффлайн wanderer6

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2019-03-22
  • Сайт: 
  • Профессия: Программист 7.7
Надо копать через отладчик.

Последний раз редактировалось: wanderer6; 22 Мар 2019, 10:22

Оффлайн AIFrame

  • *****
  • Сообщений: 1396
  • РЕПУТАЦИЯ: 182
  • КПД: 13%
  • Регистрация: 2015-07-22
  • Сайт: 
  • Профессия: Программист 1С
Работа с объектами в другой базе через com-коннектор отличается в ряде моментов.
Например, нельзя собрать что-то по запросу в выборку. Запрос нужно предварительно создать в той базе через методы com-объекта NewObject. И работать надо в контексте "той" базы.
Пример запроса из базы в базу, где код написан только на стороне инициатора подключения.
Функция COM_ПолучитьИнформациюПоБазе()
СтруктураРозницы = Новый Структура;
СтруктураРозницы.Вставить("ВерсияИБ", ""+ РезультатПодключения.Метаданные.Имя + ": " + РезультатПодключения.Метаданные.Версия);

Запрос = РезультатПодключения.NewObject("Запрос");
Запрос.Текст =
"ВЫБРАТЬ
| КассыККМ.Наименование КАК КассаККМ,
| КассыККМ.Код КАК КассаККМКод,
| ПРЕДСТАВЛЕНИЕ(КассыККМ.Магазин) КАК Магазин,
| КассыККМ.Магазин.Код КАК МагазинКод,
| ПРЕДСТАВЛЕНИЕ(КассыККМ.Магазин.СкладПродажи) КАК Склад,
| КассыККМ.Магазин.СкладПродажи.Код КАК СкладКод,
| ПРЕДСТАВЛЕНИЕ(КассыККМ.Магазин.СкладПродажи.Организация) КАК Организация,
| КассыККМ.Магазин.СкладПродажи.Организация.ИНН КАК ОрганизацияИНН
|ИЗ
| Справочник.КассыККМ КАК КассыККМ
|
|УПОРЯДОЧИТЬ ПО
| КассыККМ.Магазин.СкладПродажи.Организация,
| КассыККМ.Магазин";
ТЧ = Запрос.Выполнить().Выгрузить();

СтруктураРозницы.Вставить("Структура", ТЧ);

Возврат СтруктураРозницы;
КонецФункции
Обрати внимание, что Запрос - это не Новый Запрос;, а com-object.NewObject("Запрос"); И запрос описан так, как если бы я писал его в конфигураторе "той базы".
Короче, переделай свою ВыбКонтр = СпрКонтр.Выбрать(); в запрос.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
117 Сообщений
alexandr_ll
58 Сообщений
LexaK
47 Сообщений
alex0402 alex0402
45 Сообщений
DmitriyF DmitriyF
29 Сообщений
MuI_I_Ika MuI_I_Ika
27 Сообщений
BuhRust
27 Сообщений
Stanislav Gareev
19 Сообщений
Funt432286
18 Сообщений
Андрей_gen_D
16 Сообщений

* Кто онлайн

  • Точка Гостей: 196
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal