Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Янв 2018, 05:28
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите посчитать общее количество купонов V8.1  (Прочитано 1541 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн informts

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-10-12
  • Сайт: 
  • Профессия: Программист 1С
Помогите еще разобраться, стоит задача подсчета количества купонов для выдачи.
Критерии выдачи таковы:
Выдаем купоны по следующей схеме:
1коэ-20% от стоимости
2коэ-30% от стоимости
4коэ-40% от стоимости
6коэ-50% от стоимости
7коэ-20% от стоимости
8коэ-20% от стоимости
10коэ-50% от стоимости
Делаю так:
мСтрокаТЧ = ЭлементыФормы.Товары.ТекущиеДанные;
    Отбор = Новый Структура;
    Отбор.Вставить("Номенклатура", мСтрокаТЧ.Номенклатура);
    Отбор.Вставить("Склад", Склад);
    Конструктор = РегистрыСведений.ПоказателиКонструкторовУслоувий;
    Коэфф = Конструктор.ПолучитьПоследнее(ТекущаяДата(), Отбор);
    Для каждого т из товары цикл
    Если (Коэфф.КонструкторУсловий.Наименование="1") ИЛИ (Коэфф.КонструкторУсловий.Наименование="7") ИЛИ (Коэфф.КонструкторУсловий.Наименование="8")  Тогда
   
КолКуп_20 = ОКР(мСтрокаТЧ.цена/100*20/200);
 КонецЕсли;                                                       
Если Коэфф.КонструкторУсловий.Наименование="2" Тогда
КолКуп_30 = ОКР(мСтрокаТЧ.цена/100*30/200);
 КонецЕсли;
Если Коэфф.КонструкторУсловий.Наименование="4" Тогда
КолКуп_40 = ОКР(мСтрокаТЧ.цена/100*40/200);
КонецЕсли;
Если Коэфф.КонструкторУсловий.Наименование="10" Тогда
   КолКуп_50 = ОКР(мСтрокаТЧ.цена/100*50/200);
КонецЕсли;
КонецЦикла;
И с моим опытом для меня тупик, как теперь посчитать общее кол-во? И что тут я не так делаю??


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
99 Сообщений
AIFrame
65 Сообщений
alex0402
32 Сообщений
kiksi
26 Сообщений
pavl_vs
24 Сообщений
alexandr_ll
17 Сообщений
andron81_81
16 Сообщений
Norfolk
15 Сообщений
KOI8-R
14 Сообщений
MuI_I_Ika MuI_I_Ika
13 Сообщений

* Кто онлайн

  • Точка Гостей: 120
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal