Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 10:30
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вызов форма элемента  (Прочитано 3519 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Zverff

  • ***
  • Сообщений: 108
  • РЕПУТАЦИЯ: 6
  • КПД: 6%
  • Регистрация: 2011-11-22
  • Сайт: 
  • Профессия: Программист 8.1
Есть процедура для создание создание кнопок из Справочника Номенклатура. Как написать которые он кнопки создал, при нажатие их что вышло Форма Элемента

Процедура ПервоеНажатие(Элемент)
                // Вставить содержимое обработчика.
                 текЛево = 9;
      ВыборкаСостояния = Справочники.Номенклатура.Выбрать();
         Пока ВыборкаСостояния.Следующий() Цикл
         Если ВыборкаСостояния.Родитель.Наименование = "Второе блюдо" Тогда //найдем кнопку по данному элементу
            КнопкаНаФорме = ЭлементыФормы.Найти("Код" + ВыборкаСостояния.Код);
            Если Не КнопкаНаФорме = Неопределено Тогда
                    ЭлементыФормы.Удалить(КнопкаНаФорме);
            КонецЕсли;
         КонецЕсли;
         Если ВыборкаСостояния.Родитель.Наименование = "Первое блюдо" Тогда
            текКнопка = ЭлементыФормы.Добавить(Тип("Кнопка"), "Код" + (ВыборкаСостояния.Код), Истина);
            текКнопка.Высота = 40;
            текКнопка.Ширина = 70;
            текКнопка.Заголовок = (ВыборкаСостояния.Наименование);
            текКнопка.Верх = 65;
            текКнопка.Лево = текЛево;
           
            текЛево = текЛево + текКнопка.Ширина + 7;
         Иначе
            продолжить;
        КонецЕсли;
            КонецЦикла;
         Элемент.Доступность = Ложь;
             Если Элементыформы.Второе.Доступность = Ложь тогда
                      Элементыформы.Второе.Доступность = Истина;
             КонецЕсли;
 
  КонецПроцедуры
 


Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Программно действие чтоли установить?

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
По русски только текст между Процедура ... КонецПроцедуры. То что выше - не очень понятно. Переформулируй вопрос, не волнуясь, please.
Кнопочка Спасибо - слева!

Оффлайн Zverff

  • ***
  • Сообщений: 108
  • РЕПУТАЦИЯ: 6
  • КПД: 6%
  • Регистрация: 2011-11-22
  • Сайт: 
  • Профессия: Программист 8.1
Вообшем) Нужно при нажатие кнопки вышло ФормаЭлемента!

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Вообшем) Нужно при нажатие кнопки вышло ФормаЭлемента!
Куда ФормаЭлемента выйти должна? За дверь?)

Оффлайн Zverff

  • ***
  • Сообщений: 108
  • РЕПУТАЦИЯ: 6
  • КПД: 6%
  • Регистрация: 2011-11-22
  • Сайт: 
  • Профессия: Программист 8.1
Вот та кнопки Борщ, Мясной Бульон, они все созданы автоматом, точнее я в ручную эти кнопки на форму не добавлял. Теперь при нажатие этих кнопок вышло Форма элемента

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
ФормаЭлемента = СсылкаНаБорщ.ПолучитьФорму("ФормаЭлемента");
ФормаЭлемента.Открыть();
СсылкаНаБорщ думаю сможешь получить из номенклатуры. И на будущее, это называется не вышла, а открыть форму текущего элемента.

Оффлайн Zverff

  • ***
  • Сообщений: 108
  • РЕПУТАЦИЯ: 6
  • КПД: 6%
  • Регистрация: 2011-11-22
  • Сайт: 
  • Профессия: Программист 8.1
В суть том что, там меню будет меняться, и мне потом приходиться каждый раз забивать процедуру на Форма Элемента что ли?

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Причем тут форма элемента? это просто переменная. Тебе надо просто получать ссылку на текущий элемент справочника, допустим можно искать по наименованию кнопки. Там же код содержится. Формат имени кнопки таков "Код" + КодЭлемента. Вот получаешь и ищи элемент номенклатуры по КодЭлемента

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Аналог R-Keeper пишешь? Здорово получается.
Кнопочка Спасибо - слева!


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 253
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal