Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
25 Июн 2018, 16:46
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Добавить дополнительное поле в отчет "Ведомость по остаткам ТМЦ"  (Прочитано 6992 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Гусейн

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-23
  • Сайт: 
  • Профессия: Ученик 1С
1С: Предприятие 7.7 (7.70.025)
Конфигурация: комплексная.

Здравствуйте!

Зовут меня Гусейн. Недавно начал пользоваться вышеупомянутым продуктом.
С 1С программированием не сталкивался ранее, но некоторые навыки в программировании есть.

Теперь собственно суть проблемы. Руководитель требует, чтобы в отчете "Ведомость по остаткам ТМЦ" можно было проследить КУДА был отдан товар, т.е. адрес в городе. Наиболее эффективным полагаю вписывать данную информацию в момент выдачи товара в поле "Комментарии" блока Реализация. И как цель задачи - реализовать вывод этого поля в отчете. Прилагаю иллюстрацию задачи.
Т.к. навыком работы ни с конструктором, ни с 1с программированием не обладаю, то прошу описать решение как можно детальнее.
Заранее благодарю.

С уважением, Гусейн Каландаров!


Оффлайн 1Cnastroika

Адрес нужно брать из реквизитов контрагента. Приблизительно так: Реализация.Контрагент.Адрес, и записать это нужно в ячейку таблицы с комментарием.

Оффлайн Гусейн

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-23
  • Сайт: 
  • Профессия: Ученик 1С
Думаю, вы не совсем поняли задачу... Адрес у одного и того же контрагента будет меняться. Контрагент - наш сотрудник... он будет сегодня брать коммутатор со склада на один адрес, завтра - роутер какая-нибудь на другой адрес... Поэтому несомненно будет необходимость регулярно указывать где-то адрес, куда берут ТМЦ со склада. А другого поля, кроме "Комментарии" я не увидел...

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Через конфигуратор открываешь отчет ВедомостьПоОстаткамТМЦ
Ищешь строку
ПечатьСтрокиДокумента(Запрос,Ном,НазваниеСекции,ПечТекстСтроки,ТекРасшифровка = "",ТекОстК,ТекОстР)
заменяешь на
ПечатьСтрокиДокумента(Запрос,Ном,НазваниеСекции,ПечТекстСтроки,ТекРасшифровка = "",ТекОстК,ТекОстР,Комментарий = "")


Процедура ПечатьСтроки(Запрос,Ном,НазваниеСекции,ПечТекстСтроки,ТекРасшифровка = "")
на
Процедура ПечатьСтроки(Запрос,Ном,НазваниеСекции,ПечТекстСтроки,ТекРасшифровка = "",Комментарий= "")

Далее ищешь
			Иначе
Если НазваниеГруппировки = "Документ" Тогда
Если (Запрос.Внутреннее = 0)
или (Запрос.КоличествоПриход <> Запрос.КоличествоРасход) Тогда 
ПечатьСтрокиДокумента(Запрос,Ном,НазваниеСекции,ПечТекстСтроки,ТекРасшифровка,ТекОстК,ТекОстР);   
КонецЕсли;
Иначе
ПечатьСтроки(Запрос,Ном,НазваниеСекции,ПечТекстСтроки,ТекРасшифровка);
КонецЕсли;
КонецЕсли;
заменяем на
			Иначе
Если НазваниеГруппировки = "Документ" Тогда
Если (Запрос.Внутреннее = 0)
или (Запрос.КоличествоПриход <> Запрос.КоличествоРасход) Тогда 
ПечатьСтрокиДокумента(Запрос,Ном,НазваниеСекции,ПечТекстСтроки,ТекРасшифровка,ТекОстК,ТекОстР,Запрос.Документ.Комментарий);   
КонецЕсли;
Иначе
ПечатьСтроки(Запрос,Ном,НазваниеСекции,ПечТекстСтроки,ТекРасшифровка);
КонецЕсли;
КонецЕсли;
Переходим в таблицу
Там в ячейку вставляем выражение Комментарий (в какой строке из 10? - ставь во все 10).
Лучше конечно для опытов сохранить отчет как внешний, и тренироваться на нем.
Код брал из Торговли и Склад - в комплексной вроде аналогичный.

Кнопочка Спасибо - слева!

Оффлайн Гусейн

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-23
  • Сайт: 
  • Профессия: Ученик 1С
Спасибо за помощь. Но возникли небольшие сложности.
Вот такое error-сообщение выдает программа:
ПечатьСтрокиДокумента(Запрос,Ном,НазваниеСекции,ПечТекстСтроки,ТекРасшифровка,ТекОстК,ТекОстР,<<?>>Запрос.Документ.Комментарий);
{Отчет.ВедомостьПоОстаткамТМЦ.Форма.Модуль(482)}: слишком много фактических параметров

И просмотрите, пожалуйста, все ли верно я поместил в таблицу.
Еще раз спасибо Вам.

Оффлайн Гусейн

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-23
  • Сайт: 
  • Профессия: Ученик 1С
P.S. Error-сообщение появляется не в окне конструктора, а при запуске отчета из приложения.

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
в таблице все верно
по ошибке пропустил самую первую замену Процедура ПечатьСтрокиДокумента(Запрос,Ном,НазваниеСекции,ПечТекстСтроки,ТекРасшифровка = "",ТекОстК,ТекОстР)
заменяешь на
Процедура ПечатьСтрокиДокумента(Запрос,Ном,НазваниеСекции,ПечТекстСтроки,ТекРасшифровка = "",ТекОстК,ТекОстР,Комментарий = "")
Нашел объявление такой процедуры в модуле?
Кнопочка Спасибо - слева!

Оффлайн Гусейн

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-23
  • Сайт: 
  • Профессия: Ученик 1С
Теперь ясно. Видимо, я не понял, что строку надо заменять именно в объявлении процедуры, т.к. начало первой замены шло без слова Процедура. Наверное внес первую замену не там, где нужно было. Исправлю и отпишусь. Спасибо

Оффлайн Гусейн

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-23
  • Сайт: 
  • Профессия: Ученик 1С
Сергей, большое Вам спасибо! Вы мне очень помогли ))
Немного поправил форматы вывода текста и рамки и получил требуемый результат! Ура!

Оффлайн Гусейн

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-23
  • Сайт: 
  • Профессия: Ученик 1С
Скриншот моей радости )))


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

AIFrame AIFrame
126 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
118 Сообщений
alexandr_ll
65 Сообщений
pavl_vs
40 Сообщений
alex0402
28 Сообщений
buketov.av buketov.av
24 Сообщений
magnifico61
21 Сообщений
wise wise
16 Сообщений
ilyay ilyay
15 Сообщений
mixei
14 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal