Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Янв 2018, 08:52
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Выборка  (Прочитано 4672 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн dmd22

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-06-20
  • Сайт: 
  • Профессия: Бухгалтер
Выборка
« Первое сообщение: 22 Ноя 2011, 21:08 »
Здравствуйте!Я только учусь 1с. Нужна помощь.....
Формируется реестр док-ов...

Процедура КнопкаВыполнитьНажатие(Кнопка)
   
МетаданныеОбъектов = Метаданные["Документы"];
ТабДокумент = новый ТабличныйДокумент;
Макет = ПолучитьМакет("Реестр");
ОбластьМакета=Макет.ПолучитьОбласть("Заголовок");
ОбластьМакета.Параметры.ТекстЗаголовка=("Реестр документов с   " + НачПериода + "  по  " + КонПериода);
ТабДокумент.Вывести(ОбластьМакета);
ОбластьМакета=Макет.ПолучитьОбласть("ШапкаТаблицы");
ОбластьСтроки=Макет.ПолучитьОбласть("Строка");
ТабДокумент.Вывести(ОбластьМакета);

НомерСтроки=0;
Для СЧ=0 по Метаданные.Документы.   Количество()-1 Цикл
   МетаданныеОбъектов=Метаданные.Документы.Получить(сч);
   Выборка=Документы[МетаданныеОбъектов.Имя].Выбрать(НачПериода,КонПериода);

   Пока Выборка.Следующий() Цикл
      Наимен=МетаданныеОбъектов.ПолноеИмя();
      НомерСтроки=НомерСтроки+1;
      Дата=Выборка.Дата;   
      Если Выборка.Проведен Тогда
         Статус="Проведен"
      ИначеЕсли (Выборка.Проведен=0) и (Выборка.ПометкаУдаления=0) Тогда
         Статус="НеПроведен"
      ИначеЕсли Выборка.ПометкаУдаления=1 Тогда
         Статус="Помечен на удаление"   
      КонецЕсли;
      
      ОбластьСтроки.Параметры.Номерстроки=НомерСтроки;
      ОбластьСтроки.Параметры.Наимен=Наимен;
      ОбластьСтроки.Параметры.Дата=Дата;
      ОбластьСтроки.Параметры.Статус=Статус;
   ТабДокумент.Вывести(ОбластьСтроки);      
   КонецЦикла;
   

   ТабДокумент.Показать();   

КонецЦикла;
   
КонецПроцедуры



Все формируется отлично,но также нужно сделать отбор флажками по проведенным\непроведенным\помеченным на удаление объектам....в 7.7 был меотд УстановитьФилтр....здесь ничего похожего найти не могу....Заранее спасибо


Оффлайн dmd22

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-06-20
  • Сайт: 
  • Профессия: Бухгалтер
Re: Выборка
« Ответ #1: 22 Ноя 2011, 21:16 »
Здравствуйте!Я только учусь 1с. Нужна помощь.....
Формируется реестр док-ов...

Процедура КнопкаВыполнитьНажатие(Кнопка)
   
МетаданныеОбъектов = Метаданные["Документы"];
ТабДокумент = новый ТабличныйДокумент;
Макет = ПолучитьМакет("Реестр");
ОбластьМакета=Макет.ПолучитьОбласть("Заголовок");
ОбластьМакета.Параметры.ТекстЗаголовка=("Реестр документов с   " + НачПериода + "  по  " + КонПериода);
ТабДокумент.Вывести(ОбластьМакета);
ОбластьМакета=Макет.ПолучитьОбласть("ШапкаТаблицы");
ОбластьСтроки=Макет.ПолучитьОбласть("Строка");
ТабДокумент.Вывести(ОбластьМакета);

НомерСтроки=0;
Для СЧ=0 по Метаданные.Документы.   Количество()-1 Цикл
   МетаданныеОбъектов=Метаданные.Документы.Получить(сч);
   Выборка=Документы[МетаданныеОбъектов.Имя].Выбрать(НачПериода,КонПериода);

   Пока Выборка.Следующий() Цикл
      Наимен=МетаданныеОбъектов.ПолноеИмя();
      НомерСтроки=НомерСтроки+1;
      Дата=Выборка.Дата;   
      Если Выборка.Проведен Тогда
         Статус="Проведен"
      ИначеЕсли (Выборка.Проведен=0) и (Выборка.ПометкаУдаления=0) Тогда
         Статус="НеПроведен"
      ИначеЕсли Выборка.ПометкаУдаления=1 Тогда
         Статус="Помечен на удаление"   
      КонецЕсли;
      
      ОбластьСтроки.Параметры.Номерстроки=НомерСтроки;
      ОбластьСтроки.Параметры.Наимен=Наимен;
      ОбластьСтроки.Параметры.Дата=Дата;
      ОбластьСтроки.Параметры.Статус=Статус;
   ТабДокумент.Вывести(ОбластьСтроки);      
   КонецЦикла;
   

   ТабДокумент.Показать();   

КонецЦикла;
   
КонецПроцедуры



Все формируется отлично,но также нужно сделать отбор флажками по проведенным\непроведенным\помеченным на удаление объектам....в 7.7 был меотд УстановитьФилтр....здесь ничего похожего найти не могу....Заранее спасибо


Оффлайн dmd22

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-06-20
  • Сайт: 
  • Профессия: Бухгалтер
Re: Выборка
« Ответ #2: 22 Ноя 2011, 21:20 »
Здравствуйте!Я только учусь 1с. Нужна помощь.....
Формируется реестр док-ов...



Процедура КнопкаВыполнитьНажатие(Кнопка)

МетаданныеОбъектов = Метаданные["Документы"];
ТабДокумент = новый ТабличныйДокумент;
Макет = ПолучитьМакет("Реестр");
ОбластьМакета=Макет.ПолучитьОбласть("Заголовок");
ОбластьМакета.Параметры.ТекстЗаголовка=("Реестр документов с   " + НачПериода + "  по  " + КонПериода);
ТабДокумент.Вывести(ОбластьМакета);
ОбластьМакета=Макет.ПолучитьОбласть("ШапкаТаблицы");
ОбластьСтроки=Макет.ПолучитьОбласть("Строка");
ТабДокумент.Вывести(ОбластьМакета);

НомерСтроки=0;
Для СЧ=0 по Метаданные.Документы. Количество()-1 Цикл
МетаданныеОбъектов=Метаданные.Документы.Получить(сч);
Выборка=Документы[МетаданныеОбъектов.Имя].Выбрать(НачПериода,КонПериода);

Пока Выборка.Следующий() Цикл
Наимен=МетаданныеОбъектов.ПолноеИмя();
НомерСтроки=НомерСтроки+1;
Дата=Выборка.Дата;
Если Выборка.Проведен Тогда
Статус="Проведен"
ИначеЕсли (Выборка.Проведен=0) и (Выборка.ПометкаУдаления=0) Тогда
Статус="НеПроведен"
ИначеЕсли Выборка.ПометкаУдаления=1 Тогда
Статус="Помечен на удаление"
КонецЕсли;

ОбластьСтроки.Параметры.Номерстроки=НомерСтроки;
ОбластьСтроки.Параметры.Наимен=Наимен;
ОбластьСтроки.Параметры.Дата=Дата;
ОбластьСтроки.Параметры.Статус=Статус;
ТабДокумент.Вывести(ОбластьСтроки);
КонецЦикла;


ТабДокумент.Показать();

КонецЦикла;

КонецПроцедуры




Все формируется отлично,но также нужно сделать отбор флажками по проведенным\непроведенным\помеченным на удаление объектам....в 7.7 был меотд УстановитьФилтр....здесь ничего похожего найти не могу....Заранее спасибо

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Re: Выборка
« Ответ #3: 22 Ноя 2011, 21:33 »
В отличии от 7.7 в 8 для таких выборок (где не нужно изменять объект) чаще запросы используются.
Кнопочка Спасибо - слева!

Оффлайн Necropunk

  • IS_EVENT_2015_оплатили
  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-10-17
  • Сайт: 
  • Профессия: Разработчик 1С
Re: Выборка
« Ответ #4: 23 Ноя 2011, 09:24 »
Да, через Метаданные выборки делать - это жесть, перепишите на запрос лучше. Если уж совсем нужно через метаданные, то что-то типа

Запрос = Новый Запрос;
Текст = "";
Для Каждого Документ Из Метаданные.Документы Цикл
    Текст = Текст + "ВЫБРАТЬ Ссылка ИЗ Документ." + Документ.Имя + "ГДЕ " + Документ.Имя + ".ПометкаУдаления = ЛОЖЬ " + " ОБЪЕДИНИТЬ";
КонецЦикла;
Запрос.Текст = Лев(Текст, СтрДлина(Текст) - СтрДлина(" ОБЪЕДИНИТЬ "));"
Выборка = Запрос.Выполнить().Выбрать();

Писал так, в поле, без проверки, могут быть неточности, адаптируйте там, как вам нужно...


Теги:
 

Заполнение столбца табличной части документа по умолчанию и выборка из табличной части.

Автор marshalbratskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1664
Последний ответ 25 Май 2016, 19:38
от marshalbratsk
выборка счетов из плана счетов

Автор markgenuineРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3481
Последний ответ 22 Ноя 2012, 12:13
от markgenuine
Выборка - "не может использоваться в данных формы"

Автор ferrari314Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1952
Последний ответ 20 Фев 2015, 09:15
от ferrari314
Выборка данных из табличной части справочника в табличную часть документа

Автор GerryРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 653
Последний ответ 01 Июн 2016, 17:57
от Rasty
Выборка и выгрузка всех документов из одной базы в другую - 1С

Автор Святослав БалашовРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 628
Последний ответ 02 Дек 2016, 21:38
от Святослав Балашов

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
102 Сообщений
AIFrame
86 Сообщений
alex0402
34 Сообщений
pavl_vs
23 Сообщений
kiksi
19 Сообщений
alexandr_ll
17 Сообщений
andron81_81
16 Сообщений
Norfolk
15 Сообщений
Artibon
13 Сообщений
LexaK
13 Сообщений

* Кто онлайн

  • Точка Гостей: 586
  • Точка Скрытых: 0
  • Точка Пользователей: 10
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal