Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
19 Янв 2018, 22:39
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Люди добрые!помогите загрузить из дбв справочник номенклатура!  (Прочитано 13640 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Лейсан

  • ***
  • Сообщений: 142
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-12
  • Сайт: 
  • Профессия: Ученик 1С
пишу обработку выгрузки из дбф в 1с номенклатуры!!вылетает с ошибкой.пишет что владелец заполнен не правильно.помогите пожалуйста исправить ошибку!вот код!
   
           ДБФ = Новый XBase;
      ДБФ.ОткрытьФайл(ПутьКФайлу);
      //Проверка на наличие записей
   Если ДБФ.КоличествоЗаписей() = 0 Тогда
      Сообщить("Файл данных пуст");
      ДБФ.ЗакрытьФайл();
      //Возврат   
   КонецЕсли;
    ДБФ.Первая();

Номенклатура = Справочники.Номенклатура.СоздатьЭлемент();
            //Номенклатура.Записать();
            Номенклатура.Наименование = СокрЛП(ДБФ.NAME);
            Номенклатура.Артикул = СокрЛП(ДБФ.ART);
                        
         //Если ЗначениеЗаполнено(ДБФ.ED) Тогда
            Ед = Справочники.ЕдиницыИзмерения.НайтиПоНаименованию(СокрЛП(ДБФ.ED),истина,Номенклатура.Ссылка);
            Если Ед.Пустая() Тогда
               Ед = Справочники.ЕдиницыИзмерения.СоздатьЭлемент();
               Ед.Владелец = Номенклатура.Ссылка;
               Ед.Наименование = СокрЛП(ДБФ.ED);
               Ед.Коэффициент = 1;            
               Ед.Записать();
               Номенклатура.Записать();
            КонецЕсли;


Оффлайн DinamoYA

  • **
  • Сообщений: 70
  • РЕПУТАЦИЯ: 7
  • КПД: 10%
  • Регистрация: 2011-04-26
  • Сайт: 
  • Профессия: Консультант 1С
По логике пока Номенклатура не записана на неё не может быть ссылки.
У вас запись номенклатуры до присвовения в Ед - закомментирована
//Номенклатура.Записать();

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2860
  • РЕПУТАЦИЯ: 547
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
ДБФ = Новый XBase;
      ДБФ.ОткрытьФайл(ПутьКФайлу);
      //Проверка на наличие записей
   Если ДБФ.КоличествоЗаписей() = 0 Тогда
      Сообщить("Файл данных пуст");
      ДБФ.ЗакрытьФайл();
      //Возврат   
   КонецЕсли;
    ДБФ.Первая();

Номенклатура = Справочники.Номенклатура.СоздатьЭлемент();
            Номенклатура.Наименование = СокрЛП(ДБФ.NAME);
            Номенклатура.Артикул = СокрЛП(ДБФ.ART);
             Номенклатура.Записать();           
         //Если ЗначениеЗаполнено(ДБФ.ED) Тогда
            Ед = Справочники.ЕдиницыИзмерения.НайтиПоНаименованию(СокрЛП(ДБФ.ED),истина,Номенклатура.Ссылка);
            Если Ед.Пустая() Тогда
               Ед = Справочники.ЕдиницыИзмерения.СоздатьЭлемент();
               Ед.Владелец = Номенклатура.Ссылка;
               Ед.Наименование = СокрЛП(ДБФ.ED);
               Ед.Коэффициент = 1;           
               Ед.Записать();
               Номенклатура.Записать();
            КонецЕсли;
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Лейсан

  • ***
  • Сообщений: 142
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-12
  • Сайт: 
  • Профессия: Ученик 1С
 Номенклатура = Справочники.Номенклатура.СоздатьЭлемент();
            Номенклатура.Наименование = СокрЛП(ДБФ.NAME);
            Номенклатура.Артикул = СокрЛП(ДБФ.ART);
             Номенклатура.Записать();           
         
         //Ед = Справочники.ЕдиницыИзмерения.НайтиПоНаименованию(СокрЛП(ДБФ.ED),истина,Номенклатура.Ссылка);
      Справочники.ЕдиницыИзмерения.СоздатьЭлемент();
      
 
 
                Номенклатура = Справочники.Номенклатура.СоздатьЭлемент();
            
            Номенклатура.Наименование = СокрЛП(ДБФ.NAME);
            Номенклатура.Артикул = СокрЛП(ДБФ.ART);
             Номенклатура.Записать();            
               Номенклатура.ВидНоменклатуры=Справочники.ВидыНоменклатуры.НайтиПоНаименованию(СокрЛП(ДБФ.VID),,);
               Номенклатура.БазоваяЕдиницаИзмерения = Справочники.КлассификаторЕдиницИзмерения.НайтиПоНаименованию(СокрЛП(ДБФ.ED),истина,Номенклатура.Ссылка);
            Справочники.ЕдиницыИзмерения.СоздатьЭлемент();
               Если  Номенклатура.БазоваяЕдиницаИзмерения.Пустая() Тогда
               Номенклатура.БазоваяЕдиницаИзмерения=Справочники.КлассификаторЕдиницИзмерения.СоздатьЭлемент();   
               Номенклатура.БазоваяЕдиницаИзмерения.Владелец = Номенклатура.Ссылка;
               Номенклатура.БазоваяЕдиницаИзмерения.Наименование = СокрЛП(ДБФ.ED);
               Номенклатура.БазоваяЕдиницаИзмерения.Коэффициент = 1;            
               Номенклатура.БазоваяЕдиницаИзмерения.Записать();
               Номенклатура.Записать();
                КонецЕсли;

Оффлайн Лейсан

  • ***
  • Сообщений: 142
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-12
  • Сайт: 
  • Профессия: Ученик 1С
ДБФ = Новый XBase;
      ДБФ.ОткрытьФайл(ПутьКФайлу);
      //Проверка на наличие записей
   Если ДБФ.КоличествоЗаписей() = 0 Тогда
      Сообщить("Файл данных пуст");
      ДБФ.ЗакрытьФайл();
      //Возврат   
   КонецЕсли;

Номенклатура = Справочники.Номенклатура.СоздатьЭлемент();
                    Номенклатура.Наименование = СокрЛП(ДБФ.NAME);
                  Номенклатура.Артикул = СокрЛП(ДБФ.ART);
                    Номенклатура.Записать();           
                   Номенклатура = Справочники.Номенклатура.СоздатьЭлемент();
               Номенклатура.Наименование = СокрЛП(ДБФ.NAME);
               Номенклатура.Артикул = СокрЛП(ДБФ.ART);
                Номенклатура.Записать();            
               Номенклатура.ВидНоменклатуры=Справочники.ВидыНоменклатуры.НайтиПоНаименованию(СокрЛП(ДБФ.VID),,);
               Номенклатура.БазоваяЕдиницаИзмерения = Справочники.КлассификаторЕдиницИзмерения.НайтиПоНаименованию(СокрЛП(ДБФ.ED),истина,Номенклатура.Ссылка);
               Если  Номенклатура.БазоваяЕдиницаИзмерения.Пустая() Тогда
               Номенклатура.БазоваяЕдиницаИзмерения=Справочники.КлассификаторЕдиницИзмерения.СоздатьЭлемент();   
               Номенклатура.БазоваяЕдиницаИзмерения.Владелец = Номенклатура.Ссылка;
               Номенклатура.БазоваяЕдиницаИзмерения.Наименование = СокрЛП(ДБФ.ED);
               Номенклатура.БазоваяЕдиницаИзмерения.Коэффициент = 1;            
               Номенклатура.БазоваяЕдиницаИзмерения.Записать();
               Номенклатура.Записать();
                КонецЕсли;
Делаю вот так.все равно ошибку бьет:что не заполнены поля единица измерения и вид!!Где сейчас я не права???

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
здесь наверное
Номенклатура.БазоваяЕдиницаИзмерения=Справочники.КлассификаторЕдиницИзмерения.СоздатьЭлемент();  
Лучше на несколько строк разбить. В одной создаем единицу, во второй - ... заполняем, затем записываем единицу, затем присваиваем номенклатуре.
Кнопочка Спасибо - слева!

Оффлайн Лейсан

  • ***
  • Сообщений: 142
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-12
  • Сайт: 
  • Профессия: Ученик 1С

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
               БазоваяЕдиницаИзмерения=Справочники.КлассификаторЕдиницИзмерения.СоздатьЭлемент();  
               БазоваяЕдиницаИзмерения.Владелец = Номенклатура.Ссылка;
               БазоваяЕдиницаИзмерения.Наименование = СокрЛП(ДБФ.ED);
               БазоваяЕдиницаИзмерения.Коэффициент = 1;            
               БазоваяЕдиницаИзмерения.Записать();
               Номенклатура.БазоваяЕдиницаИзмерения=БазоваяЕдиницаИзмерения.Ссылка;
               Номенклатура.Записать();
Кнопочка Спасибо - слева!

Оффлайн Лейсан

  • ***
  • Сообщений: 142
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-12
  • Сайт: 
  • Профессия: Ученик 1С
и так не получается к сожалению

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Внутрь условия заходит?              
Номенклатура.Записать(); лучше перенести после КонецЕсли; (иначе присвоится но не запишется)
Кнопочка Спасибо - слева!


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4392
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5652
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5983
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4579
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2037
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
101 Сообщений
AIFrame
78 Сообщений
alex0402
33 Сообщений
kiksi
30 Сообщений
pavl_vs
24 Сообщений
andron81_81
18 Сообщений
alexandr_ll
17 Сообщений
Norfolk
15 Сообщений
KOI8-R
14 Сообщений
MuI_I_Ika MuI_I_Ika
13 Сообщений

* Кто онлайн

  • Точка Гостей: 257
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal