Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 23:03
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Выгружаю справочники из dbf в 1с!!!Где моя ошибка???  (Прочитано 3013 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Лейсан

  • ***
  • Сообщений: 142
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-12
  • Сайт: 
  • Профессия: Ученик 1С
ДБФ = Новый ("XBase");
      ДБФ.ОткрытьФайл(ПутьКФайлу);
      //Проверка на наличие записей
   Если ДБФ.КоличествоЗаписей() = 0 Тогда
      Сообщить("Файл данных пуст");
      ДБФ.ЗакрытьФайл();
      Возврат
   КонецЕсли;

   Пока ДБФ.Следующая()  Цикл
      Спр= Справочники.Контрагенты.СоздатьСправочник();      
      Спр.Новый();
      Спр.Наименование = СокрЛП(ДБФ.NAME);
      Спр.ИНН = СокрЛП(ДБФ.INN);
      Спр.КПП = СокрЛП(ДБФ.KPP);
      Спр.БанковскийСчет = СокрЛП(ДБФ.COUNT);
      Спр.КодГал = СокрЛП(ДБФ.KOD);
      Спр.Записать();
       ДБФ.Следующая();
   Иначе
      Спр= Справочники.Контрагенты.СоздатьСправочник();      
      Спр.Новый();
      Спр.Наименование = СокрЛП(ДБФ.NAME);
      Спр.ИНН = СокрЛП(ДБФ.INN);
      Спр.КПП = СокрЛП(ДБФ.KPP);
      Спр.БанковскийСчет = СокрЛП(ДБФ.COUNT);
      Спр.КодГал = СокрЛП(ДБФ.KOD);
      Спр.Записать();
       ДБФ.Следующая();
   КонецЦикла;   
   КонецЕсли;   


Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Приблизительно в этих местах.

ДБФ = Новый ("XBase");
      ДБФ.ОткрытьФайл(ПутьКФайлу);
      //Проверка на наличие записей
   Если ДБФ.КоличествоЗаписей() = 0 Тогда
      Сообщить("Файл данных пуст");
      ДБФ.ЗакрытьФайл();
      Возврат
   КонецЕсли;

   Пока ДБФ.Следующая()  Цикл
      Спр= Справочники.Контрагенты.СоздатьСправочник();     
      Спр.Новый();

      Спр.Наименование = СокрЛП(ДБФ.NAME);
      Спр.ИНН = СокрЛП(ДБФ.INN);
      Спр.КПП = СокрЛП(ДБФ.KPP);
      Спр.БанковскийСчет = СокрЛП(ДБФ.COUNT);
      Спр.КодГал = СокрЛП(ДБФ.KOD);
      Спр.Записать();
       ДБФ.Следующая();
   Иначе
     Спр= Справочники.Контрагенты.СоздатьСправочник();     
      Спр.Новый();
      Спр.Наименование = СокрЛП(ДБФ.NAME);
      Спр.ИНН = СокрЛП(ДБФ.INN);
      Спр.КПП = СокрЛП(ДБФ.KPP);
      Спр.БанковскийСчет = СокрЛП(ДБФ.COUNT);
      Спр.КодГал = СокрЛП(ДБФ.KOD);
      Спр.Записать();
      ДБФ.Следующая();

   КонецЦикла;   
   КонецЕсли;   
Кнопочка Спасибо - слева!

Оффлайн Лейсан

  • ***
  • Сообщений: 142
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-12
  • Сайт: 
  • Профессия: Ученик 1С
Подскажите пожалуйста,как исправить эти ошибки...

Оффлайн Лейсан

  • ***
  • Сообщений: 142
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-12
  • Сайт: 
  • Профессия: Ученик 1С
Спр= Справочники.Контрагенты.СоздатьСправочник();     
Спр.Новый();
как можно это исправить??

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Спр= Справочники.Контрагенты.СоздатьЭлемент();    
ДБФ = Новый XBase;
Кнопочка Спасибо - слева!

Оффлайн Лейсан

  • ***
  • Сообщений: 142
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-12
  • Сайт: 
  • Профессия: Ученик 1С
ДБФ.Первая();
      Спр = Справочники.Контрагенты;
        НовыйКонтрагент = Спр.СоздатьЭлемент();
      НовыйКонтрагент.Наименование = СокрЛП(ДБФ.NAME);
      НовыйКонтрагент.ИНН = СокрЛП(ДБФ.INN);
      НовыйКонтрагент.КПП = СокрЛП(ДБФ.KPP);
      НовыйКонтрагент.Записать();
       Пока  ДБФ.Следующая()  Цикл
      Спр = Справочники.Контрагенты;
        НовыйКонтрагент = Спр.СоздатьЭлемент();
      НовыйКонтрагент.Наименование = СокрЛП(ДБФ.NAME);
      НовыйКонтрагент.ИНН = СокрЛП(ДБФ.INN);
      НовыйКонтрагент.КПП = СокрЛП(ДБФ.KPP);
      НовыйКонтрагент.Записать();
         НовыйКонтрагент.Следующая();

   КонецЦикла;   

выгрузила справочник))спасибо))


Теги:
 

При открытии обр-ки в "Предприятии" есть ошибка, а в "Отладке" нет

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4542
Последний ответ 21 Сен 2011, 17:35
от proofet
ошибка "Невозможно обработать параметр "ПрофильПолномочийПользователя""

Автор lindeluРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 6100
Последний ответ 06 Июн 2012, 09:15
от lindelu
Синтаксическая ошибка "В" Номенклатура.Ссылка = <<?>> В ИЕРАРХИИ(&Ссылка)

Автор maskitoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4208
Последний ответ 28 Апр 2014, 15:53
от maskito
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8524
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Ошибка при загрузке данных через (Обработка "Выгрузка и загрузка данных XML")

Автор Сергей_87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 8570
Последний ответ 26 Апр 2012, 23:08
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
ilyay ilyay
69 Сообщений
alex0402
54 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 221
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal