Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 03:14
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Сравнение двух документов  (Прочитано 3727 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн kox

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-19
  • Сайт: 
  • Профессия: Ученик 1С
Есть два документа и нужно сравнить табличные части этих двух документов и в новый документ так же в табличную часть вывести абсолютно все позиции из обоих документов, но не дублировать одинаковые позиции, предложите варианты алгоритма???


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Загрузи все строки найди одинаковые и удали
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн kox

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-19
  • Сайт: 
  • Профессия: Ученик 1С
Предложи как можно потом удалить??? небольшой кусочек кода напиши!! Заранее благодарен тебе!!!

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Ну примерно как то так...

НашлиСамуСебя = Ложь;
МассивДляУдаления = Новый массив;
Для каждого х из ТЧ Цикл
  Для каждого у из ТЧ Цикл
    Если НашлиСамуСебя и у.Наименование = х.Наименование и у.Цена = х.Цена Тогда
МассивДляУдаления.Добавить(х);
ИначеЕсли не НашлиСамуСебя и у.Наименование = х.Наименование и у.Цена = х.Цена Тогда
НашлиСамуСебя = Истина;
КонецЕсли;
КонецЦикла;
КонецЦикла;
Для каждого Строка из МассивДляУдаления Цикл
ТЧ.Удалить(Строка);
КонецЦикла;
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Забыл... вот так...

МассивДляУдаления = Новый массив;
Для каждого х из ТЧ Цикл
НашлиСамуСебя = Ложь;
  Для каждого у из ТЧ Цикл
    Если НашлиСамуСебя и у.Наименование = х.Наименование и у.Цена = х.Цена Тогда
МассивДляУдаления.Добавить(х);
ИначеЕсли не НашлиСамуСебя и у.Наименование = х.Наименование и у.Цена = х.Цена Тогда
НашлиСамуСебя = Истина;
КонецЕсли;
КонецЦикла;
КонецЦикла;
Для каждого Строка из МассивДляУдаления Цикл
ТЧ.Удалить(Строка);
КонецЦикла;
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Не нашел кнопку отредактировать...(((
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

Как создать нескольких документов "расчет при увольнении" на основании кадрового документа "увольнение" как Отпуска

Автор cozuРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 3181
Последний ответ 21 Мар 2015, 20:24
от дфтын
Не работает структура подчиненности документов "Требование-накладная" и "Передач

Автор sv_stas_svРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 4100
Последний ответ 10 Мар 2011, 07:36
от sv_stas_sv
готовая компонента сканирования/загрузки / распознавания бумажных документов (счетов, налоговых накладных, приходных накладных) из бумажного документа в 1с

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 176
Последний ответ 14 Ноя 2017, 10:43
от oleg-x
Реквизит "Ссылка" у справочников и документов

Автор leklerkРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3024
Последний ответ 29 Май 2013, 16:24
от leklerk
"Дубляж" документов реализации в ВзаиморасчетыКомпанииОстаткиИОбороты

Автор mspuzРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 1786
Последний ответ 24 Янв 2014, 13:55
от mspuz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
178 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 187
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal