Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 12:42
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Изменение в табличной части документа  (Прочитано 10747 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн shtrihs

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-09-26
  • Сайт: 
  • Профессия: Программист 8.1
Добрый день!

Заранее извиняюсь, так как я новичок и были похожие темы, но мне не совсем понятно.

Задача: Требуется при изменении поля дата, перебирать строки табличной части и выводить сообщение из заданной колонки. Версия 1с 8.2

Я написал

Процедура ДатаПриИзменении(Элемент)
   СтрокаТабличнойЧасти=Элементы.ПереченьНоменаклатуры.ТекущиеДанные;
   Для каждого стр из СтрокаТабличнойЧасти Цикл
   Сообщить(СтрокаТабличнойЧасти.Цена);    
   КонецЦикла;
КонецПроцедуры

При этом 1с выдает сообщение: Итератор для значения не определён. Что я делаю не так?


Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Выхотите обходить колонки таблицы в текущей строке?

Оффлайн Андрей Федотов

  • ***
  • Сообщений: 212
  • РЕПУТАЦИЯ: 36
  • КПД: 17%
  • Регистрация: 2011-07-07
  • Компания: Future IT Solutions
  • Профессия: Разработчик 1С
Сообщить(стр.Цена);
С уважением,
Андрей Федотов
Future IT Solutions

Оффлайн shtrihs

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-09-26
  • Сайт: 
  • Профессия: Программист 8.1
Выхотите обходить колонки таблицы в текущей строке?
Нет. Не в текущей. А все строки в открытом документе.

Оффлайн shtrihs

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-09-26
  • Сайт: 
  • Профессия: Программист 8.1
Сообщить(стр.Цена);
Так не работает. Хотя исправить так действительно надо. Ругается именно на строку    
Для каждого стр из СтрокаТабличнойЧасти Цикл

Оффлайн Андрей Федотов

  • ***
  • Сообщений: 212
  • РЕПУТАЦИЯ: 36
  • КПД: 17%
  • Регистрация: 2011-07-07
  • Компания: Future IT Solutions
  • Профессия: Разработчик 1С

&НаКлиенте
Процедура ПоказатьЗначенияРеквизита(Команда)
       СообщитьДанныеССервера(Объект.ТабличнаяЧасть1)
КонецПроцедуры
&НаСервере
Процедура СообщитьДанныеССервера(ТЧ1)
Для каждого Стр из ТЧ1  Цикл
      Сообщить(Стр.Реквизит1);
   КонецЦикла;
КонецПроцедуры;

Что-то такое.
С уважением,
Андрей Федотов
Future IT Solutions

Оффлайн shtrihs

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-09-26
  • Сайт: 
  • Профессия: Программист 8.1
Если не трудно, то можно на моем примере. Так как я не понял, что это разные процедуры

&НаКлиенте
Процедура ДатаПриИзменении(Элемент)
   
   СтрокаТабличнойЧасти=Элементы.ПереченьНоменаклатуры.ТекущиеДанные;
   Для каждого стр из СтрокаТабличнойЧасти Цикл
   Сообщить(Стр.Цена);    
   КонецЦикла;
КонецПроцедуры

Оффлайн shtrihs

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-09-26
  • Сайт: 
  • Профессия: Программист 8.1
Заработало. Спасибо.
Сделал по вашему образцу

Процедура ДатаПриИзменении(Элемент)
      ТЧ1= Объект.ПереченьНоменаклатуры;
      Для каждого Стр из ТЧ1  Цикл
        Сообщить(Стр.Сумма);
      КонецЦикла;
КонецПроцедуры

Задам тогда ещё один глупый вопрос по теории:
Раньше я пробовал писать, точно такую же процедуру но использовал строку ТЧ1= Элементы.ПереченьНоменаклатуры (то есть вместо Объект - Элементы). Почему так было не правильно?

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Потому что ты еще приписывал .ТекущиеДанные в этом и была ошибка.
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Вот так должно работать

Процедура ДатаПриИзменении(Элемент)
      Для каждого Стр из Элементы.ПереченьНоменаклатуры Цикл
        Сообщить(Стр.Сумма);
      КонецЦикла;
КонецПроцедуры
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4467
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7730
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4768
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8473
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Фамилия руководителя в печатных формах документа "Акт сверки", "Акт об оказании"

Автор MKozzlikРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 7329
Последний ответ 03 Фев 2012, 17:27
от Dinah

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 841
  • Точка Скрытых: 0
  • Точка Пользователей: 10
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal