Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 17:06
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Заполнение таблицы  (Прочитано 1422 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Maximka

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-12
  • Сайт: 
  • Профессия: Ученик 1С
Помогите пожалуйста, у меня такая проблема... есть таблица и мне надо что если я в 1ом столбце "КоррСчет" ввожу определенный счет, то во 2ом столбце "ВидСубконто" должно выводиться автоматически название справочника, в зависимости от счета. а в 3ем столбце "Субконто" должен открываться тот самый справочник.

Например при выборе счета 26, 2ой столбец - общехозяйственные затраты, 3ий - открытие справочника "ОбщехозЗатраты"

Код

Процедура ТабличнаяЧасть1КоррСчетПриИзменении(Элемент)
   СтрокаТабличнойЧасти = ЭлементыФормы.ТабличнаяЧасть1.ТекущиеДанные;
   Если СтрокаТабличнойЧасти.КоррСчет = ПланыСчетов.ПланСчетов.А26 Тогда
      СтрокаТабличнойЧасти.ВидСубконто = "Подразделения";
................
   КонецЕсли;


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Ну вот как бы пример. тока я это в ЗУП сделал, хз заработает в БУхии
Процедура ТЧСчетПриИзменении(Элемент)

Строка = ЭлементыФормы.ТЧ.ТекущиеДанные;
Если НЕ Строка = Неопределено Тогда
Если Не Строка.Счет.Пустая() Тогда
            Строка.Вид = Строка.Счет.ВидыСубконто[0].ВидСубконто;
Строка.СубконтоДт1 = Строка.Счет.ВидыСубконто[0].ВидСубконто.ТипЗначения.ПривестиЗначение(Строка["СубконтоДт1"]);
КонецЕсли;
КонецЕсли;

КонецПроцедуры
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

Заполнение табл. части документа из табл. части другого документа

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 11
Просмотров: 7603
Последний ответ 16 Авг 2012, 21:50
от Will
Заполнение табличной части документа табличной частью из другого документа

Автор PeaceownerРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2545
Последний ответ 30 Ноя 2011, 07:10
от has
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15965
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4209
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 642
Последний ответ 10 Май 2017, 20:44
от ilnur75

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
59 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
alexandr_ll
24 Сообщений

* Кто онлайн

  • Точка Гостей: 313
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal