Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 03:52
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Ошибка в тексте процедуры  (Прочитано 4604 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн v_kuzmin

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 2
  • КПД: 2%
  • Регистрация: 2011-11-09
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте!Я только учусь 1с и не особо разбираюсь в коде,помогите пожалуйста  помогите исправить ошибку.

Процедура ИнициализацияНажатие(Элемент)
   // Вставить содержимое обработчика.
   Построитель.Текст= "ВЫБРАТЬ
|         ПриходнаяТовары.Номенклатура КАК Номенклатура,
|         ПриходнаяТовары.Количество КАК Количество,
|         ПриходнаяТовары.Сумма КАК Сумма,
|         ЗначенияСвойств.Свойство КАК Свойство,
|         ЗначенияСвойств.Значение
|    ИЗ
|         Документ.Приходная.Товары КАК ПриходнаяТовары
|         ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ЗначенияСвойств КАК ЗначенияСвойств
| ПО ПриходнаяТовары.Номенклатура = ЗначенияСвойств.Номенклатура";
|
|ИТОГИ СУММА (Количество), СУММА(Сумма) ПО Номенклатура,Свойство";
Построитель.ЗаполнитьНастройки();

КонецПроцедуры




ОШИБКА:
Проверка клиентского приложения {Отчет.ПорядокОбхода(21,13)}: Неопознанный оператор
Номенклатура<<?>>, Номенклатура.НаименованиеНаименованиеНоменклатуры, |Количество Количество, Сумма Сумма (ИЗ Документ.Приходная.Товары (Где Ссылка.Дата Между &НачПериода И &КонПериода |УПОРЯДОЧИТЬ ПО Номенклатура.Наименование


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Платформа то какая? Упр формы??
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн v_kuzmin

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 2
  • КПД: 2%
  • Регистрация: 2011-11-09
  • Сайт: 
  • Профессия: Ученик 1С
8.1 учебная.2 не понял)

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
точку с запятой убери и ковычки
| ПО ПриходнаяТовары.Номенклатура = ЗначенияСвойств.Номенклатура";

Оффлайн v_kuzmin

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 2
  • КПД: 2%
  • Регистрация: 2011-11-09
  • Сайт: 
  • Профессия: Ученик 1С
Спасибо огромное исправил.
есть ещё вопрос опять ошибки...и опять видимо с " или ; ну или что-то в этом роде
Процедура
ВыполнитьОтчет(ТабДок,ТП,ОбходРезультата) Экспорт Перем ОбщиеИтогиСумма; Перем ОбщиеИтогиКоличество; Макет = ПолучитьМакет("ПродолжениеМакет"); Секция = Макет.ПолучитьОбласть("Шапка"); Секция.Параметры.ПериодС = Формат(КонПериода, "ДЛФ=D"); Секция.Параметры.ПериодПо = Формат(КонПериода, "ДЛФ=D"); ТабДок.Вывести(Секция); Секция = Макет.ПолучитьОбласть("Позиция"); Запрос = Новый Запрос;
ТекстЗапроса = "ВЫБРАТЬ
[Номенклатура, Номенклатура.НаименованиеНаименованиеНоменклатуры, |Количество Количество, Сумма Сумма (ИЗ Документ.Приходная.Товары (Где Ссылка.Дата Между &НачПериода И &КонПериода |УПОРЯДОЧИТЬ ПО Номенклатура.Наименование
|ИТОГИ Сумма(Количество), Сумма(Сумма) ПО ОБЩИЕ, Номенклатура ИЕРАРХИЯ |"'
Зопрос.Текст = ТекстЗапроса;
Запрос.УстановитьПараметр("НачПериода", НачПериода);
Запрос.УстановитьПараметр("КонПериода", КонецДня(КонПериода));
РезультатЗапроса = Запрос.Выполнить();
ТП.Значение=РезультатЗапроса.Выгрузить();
ТП.СоздатьКолонки();
ТабДок.НачатьАвтогруппировкуСтрок();
Номер=0;
ВыборкаОсновная = РезультатЗапроса.Выбрать(ОбходРезультата);
Пока ВыборкаОсновная.Следующий() Цикл
Секция.Параметры.Наименование = ВыборкаОсновная.НаименованиеНоменклатуры;
Секция. Параметры.Колво = ВыборкаОсновная.Количество;
Секция.Параметры.Сумма = ВыборкаОсновная.Сумма;
Секция.Параметры.Номер = Номер;
Секция.Параметры.ТипЗаписи = ВыборкаОсновная.ТипЗаписи();
Секция.Параметры.Уровень = ВыборкаОсновная.Уровень();
ТабДок.Вывести(Секция, ВыборкаОсновная.Уровень());
КонецЦикла
КонецПроцедуры      


Ошибка
Проверка клиентского приложения {Отчет.ПорядокОбхода(14,1)}: Неопознанный оператор
<<?>>[Номенклатура, Номенклатура.НаименованиеНаименованиеНоменклатуры, |Количество Количество, Сумма Сумма (ИЗ Документ.Приходная.Товары (Где Ссылка.Дата Между &НачПериода И &КонПериода |УПОРЯДОЧИТЬ ПО Номенклатура.Наименование
Проверка клиентского приложения {Отчет.ПорядокОбхода(33,11)}: Обнаружено логическое завершение исходного текста модуля
КонецЦикла<<?>>

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
<<?>>[Номенклатура,  замени <|Номенклатура,
Кнопочка Спасибо - слева!

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Кнопочка Спасибо - слева!

Оффлайн Андрей Федотов

  • ***
  • Сообщений: 212
  • РЕПУТАЦИЯ: 36
  • КПД: 17%
  • Регистрация: 2011-07-07
  • Компания: Future IT Solutions
  • Профессия: Разработчик 1С
Задам быть может глупый вопрос: вы запросы вручную пишете?
При использовании коструктора все бы вопросы сами собой отпали.
С уважением,
Андрей Федотов
Future IT Solutions

Оффлайн AntonB

  • Модератор
  • *****
  • Сообщений: 402
  • РЕПУТАЦИЯ: 74
  • КПД: 18%
  • Регистрация: 2011-05-26
  • Сайт: 
  • Профессия: Программист 8.1
да из книжки, небось, переписывает...
Предлагаю полный ИТ сервис небольшой организации в Москве (приходящий сисадмин+1С7.7,1С8.x)


Теги:
 

При открытии обр-ки в "Предприятии" есть ошибка, а в "Отладке" нет

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4534
Последний ответ 21 Сен 2011, 17:35
от proofet
ошибка "Невозможно обработать параметр "ПрофильПолномочийПользователя""

Автор lindeluРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 6095
Последний ответ 06 Июн 2012, 09:15
от lindelu
Синтаксическая ошибка "В" Номенклатура.Ссылка = <<?>> В ИЕРАРХИИ(&Ссылка)

Автор maskitoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4202
Последний ответ 28 Апр 2014, 15:53
от maskito
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8512
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Ошибка при загрузке данных через (Обработка "Выгрузка и загрузка данных XML")

Автор Сергей_87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 8567
Последний ответ 26 Апр 2012, 23:08
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
175 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
alex0402
44 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 175
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal