Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
19 Июн 2018, 04:02
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Отбор по номенклатуре  (Прочитано 9484 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Шурик_1985

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 5
  • КПД: 11%
  • )
  • Регистрация: 2011-05-14
  • Сайт: 
  • Профессия: Ученик 1С
Всем привет, нужна Ваша помощь

Проблема вот в чём. Есть Документ Расходная Накладная на ней расположен реквизит: Транспорт с типом значения Номенклатура. Так вот, при выборе реквизита транспорт должно сделать отбор по Номенклатура транспорт.

Транспорт предопределенный

Заранее спасибо!

Вот что я пробовал написать;(


&НаКлиенте
Процедура ТранспортНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)

СтандартнаяОбработка = Ложь;
ЗначениеОтбора = Новый Структура("Предопределенный",ДанныеВыбора );
ПараметрыВыбора = Новый Структура ("Отбор", ЗначениеОтбора);
Форма = ПолучитьФорму("Справочник.Номенклатура.Транспорт.ФормаВыбора", ПараметрыВыбора, Элемент);
Форма.Элементы.Список.Отображение = ОтображениеТаблицы.Список;

Форма.Открыть();
КонецПроцедуры
Усё чотко!


Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1310
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
У номенклатуры есть реквизит транспорт чтоли? Не совсем понял, но вот пример отбора
&НаКлиенте
Процедура ТранспортНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)  

   СтандартнаяОбработка = Ложь;

   ФормаВыбора= ПолучитьФорму("Справочник.Номенклатура.Форма.ФормаВыбора", ,Элемент);

   ЭлементОтбора = ФормаВыбора.Список.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
   ЭлементОтбора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("Транспорт");
   ЭлементОтбора.Использование = Истина;
   ЭлементОтбора.ПравоеЗначение = ПолучитьНоменклатураТранспорт();
   ЭлементОтбора.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;

   ФормаВыбора.Открыть();

КонецПроцедуры

&НаСервереБезКонтекста
Функция ПолучитьНоменклатураТранспорт()
   Возврат Справочники.Номенклатура.Транспорт;
КонецФункции

Оффлайн Шурик_1985

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 5
  • КПД: 11%
  • )
  • Регистрация: 2011-05-14
  • Сайт: 
  • Профессия: Ученик 1С
У номенклатуры есть реквизит транспорт чтоли? Не совсем понял, но вот пример отбора
&НаКлиенте
Процедура ТранспортНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)   

   СтандартнаяОбработка = Ложь;

   ФормаВыбора= ПолучитьФорму("Справочник.Номенклатура.Форма.ФормаВыбора", ,Элемент);

   ЭлементОтбора = ФормаВыбора.Список.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
   ЭлементОтбора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("Транспорт");
   ЭлементОтбора.Использование = Истина;
   ЭлементОтбора.ПравоеЗначение = ПолучитьНоменклатураТранспорт();
   ЭлементОтбора.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;

   ФормаВыбора.Открыть();

КонецПроцедуры

&НаСервереБезКонтекста
Функция ПолучитьНоменклатураТранспорт()
   Возврат Справочники.Номенклатура.Транспорт;
КонецФункции
У справочника номенклатуры есть предопределенный элемент "транспорт" вот по нему нужно сделать отбор!
Усё чотко!

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1310
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
т.е. выбрать этот элемент только? Тогда зачем вобще тут отбор? Просто присваивай нужному реквизиту Справочники.Номенклатура.Транспорт и все

Оффлайн Шурик_1985

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 5
  • КПД: 11%
  • )
  • Регистрация: 2011-05-14
  • Сайт: 
  • Профессия: Ученик 1С
т.е. выбрать этот элемент только? Тогда зачем вобще тут отбор? Просто присваивай нужному реквизиту Справочники.Номенклатура.Транспорт и все
Можно на примере
Усё чотко!

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1310
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
На примере чего? Смотря зачем этот реквизит транспорт и какую роль он играет.

Оффлайн Шурик_1985

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 5
  • КПД: 11%
  • )
  • Регистрация: 2011-05-14
  • Сайт: 
  • Профессия: Ученик 1С
На примере чего? Смотря зачем этот реквизит транспорт и какую роль он играет.
да просто что бы пользователю удобно было выбрать нужный транспор, что бы избежать ошибок!
а реквизит транспорт делает запись регистрах, в конце месяца по этому реквизиту делаеться отчеты!
Усё чотко!

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1310
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
если элемент транспорт предопределенный, то он будет единственным

Оффлайн AntonB

  • Модератор
  • *****
  • Сообщений: 402
  • РЕПУТАЦИЯ: 74
  • КПД: 18%
  • Регистрация: 2011-05-26
  • Сайт: 
  • Профессия: Программист 8.1
Для значений, которые может принимать реквизит, наверное, должен быть сделан отдельный справочник или перечисление... почему он из Номенклатуры то выбирается?
Предлагаю полный ИТ сервис небольшой организации в Москве (приходящий сисадмин+1С7.7,1С8.x)

Оффлайн Шурик_1985

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 5
  • КПД: 11%
  • )
  • Регистрация: 2011-05-14
  • Сайт: 
  • Профессия: Ученик 1С
Вроде получилось, зацените
&;НаКлиенте
Процедура ТранспортНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)     
    СтандартнаяОбработка = Ложь;
        стрТранспорт = Новый Структура;
ПолучитьНоменклатураТранспорт1 (стрТранспорт);

ПараметрыФормы = Новый Структура("Отбор",стрТранспорт);
    ОткрытьФорму("Справочник.Номенклатура.Форма.ФормаВыбора",ПараметрыФормы,);


КонецПроцедуры

  &;НаСервере
  Процедура ПолучитьНоменклатураТранспорт1 (стрТранспорт)
стрТранспорт.Вставить("Родитель", Справочники.Номенклатура.Транспорт);
стрТранспорт.Вставить("ЭтоГруппа", Ложь);
  КонецПроцедуры
 
  &;НаСервере

 Процедура  ПолучитьНоменклатураТранспорт(сзТранспорт)

ЗапрНаНоменклатуру = Новый запрос("ВЫБРАТЬ
| Номенклатура.Ссылка КАК Номенклатура
|ИЗ
| Справочник.Номенклатура КАК Номенклатура
|ГДЕ
| Номенклатура.Родитель = ЗНАЧЕНИЕ(Справочник.Номенклатура.Транспорт)");
Выборка = Справочники.Номенклатура.Выбрать(Справочники.Номенклатура.Транспорт);

Пока выборка.Следующий() Цикл
     сзТранспорт.Добавить(выборка.Ссылка);
КонецЦикла;

КонецПроцедуры
Усё чотко!


Теги:
 

Программный отбор в "Документы"

Автор SeolkinРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4584
Последний ответ 06 Окт 2012, 18:08
от Seolkin
Отбор при "быстром выборе"

Автор Gregory78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3775
Последний ответ 15 Фев 2015, 12:13
от Gregory78
Дин.список отбор данных - не работает код при тех же данных

Автор Аля ТинаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 390
Последний ответ 15 Дек 2017, 14:36
от alex0402
Отбор по дате проведения документа в обработке "Универсальные подбор и обработка объектов"

Автор rooflessРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 2868
Последний ответ 25 Июн 2014, 15:30
от roofless
Отключение кнопки "Отключить отбор" на панели формы списка документа

Автор AlterMannРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 11336
Последний ответ 13 Мар 2013, 09:41
от AlterMann

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
132 Сообщений
AIFrame AIFrame
124 Сообщений
alexandr_ll
55 Сообщений
alex0402
47 Сообщений
pavl_vs
47 Сообщений
buketov.av buketov.av
43 Сообщений
ilyay ilyay
36 Сообщений
trialex3
24 Сообщений
magnifico61
21 Сообщений
wise wise
15 Сообщений

* Кто онлайн

  • Точка Гостей: 239
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal