Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
27 Май 2018, 16:51
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Обработка событий в модуле приложения  (Прочитано 2364 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн nedo

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-07
  • Сайт: 
  • Профессия: Ученик 1С
Всем добрый день!
Начал проходить курс по конфигурированию, но возникла проблема при написании:

//Модуль приложения
//ПриНачалеРаботыСистемы() - проверяет время входа в систему
Процедура ПриНачалеРаботыСистемы()
    ВремяЧас=Час(ТекущаяДата());
    Если (ВремяЧас>=13) и (ВремяЧас<14) Тогда
        Ответ=Вопрос("Сейчас не рабочее время! Будете работать?",РежимДиалогаВопрос.ДаНет);
        Если Ответ=КодВозвратаДиалога.Нет Тогда ПрекратитьРаботуСистемы();
        КонецЕсли;
    КонецЕсли;
КонецПроцедуры

При запуске конфигурации ничего не происходит!в чем может быть ошибка?



Оффлайн Slin

  • Глобальный модератор
  • *****
  • Сообщений: 780
  • РЕПУТАЦИЯ: 247
  • КПД: 32%
  • Game over...
  • Регистрация: 2010-10-13
  • Сайт: 
  • Профессия: Программист 1С
ну а в какое время запускаете то?
skype: slin-dev

Оффлайн nedo

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-07
  • Сайт: 
  • Профессия: Ученик 1С
теперь понял!было не то время!
как правильно добавить, чтобы нерабочее время было с 13 до 14 и с 17 до 8?

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1310
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Процедура ПриНачалеРаботыСистемы()
    ВремяЧас=Час(ТекущаяДата());
    Если ВремяЧас=13 ИЛИ (ВремяЧас>=17 И ВремяЧас<=23) ИЛИ (ВремяЧас>=0 И ВремяЧас<8) Тогда
        Ответ=Вопрос("Сейчас не рабочее время! Будете работать?",РежимДиалогаВопрос.ДаНет);
        Если Ответ=КодВозвратаДиалога.Нет Тогда ПрекратитьРаботуСистемы();
        КонецЕсли;
    КонецЕсли;
КонецПроцедуры

Оффлайн nedo

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-07
  • Сайт: 
  • Профессия: Ученик 1С
большое спасибо!!!


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
alex0402
67 Сообщений
AIFrame AIFrame
56 Сообщений
oleg-x
56 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
41 Сообщений
ilyay ilyay
39 Сообщений
Анюта17
33 Сообщений
Alter
32 Сообщений
trialex3
30 Сообщений

* Кто онлайн

  • Точка Гостей: 245
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal