Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 13:11
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Главная книга  (Прочитано 3319 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Sonik

  • **
  • Сообщений: 76
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-03-03
  • Сайт: 
  • Профессия: Программист 8.1
 Скачал внешний  отчет Главная книга по субсчетам для 1С 8.2 Бухгалтерия 1.6 и пытаюсь переделать под свою бухгалтерию. И конечно в моей конфигурации Метод объекта не обнаружен (ПривестиКЧислу)
Что это может быть за метод, как его задать?
Если Не СтруктураПараметров.РазвернутоеСальдо Тогда

СуммаКонДт = СуммаНачДт + БухгалтерскиеОтчеты.ПривестиКЧислу(ОбщийИтог.СуммаОборотДт) - БухгалтерскиеОтчеты.ПривестиКЧислу(ОбщийИтог.СуммаОборотКт);
         СуммаКонКт = СуммаНачКт;

Иначе

ДеревоОстатков = СтруктураПараметров["ДеревоОстатков"];
КолвоСтрок = ДеревоОстатков.Строки.Количество();

Если КолвоСтрок<>0 Тогда

СтрокаОстатков = ДеревоОстатков.Строки[0];

СуммаКонДт = СтрокаОстатков.СуммаРазвернутоКонДт;
СуммаКонКт = СтрокаОстатков.СуммаРазвернутоКонКт;

Иначе
СуммаКонДт = 0;
СуммаКонКт = 0;
КонецЕсли;
КонецЕсли;

Если Не СтруктураПараметров.РазвернутоеСальдо Тогда

Если СуммаКонДт>СуммаКонКт Тогда
СуммаКонДт=СуммаКонДт-СуммаКонКт;
СуммаКонКт=0;
Иначе
СуммаКонКт=СуммаКонКт-СуммаКонДт;
СуммаКонДт=0;
КонецЕсли;

КонецЕсли;


Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Re: Главная книга
« Ответ #1: 11 Ноя 2011, 15:04 »
Это значит в общем модуле БухгалтерскиеОтчеты нет функции ПривестиКЧислу

Оффлайн Sonik

  • **
  • Сообщений: 76
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-03-03
  • Сайт: 
  • Профессия: Программист 8.1
Re: Главная книга
« Ответ #2: 14 Ноя 2011, 11:00 »
А где искать "глЗначениеПеременной"? В строке
УправлениеОтчетами.УстановитьКолонтитулыПоУмолчанию(ДокументРезультат, ЗаголовокОтчета(), Строка(глЗначениеПеременной("глТекущийПользователь")));
ругается на эту переменную, где в стандартной конфигурации эта переменная определена???

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Re: Главная книга
« Ответ #3: 14 Ноя 2011, 12:00 »
Она вроде в общем модуле ОбщегоНазначения. А вобще ставишь курсор на глЗначениеПеременной, жмешь F12 и она переходит к процедуре


Теги:
 

Ошибка при создании отчета "Кассовая книга (КО-4)"

Автор GrantmetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2342
Последний ответ 07 Авг 2012, 12:38
от Grantmet
Перенесено: Книга покупок. На выданные авансы вместо контрагента выводит "нас"

Автор progmikonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1880
Последний ответ 30 Ноя 2010, 22:36
от progmikon
Книга покупок. На выданные авансы вместо контрагента выводит "нас"

Автор mormarisРаздел Пользователям "1С - Предприятие 8"

Ответов: 4
Просмотров: 3723
Последний ответ 30 Ноя 2010, 22:53
от mormaris
кому нужна книга Андрей Габец и др Профессиональная разработка в системе 1СПредп

Автор gioto76Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 2137
Последний ответ 22 Июл 2010, 16:40
от gioto76
Книга покупок, пустые поля в Дата оплаты счета-фактуры продавца

Автор GendelfРаздел Пользователям "1С - Предприятие 8"

Ответов: 4
Просмотров: 5536
Последний ответ 04 Дек 2012, 10:35
от Gendelf

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
177 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
alex0402
46 Сообщений
AIFrame
46 Сообщений
andron81_81
41 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 774
  • Точка Скрытых: 0
  • Точка Пользователей: 12
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal