Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 20:44
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Ребят помогите!!!!  (Прочитано 3174 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн SpiritDark

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-08
  • Сайт: 
  • Профессия: Программист 8.1
 :dfbbdrfb:Вопрос первый: Создал регистр накопления по долгам контрагентов. Как в Документе "Расходная" сделать так что бы при выборе Контрагента в реквизит "Долг контрагента" записывалась Ресурс "СуммаДолга" из регистра накопления. В Табличный документ записывается а в реквизит пустое значение передается.
 :dfbbdrfb:Второй вопрос: Есть числовой учет прихода товара в упаковке. Но бывает что приход 12 упаковок и + 4 шт. Как дробное число разбить на части. Пример: пришло 12.4 упаковки. Сделать так что итог был 12 уп. + 4шт.

Заранее огромное спасибо за помощь)))


Оффлайн SpiritDark

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-08
  • Сайт: 
  • Профессия: Программист 8.1
Re: Ребят помогите!!!!
« Ответ #1: 08 Ноя 2011, 14:23 »
аппп

Оффлайн Spiriton

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-09-16
  • Сайт: 
  • Профессия: Ученик 1С
Re: Ребят помогите!!!!
« Ответ #2: 08 Ноя 2011, 17:04 »
апп

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Re: Ребят помогите!!!!
« Ответ #3: 09 Ноя 2011, 00:42 »
1. ДолгКонтрагента = СуммаДолга;
2. Вести учет отдельно упаковки от штук (2ресурса)
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн mohock

  • ***
  • Сообщений: 170
  • РЕПУТАЦИЯ: 50
  • КПД: 29%
  • Регистрация: 2010-08-12
  • Сайт: 
  • Профессия: Программист 8.1
Re: Ребят помогите!!!!
« Ответ #4: 09 Ноя 2011, 01:24 »
Уточняю:
1. Реквизит ДолгКонтрагента должен быть реквизитом формы документа, а не реквизитом объекта документ. И, соответственно вычисляться при открытии сохраненного документа и при изменении в поле Контрагент. :) Т.е. эту сумму глупо хранить в документе.
2. Ввести две единицы измерения для товара и забивать его двумя строками - одну в уп. другую в шт. (см. типовые конф.)

Оффлайн SpiritDark

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-08
  • Сайт: 
  • Профессия: Программист 8.1
Re: Ребят помогите!!!!
« Ответ #5: 09 Ноя 2011, 07:08 »
Вот код! Правильно я получаю СуммуДолга из Регистра Накопления??? А то при изменение контрагента ничего не происходит(((


&НаКлиенте
Процедура КонтрагентПриИзменении(Элемент)
      ДолгКонтрагента = ПолучитьДолг(Объект.Контрагент);
КонецПроцедуры


&НаСервере
Функция ПолучитьДолг(Контрагент)
ЗапросДолг = Новый Запрос;
ЗапросДолг.УстановитьПараметр("Контрагент",Контрагент);
ЗапросДолг.Текст = "ВЫБРАТЬ
                   |   ДолгКонтрагентаОстатки.Контрагенты,
                   |   ДолгКонтрагентаОстатки.СуммаДолгаОстаток
                   |ИЗ
                   |   РегистрНакопления.ДолгКонтрагента.Остатки КАК ДолгКонтрагентаОстатки
                   |ГДЕ
                   |   ДолгКонтрагентаОстатки.Контрагенты = &Контрагент";
               
               Результат = ЗапросДолг.Выполнить().Выбрать();
               Долг = Результат.СуммаДолгаОстаток;
               Возврат  Долг;
   
   
КонецФункции

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Re: Ребят помогите!!!!
« Ответ #6: 09 Ноя 2011, 07:19 »
&НаСервере
Функция ПолучитьДолг(Контрагент)
Долг = 0;
ЗапросДолг = Новый Запрос;
ЗапросДолг.УстановитьПараметр("Контрагент",Контрагент);
ЗапросДолг.Текст = "ВЫБРАТЬ
                   |   ДолгКонтрагентаОстатки.СуммаДолгаОстаток
                   |ИЗ
                   |   РегистрНакопления.ДолгКонтрагента.Остатки(&ДатаДок, Контрагенты = &Контрагент) КАК ДолгКонтрагентаОстатки";
              
               Запрос.УстановитьПараметр("ДатаДок", Объект.Дата);
               Запрос.УстановитьПараметр("Контрагент", Контрагент);
               Результат = ЗапросДолг.Выполнить().Выбрать();
               Если Результат .Следующий() Тогда
                   Долг = Результат.СуммаДолгаОстаток;
               КонецЕсли
               Возврат  Долг;
КонецФункции
Можно было вместе с контрагентом передать еще дату документа и выполнять НаСервереБезКонтекста, чтобы форму на сервер не передавать

Оффлайн SpiritDark

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-08
  • Сайт: 
  • Профессия: Программист 8.1
Re: Ребят помогите!!!!
« Ответ #7: 09 Ноя 2011, 07:47 »
&НаСервере
Функция ПолучитьДолг(Контрагент)
Долг = 0;
ЗапросДолг = Новый Запрос;
ЗапросДолг.УстановитьПараметр("Контрагент",Контрагент);
ЗапросДолг.Текст = "ВЫБРАТЬ
                   |   ДолгКонтрагентаОстатки.СуммаДолгаОстаток
                   |ИЗ
                   |   РегистрНакопления.ДолгКонтрагента.Остатки(&ДатаДок, Контрагенты = &Контрагент) КАК ДолгКонтрагентаОстатки";
               
               Запрос.УстановитьПараметр("ДатаДок", Объект.Дата);
               Запрос.УстановитьПараметр("Контрагент", Контрагент);
               Результат = ЗапросДолг.Выполнить().Выбрать();
               Если Результат .Следующий() Тогда
                   Долг = Результат.СуммаДолгаОстаток;
               КонецЕсли
               Возврат  Долг;
КонецФункции
Можно было вместе с контрагентом передать еще дату документа и выполнять НаСервереБезКонтекста, чтобы форму на сервер не передавать

СПАСИБО!!! Работает


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4303
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5561
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5901
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4388
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1986
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
AIFrame
64 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
alexandr_ll
24 Сообщений

* Кто онлайн

  • Точка Гостей: 279
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal