Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 16:26
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как получить значение элемента табличной части формы документа?  (Прочитано 29405 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Valery3103

  • *
  • Сообщений: 14
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-08
  • Сайт: 
  • Профессия: Ученик 1С
Сразу извиняюсь за возможно глупый и, возможно, уже задававшийся вопрос.
Версия 1С 8.2.
Итак есть форма документа,на ней табличная часть и ревкизиты: Количество, Сумма, Цена. Все число длина 10 точность 2.
Надо при наступлении события изменение поля ввода количество полю ввода сумма присвоить значение поля ввода Цена * значение поля ввода Количество.
Простым обращениям к реквизитам как в 7.7 не получается. излазала полинтернета,нигде ничего не могу найти. помогите пожалуйста! :nhsrm:


Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Если интерфейс обычный, то в событии при изменении
СтрокаТабличнойЧасти = ЭлементыФормы.ИмяТабличнойЧасти.ТекущийДанные; 
СтрокаТабличнойЧасти.Сумма = СтрокаТабличнойЧасти.Цена * СтрокаТабличнойЧасти.Количество;

Оффлайн Valery3103

  • *
  • Сообщений: 14
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-08
  • Сайт: 
  • Профессия: Ученик 1С
Если интерфейс обычный, то в событии при изменении
СтрокаТабличнойЧасти = ЭлементыФормы.ИмяТабличнойЧасти.ТекущийДанные; 
СтрокаТабличнойЧасти.Сумма = СтрокаТабличнойЧасти.Цена * СтрокаТабличнойЧасти.Количество;

не работает(( ошибок не выдает, но и в поле ввода сумма не появляется.

Оффлайн Natalia21

  • *
  • Сообщений: 32
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-06
  • Сайт: 
  • Профессия: Ученик 1С
в свойствах графы Цена и Количество надо выбрать событие ПриИзменении с этим кодом. Делала также у меня все получилось. Только возникла еще проблема:

Процедура ТабличнаяЧасть1Сумма(Элемент)
    СтрокаТабличнойЧасти = ЭлементыФормы.ТабличнаяЧасть1.ТекущиеДанные;
   СтрокаТабличнойЧасти.Сумма = СтрокаТабличнойЧасти.Цена * СтрокаТабличнойЧасти.Количество;
КонецПроцедуры

Процедура ТабличнаяЧасть1Всего (Элемент)
   СтрокаТабличнойЧасти = ЭлементыФормы.ТабличнаяЧасть1.ТекущиеДанные;
   СтрокаТабличнойЧасти.Всего = СтрокаТабличнойЧасти.Сумма + СтрокаТабличнойЧасти.НДС;
КонецПроцедуры

В этом случае не считается графа Всего. Подскажите почему? Что надо исправить?

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Не забываем прицеплять события к элементам формы!
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Valery3103

  • *
  • Сообщений: 14
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-08
  • Сайт: 
  • Профессия: Ученик 1С
Не забываем прицеплять события к элементам формы!
в свойствах графы Цена и Количество надо выбрать событие ПриИзменении с этим кодом. Делала также у меня все получилось.

Конечно это работает в версии 8.1, а в версии 8.2 уже все по-другому, я спрашивала касательно версии 8.2

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Что по другому то????
Все тоже самое!!!!
&НаКлиенте
Процедура ТЧРеквизит1ПриИзменении(Элемент)
      
   Строка = Элементы.ТЧ.ТекущиеДанные;
   Строка.Реквизит1 = Строка.Реквизит1+Строка.Реквизит2;
      
КонецПроцедуры
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
А немного подумать и почитать синтаксис помошник просто не судьба((((
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Valery3103

  • *
  • Сообщений: 14
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-08
  • Сайт: 
  • Профессия: Ученик 1С
А немного подумать и почитать синтаксис помошник просто не судьба((((
Да,не судьба(( знать бы,что искать. я ж по аналогии с Borland Delphi, а там даже близких аналогов нет, и от 7.7 отличается,я не то что синтаксис-помощник, я пол интернета перерыла, и ничего и близко нет.

Оффлайн Valery3103

  • *
  • Сообщений: 14
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-08
  • Сайт: 
  • Профессия: Ученик 1С
Что по другому то????
Все тоже самое!!!!
&НаКлиенте
Процедура ТЧРеквизит1ПриИзменении(Элемент)
      
   Строка = Элементы.ТЧ.ТекущиеДанные;
   Строка.Реквизит1 = Строка.Реквизит1+Строка.Реквизит2;
      
КонецПроцедуры

кстати,не работает( сумма не выводится, хоть синтаксических ошибок и нет. Ладно, пристану к преподавателям...


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4473
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7742
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4780
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
Фамилия руководителя в печатных формах документа "Акт сверки", "Акт об оказании"

Автор MKozzlikРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 7343
Последний ответ 03 Фев 2012, 17:27
от Dinah
Не заполняется поле "Цена" при формировании документа "Пересчет товаров"

Автор InnakechaРаздел Пользователям "1С - Предприятие 8"

Ответов: 4
Просмотров: 1081
Последний ответ 29 Дек 2016, 09:54
от Innakecha

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
184 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
40 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 694
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal