Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 05:58
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: 1С 8.1 Управление видимостью  (Прочитано 21176 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Natalia21

  • *
  • Сообщений: 32
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-06
  • Сайт: 
  • Профессия: Ученик 1С
Подскажите пожалуйста как сделать чтобы при постановке галочки, поле ввода и надпись стали невидимы. не могу разобраться как написать код для управления видимостью(((
Имя флажка - ВариантОплаты
Имя надписи - НадписьПлательщик
Имя поля ввода - Плательщик
В свойствах флажка в собитиях поставила при изменении - ВариантОплатыПриИзменении

Код:
Процедура ВариантОплатыПриИзменении (Элемент)
УправлениеВидимостьюПлательщика();
КонецПроцедуры

Процедура УправлениеВидимостьюПлательщика()
Евли ВариантОплаты = 1 Тогда
............
КонецПроцедуры

Подскажите пожалуйста как правильно написать??


Оффлайн Андрей Федотов

  • ***
  • Сообщений: 212
  • РЕПУТАЦИЯ: 36
  • КПД: 17%
  • Регистрация: 2011-07-07
  • Компания: Future IT Solutions
  • Профессия: Разработчик 1С
Зависит от того управляемая форма или нет:

1) Если форма управляемая:
Элементы.НадписьПлательщик.Видимость = Истина;
Элементы.Плательщик.Видимость = Истина;

2) Если форма обычная:
ЭлементыФормы.НадписьПлательщик.Видимость = Истина;
ЭлементыФормы.Плательщик.Видимость = Истина;

При использовании управляемой формы лучше использовать свойство Доступность, ибо при изменении значения свойства "Видимость" идёт дополнительный вызов Сервера, что не есть хорошо
С уважением,
Андрей Федотов
Future IT Solutions

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Если ВариантОплаты Тогда
     ЭлементыФормы.НадписьПлательщик.Видимость = Истина;
ЭлементыФормы.Плательщик.Видимость = Истина;
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Если ВариантОплаты Тогда
     ЭлементыФормы.НадписьПлательщик.Видимость = Истина;
     ЭлементыФормы.Плательщик.Видимость = Истина;
Иначе
     ЭлементыФормы.НадписьПлательщик.Видимость = Ложь;
     ЭлементыФормы.Плательщик.Видимость = Ложь;
КонецЕсли;
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Natalia21

  • *
  • Сообщений: 32
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-06
  • Сайт: 
  • Профессия: Ученик 1С
все, разобралась с этим, спасибо большое!
подскажите еще пожалуйста как сделать обращение к данным из справочника. Мне надо чтобы при создании новой формы некоторые поля ставились автоматически, но их можно было бы изменять... Пример:
В документе в поле ввода "ВидПлатежа" надо чтобы автоматически при создании только (а не при повторных открытиях) ставилось значение из справочника "ВидыПлатежей" - Электронно(это графа - Наименование)...
В данном справочнике значение "Электронно" вводилось из самой программы, а не из конфигуратора (надо еще как то учесть то, чтобы данное значение удалить нельзя было или так чтобы ошибка не выскакивала при удалении, подскажите как это можно сделать?)

Оффлайн Андрей Федотов

  • ***
  • Сообщений: 212
  • РЕПУТАЦИЯ: 36
  • КПД: 17%
  • Регистрация: 2011-07-07
  • Компания: Future IT Solutions
  • Профессия: Разработчик 1С
В справочнике "ВидыПлатежей" в конфигураторе делаете предопределенный элемент "Электронно".
Пользователи смогут изменить его наименование, но системное название нет. Удаление данного элемента справочника невозможно интерактивными средствами.

Далее есть замечательный обработчик формы: ПриСозданииНаСервере(). В нём можно будет заполнить значение элемента формы
С уважением,
Андрей Федотов
Future IT Solutions

Оффлайн Natalia21

  • *
  • Сообщений: 32
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-06
  • Сайт: 
  • Профессия: Ученик 1С
"обработчик формы: ПриСозданииНаСервере()"
но у меня обычная форма, а не управляемая, разве сервер тут уместен?!

Оффлайн Necropunk

  • IS_EVENT_2015_оплатили
  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-10-17
  • Сайт: 
  • Профессия: Разработчик 1С
Ну, что-то типа такого (писал по памяти в конфе, так, в виде примерной реализации)

Процедура ПередОткрытием()

Если ЭтотОбъект.ЭтоНовый() Тогда
      ВидДокумента = Справочники.ВидыДокументов.НайтиПоНаименованию("Электронный");
КонецЕсли;

КонецПроцедуры

Оффлайн Necropunk

  • IS_EVENT_2015_оплатили
  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-10-17
  • Сайт: 
  • Профессия: Разработчик 1С
Лучше с предопределенными, но там смотрите сами, как удобнее, их не всегда получается корректно использовать - их создание обновления конфы требует.

Оффлайн Natalia21

  • *
  • Сообщений: 32
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-06
  • Сайт: 
  • Профессия: Ученик 1С
аха, поняла, все получилось! спасибо большое!!! Можно еще вопрос, вот есть таблица, в ней столбец сумма. мне надо чтобы после таблицы, в объект "Надпись" посчиталась общая сумма по всем строкам столбца "Сумма". как это можно реализовать?

Процедура ТабличнаяЧасть1СуммаПриИзменении(Элемент)
    ЭлементыФормы.Всего_Итог = ЭлементыФормы.ТабличнаяЧасть1.ТекущиеДанные;
КонецПроцедуры

Я думаю что свойство тут выбрано не правильное, т.к. графа сумма она считается автоматически.... и как посчитать сумму по всем строкам не знаю(((( помогите пожалуйста!


Теги:
 

Размещение рекламы Форумы для специалистов: buhgalter-info.ru economist-info.ru sekretar-info.ru economist-info.ru Разделы: Наша профессия (1824) Кадровое делопроизводство (21366) Управление персоналом (1216) Трудовое законодательство (7361) Трудоустро

Автор YataРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 1317
Последний ответ 28 Янв 2016, 13:32
от Yata
Обновление конфигурации "Аренда и управление недвижимостью для "1С:Бухгалтерия 8"" с 2.0 на 3.0

Автор Эльвина МуромцеваРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 211
Последний ответ 16 Ноя 2017, 14:26
от Геннадий ОбьГЭС
Не работает метод Сдвинуть() по отношению к программно добавляемой колонке1С:Предприятие 8.3 (8.3.10.2561) Управление производственным предприятием, редакция 1.4 Приветствую, я добавляю программно свою колонку в методе ПриОткрытии() модуля формы, вот так

Автор InsiderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 278
Последний ответ 21 Сен 2017, 10:33
от Insider
1С "Управление аптекой"

Автор RegsterРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 2666
Последний ответ 29 Апр 2010, 11:51
от Regster
"1С:Предприятие 8. Использование конфигурации "Управление торговлей" Пользовател

Автор raika4Раздел Закрытые темы

Ответов: 0
Просмотров: 3351
Последний ответ 13 Мар 2011, 14:28
от raika4

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
167 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 230
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal