Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 16:30
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вывод отчета в поле табличного документа с иерархией  (Прочитано 9458 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн anateron

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-07-15
  • Сайт: 
Здравствуйте, стоит задача сделать отчет, который должен выводиться в поле табличного документа.
Каким образом вывести данный отчет так, чтобы он сворачивался по первой колонке "Триста"(должен быть + разворачивающий все остальные детальные записи). В консоле запросов я так сделать могу(если выбрать способ выгрузки "дерево"). Вот сам код

Процедура КнопкаСформироватьНажатие(Кнопка)
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
|   ВЫБОР
|    КОГДА ХозрасчетныйОстатки.СуммаОстаток > 300000
|    ТОГДА ""Более трехсот""
|    ИНАЧЕ ""Менее трехсот""
|   КОНЕЦ КАК Поле1,
|   ХозрасчетныйОстатки.Субконто1,
|   СУММА(ХозрасчетныйОстатки.СуммаОстаток) КАК СуммаОстаток
|ИЗ
|   РегистрБухгалтерии.Хозрасчетный.Остатки КАК ХозрасчетныйОстатки
|
|СГРУППИРОВАТЬ ПО
|   ХозрасчетныйОстатки.Субконто1,
|   ВЫБОР
|    КОГДА ХозрасчетныйОстатки.СуммаОстаток > 300000
|    ТОГДА ""Более трехсот""
|    ИНАЧЕ ""Менее трехсот""
|   КОНЕЦ
|
|УПОРЯДОЧИТЬ ПО
|   Поле1
|ИТОГИ
|   СУММА(СуммаОстаток)
|ПО
|   Поле1";

ЭлементыФормы.ДокументРезультат.Очистить();

Макет = ПолучитьМакет("Анализ");

ЗаголовокОтчета = Макет.ПолучитьОбласть("ЗаголовокОтчета");

ЭлементыФормы.ДокументРезультат.Вывести(ЗаголовокОтчета);

//ЭлементыФормы.ДокументРезультат.НачатьАвтогруппировкуСтрок();

ОбластьСтрокаСчет = Макет.ПолучитьОбласть("Строка");

ЭлементыФормы.ДокументРезультат.НачатьАвтогруппировкуСтрок();

Результат = Запрос.Выполнить();
ВыборкаПоТриста = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкамСИерархией,"Поле1");
Пока ВыборкаПоТриста.Следующий() Цикл
ВыборкаПоКонтрагентам = ВыборкаПоТриста.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
Пока ВыборкаПоКонтрагентам.Следующий() Цикл
ОбластьСтрокаСчет.Параметры.Триста = ВыборкаПоКонтрагентам.Поле1;
ОбластьСтрокаСчет.Параметры.Контрагент = ВыборкаПоКонтрагентам.Субконто1;
ОбластьСтрокаСчет.Параметры.СуммаОстаток = ВыборкаПоКонтрагентам.СуммаОстаток;
ЭлементыФормы.ДокументРезультат.Вывести(ОбластьСтрокаСчет);
КонецЦикла;

КонецЦикла;

ЭлементыФормы.ДокументРезультат.ЗакончитьАвтогруппировкуСтрок();

КонецПроцедуры


Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
НачатьАвтогруппировкуСтрок() и ЗакончитьАвтогруппировкуСтрок()


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4473
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15929
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4199
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 628
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7742
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
184 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
40 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 678
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal