Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 21:13
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Запрос по документу  (Прочитано 2595 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн xDee

  • *
  • Сообщений: 35
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-09
  • Сайт: 
  • Профессия: Программист 7.7
Доброго времени суток всем! Уважаемые, не могу реализовать запрос, конфа ТиС 9.2 , самописный документ реализации назван ЧекККМ (не моё). Написал запрос в котором вывожу артикул, номенклатуру, цену. скидку, сумму, все вроде хорошо, НО, просят вывести еще и поставщика номенклатуры, в документе ЧекККМ нет реквизита контрагент, точнее он есть но это покупатель а не поставщик. Как связать номенклатуру с поставщиком ? Подозреваю что еще одним запросом, но не пойму как. Уже второй день ломаю голову.

Процедура Сформировать()
   Перем Запрос, ТекстЗапроса, Таб;
   Запрос = СоздатьОбъект("Запрос");
   ТекстЗапроса =
   "//{{ЗАПРОС(Сформировать)
   |Период с ВыбНачПериода по ВыбКонПериода;
   |Обрабатывать НеПомеченныеНаУдаление;
   |ЧекККМ = Документ.ЧекККМ.ТекущийДокумент;
   |Номенклатура = Документ.ЧекККМ.Номенклатура;
   |Количество = Документ.ЧекККМ.Количество;
   |Цена = Документ.ЧекККМ.Цена;
   |Процент = Документ.ЧекККМ.Скидка.Процент;
   |Сумма = Документ.ЧекККМ.Сумма;
   |Артикул = Документ.ЧекККМ.Номенклатура.Артикул;
   |Группировка Документ;
   |Группировка ЧекККМ ;
           |Группировка Номенклатура;
   |Группировка Количество;
   |Группировка Цена;
   |Группировка Процент;
   |Группировка Сумма;
   |Группировка Артикул;
   |"//}}ЗАПРОС
   ;
   Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
      Возврат;
   КонецЕсли;

   Таб = СоздатьОбъект("Таблица");
   Таб.ИсходнаяТаблица("Сформировать");
   Таб.ВывестиСекцию("Заголовок");
   Состояние("Заполнение выходной таблицы...");
   Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
   НомСтр=0;
   ПечИтог = 0;
   Пока Запрос.Группировка(1) = 1 Цикл
      НомСтр = НомСтр + 1;
   Таб.ВывестиСекцию("Документ");
   Пока Запрос.Группировка(2) = 1 Цикл
      // Заполнение полей ЧекККМ
   Пока Запрос.Группировка(3) = 1 Цикл
      // Заполнение полей Номенклатура
   Пока Запрос.Группировка(4) = 1 Цикл
      // Заполнение полей Количество
   Пока Запрос.Группировка(5) = 1 Цикл
      // Заполнение полей Цена
   Пока Запрос.Группировка(6) = 1 Цикл
      // Заполнение полей Процент
   Пока Запрос.Группировка(7) = 1 Цикл
      // Заполнение полей Сумма
   Пока Запрос.Группировка(8) = 1 Цикл
      // Заполнение полей Артикул
   Таб.ВывестиСекцию("Строка");
КонецЦикла;
КонецЦикла;
КонецЦикла;
КонецЦикла;
КонецЦикла;
КонецЦикла;
КонецЦикла;
   КонецЦикла;
   Таб.ТолькоПросмотр(1);
   Таб.Показать("Сформировать", "");
КонецПроцедуры


Оффлайн 1Cnastroika

Как связать номенклатуру с поставщиком ? Подозреваю что еще одним запросом, но не пойму как.


В зависимости от конфигурации поставщик может быть реквизитом справочника номенклатура, может быть измерением регистра остатков (если остатки хранятся в регистре, а не на бухгалтерском счете), либо учет по поставщикам вообще не ведется. Если учет по поставщикам не ведется, то нужно искать подходящий приходный документ и из него брать поставщика, но возможно, что не получится правильно определить от какого поставщика пришел данный товар.

Оффлайн TORN

  • *
  • Сообщений: 35
  • РЕПУТАЦИЯ: 3
  • КПД: 9%
  • Регистрация: 2011-09-03
  • Сайт: 
  • Профессия: Бухгалтер
надо найти партию, из которой списан товар и оттуда выдернуть.необязательно в теле запроса..


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
169 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
49 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 316
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal