Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 12:19
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Бухг.запрос (ОСВ)  (Прочитано 2444 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн T11

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-02
  • Сайт: 
  • Профессия: Программист 7.7
Добрый вечер, коллеги! Нужна ваша помощь...
В бухгалтерском запросе "Оборотно-сальдовая ведомость по счетам взаиморасчетов" на форме отчета можно выбрать определенного контрагента, счет и по нему сформировать оборотно-сальдовую ведомость...
А если поле Контрагента пустое-необходимо в отчет вынести всех контрагентов, у которых Перечисление.ВидыКонтрагента----Организация или Частное лицо, а также этот контрагент не является плательщиком налогов. С этим и возникла проблема-не отбираются контрагенты по написанному условию...

///*******************************************
//{{БУХГАЛТЕРСКИЙ ЗАПРОС(Сформировать)

//Данный фрагмент построен конструктором.
//При повторном использовании конструктора, внесенные вручную изменения будут потеряны!!!

//{{ Схема номер 1

Процедура Сформировать()
Перем ЗначениеПодбора1;
Перем ЗначениеПодбора2;
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Сформировать");
Ит = СоздатьОбъект("БухгалтерскиеИтоги");
Ит.ИспользоватьПланСчетов(ПланыСчетов.Основной);
Ит.ИспользоватьРазделительУчета(ВыбРазделительУчета);
спКонтрагентов = СоздатьОбъект("СписокЗначений");

Если ПустоеЗначение(ВыбСубконто1) = 1 Тогда
СпрКонтр=СоздатьОбъект("Справочник.Контрагенты");
ЗначениеПодбора1=СокрЛП(СпрКонтр.ВидКонтрагента);
ЗначениеПодбора2=СокрЛП(СпрКонтр.ПлательщикНалогов);
СпрКонтр.ВыбратьЭлементы();
Пока СпрКонтр.ПолучитьЭлемент()=1 Цикл
Если (ЗначениеПодбора1=Перечисление.ВидыКонтрагентов.Организация) или (ЗначениеПодбора1=Перечисление.ВидыКонтрагентов.ЧастноеЛицо) и (ЗначениеПодбора2=0) Тогда
спКонтрагентов.ДобавитьЗначение(СпрКонтр.ТекущийЭлемент();
КонецЕсли;
КонецЦикла;
Иначе
спКонтрагентов.ДобавитьЗначение(ВыбСубконто1);
КонецЕсли;
Ит.ИспользоватьСубконто(ВидыСубконто.Контрагенты, спКонтрагентов, 1);
Ит.ВыполнитьЗапрос(ВыбНачПериода, ВыбКонПериода, ВыбСчет,,, 1,, "С");
Таб.ВывестиСекцию("Шапка");
Таб.Опции(0,0,Таб.ВысотаТаблицы(),0);
Ит.ВыбратьСубконто(ВидыСубконто.Контрагенты);
Пока Ит.ПолучитьСубконто(ВидыСубконто.Контрагенты) = 1 Цикл
Таб.ВывестиСекцию("Субконто1");
КонецЦикла;
Таб.ВывестиСекцию("Подвал");
Таб.ТолькоПросмотр(1);
Таб.Показать("Сформировать","");
КонецПроцедуры
//}}БУХГАЛТЕРСКИЙ ЗАПРОС
Процедура ПриОткрытии()
//{{ИНИЦИАЛИЗАЦИЯ БУХГАЛТЕРСКОГО ЗАПРОСА(Сформировать)
ВыбНачПериода = НачалоПериодаБИ();
ВыбКонПериода = КонецПериодаБИ();
//{{ИНИЦИАЛИЗАЦИЯ БУХГАЛТЕРСКОГО ЗАПРОСА
КонецПроцедуры


Оффлайн 1Cnastroika

Re: Бухг.запрос (ОСВ)
« Ответ #1: 05 Ноя 2011, 20:43 »
С этим и возникла проблема-не отбираются контрагенты по написанному условию...


Не понятен вопрос. Какой должен быть результат работы программы и как программа работает? Чтобы мне не разбирать весь текст программы, а только то что нужно.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 269
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal