Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 09:18
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Проблема - ошибки в написании модуля  (Прочитано 2587 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн wad_str

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-10-27
  • Сайт: 
  • Профессия: Программист 7.7
1С 7.7.025 типовая переписанная релиз 530

Привет! Очередная засада....
 заполнение ячеек частью текста я победил, правда "заплатка" получилась, я посчитал количество символов
и функцией Сред отобрал жестко 4 символа от порядкового номера следующего за символом №
работает только для одного договора, потому что в разных договорах всё написано по-разному......

   //****************************************для ТОРГ-12 заполнить договор **********************************************
   Ддата = Строка(СокрЛП(Договор.Наименование));           
   Если Найти(Ддата," ")>0 тогда
   Для н=1 по СтрЧислоВхождений(Ддата," ") Цикл
   Ддата=Прав(Ддата, (СтрДлина(Ддата)-Найти(Ддата," ")));
    КонецЦикла;
КонецЕсли;
    ДНомер = Строка(СокрЛП(Договор.Наименование));
   Если Найти(Договор,"№")>0 Тогда
       //Пока  ч<> " " Цикл
      //Для ч=1 по СтрЧислоВхождений(ДНомер," ") Цикл
      ДНомер =Сред(ДНомер,19,4);
   //КонецЦикла;
КонецЕсли;
если использую цикл Пока ч <>.... обработка затыкается и думает бесконечно долго....
а для ч=1 по  Цикл - выбирает всё что угодно только не то что нужно....
//*********************************************************************************
 а вот в этом куске принцип тот же, тут жестко в наименовании номенклатуры прописано количество в упаковке,
выдергиваю - дает ошибку
Ит.ВыбратьСубконто(1);
{Документ.РасходнаяНакладная.Форма.Модуль(1051)}: Данная операция допустима только в режиме запроса по аналитике !

   Ит = СоздатьОбъект("БухгалтерскиеИтоги");
   Номенкл = СоздатьОбъект("Справочник.Номенклатура");
      Ит.ВыбратьСубконто(1);
      Ит.ПолучитьСубконто(1);
      Ит.ИспользоватьСубконто(ВидыСубконто.Номенклатура, , 1);
      Пока Ит.ПолучитьСубконто(1) = 1 Цикл 
            Ит.ВыполнитьЗапрос(, ДатаДок, "41.4,41.1",,, 1,, "К");
         
      КолвоУп = "";
         Врем = "";
         НаименТовара = Ит.ПредставлениеСубконто(1);
         Если Найти(НаименТовара, "(")>0 Тогда
            Врем = НаименТовара;
            Пока (Найти(Врем, "(")>0) и (КолвоУп = "") Цикл
               КолвоУп = Сред(Врем, Найти(Врем, "(")+1, Найти(Врем, ")") - Найти(Врем, "(") - 1);
               Если Число(КолвоУп) = 0 Тогда
                  КолвоУп = "";
               КонецЕсли;
               Врем = Прав(Врем, СтрДлина(Врем) - Найти(Врем, ")"));
               Если КолвоУп <> "" Тогда
                  НаименТовара = СтрЗаменить(НаименТовара, "("+КолвоУп+")", "");
               КонецЕсли;
            
            КонецЦикла;
               КонецЕсли;
            КонецЦикла;   
            Сообщить("Кол-во уп"+КолвоУп);
В чем проблема- так не могу разобраться.... Кто знает - укажите на ошибку пожалуйста. Заранее спасибо!


Оффлайн wad_str

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-10-27
  • Сайт: 
  • Профессия: Программист 7.7
Всем спасибо, разобрался во всём отдельное спасибо Володе volodyja122


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
AIFrame
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
alexandr_ll
24 Сообщений

* Кто онлайн

  • Точка Гостей: 199
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal