Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Май 2018, 18:01
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Экспорт процедуры из общего модуля в модуль формы  (Прочитано 4229 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Keiichiro

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-10-26
  • Сайт: 
  • Профессия: Программист 1С
Здравствуйте. Помогите пожалуйста. Только начала изучать 1С 8.2. Не в восторге от разделения выполнения НаКлиенте и НаСервере. Собственно возникли проблемы.

модуль формы:

&НаКлиенте
Процедура НажатиеКнопки(Кнопка)
ОбщийМодуль1.ОткрытьФорму(); // вот здесь возникает проблема..что же должно быть в скобках..   
КонецПроцедуры

общий модуль:

Процедура ОткрытьФорму(ФормаПодбора) Экспорт   
   Перем ГлГр;   
ФормаПодбора = Справочники.Счетчик.ПолучитьФормуВыбора();                               
  ФормаПодбора.ЗакрыватьПриВыборе = Ложь;
  ФормаПодбора.Открыть();
     ГлГр = 1;   
КонецПроцедуры

Не удивлюсь если у меня весь код не правильный..не судите строго..


Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1310
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Как-то так
&НаКлиенте
Процедура НажатиеКнопки(Кнопка)
   ФормаПодбора = ПолучитьФорму("Справочник.Счетчик.ФормаВыбора");
   ФормаПодбора.ЗакрыватьПриВыборе = Ложь;
   ФормаПодбора.Открыть();
КонецПроцедуры

Оффлайн Keiichiro

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-10-26
  • Сайт: 
  • Профессия: Программист 1С
Огромное спасибо..никак не могу найти нормальную литературу и примеры..при чтении уже просто залипается..

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1310
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С


Теги:
 

Нужно в параметр запроса к РегистрБухгалтерии.Проводки.Остатки вставить вместо периода данные из другого запроса отчет СКД 8.3, обычные формы

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 153
Последний ответ 10 Апр 2018, 14:00
от Св Ч
Редактирование формы "Настройки пользователя".

Автор t955938Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 5251
Последний ответ 03 Авг 2011, 11:45
от t955938
получаю значение реквизита формы, дает значение 0

Автор mikel10Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3790
Последний ответ 12 Июл 2013, 15:35
от mikel10
Настройка формы "Заполнение товаров"

Автор ЖаннаРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 834
Последний ответ 10 Мар 2017, 21:00
от Жанна
Изменение формы "Список сотрудников"

Автор OZZYikРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 325
Последний ответ 02 Апр 2018, 06:23
от alexandr_ll

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
152 Сообщений
oleg-x
65 Сообщений
alex0402
63 Сообщений
AIFrame AIFrame
52 Сообщений
wise wise
37 Сообщений
KOI8-R
34 Сообщений
buketov.av buketov.av
34 Сообщений
Alter
24 Сообщений
BuhRust
21 Сообщений
alexandr_ll
21 Сообщений

* Кто онлайн

  • Точка Гостей: 487
  • Точка Скрытых: 0
  • Точка Пользователей: 13
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal