Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 21:44
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Экспорт процедуры из общего модуля в модуль формы  (Прочитано 3789 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Keiichiro

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-10-26
  • Сайт: 
  • Профессия: Программист 1С
Здравствуйте. Помогите пожалуйста. Только начала изучать 1С 8.2. Не в восторге от разделения выполнения НаКлиенте и НаСервере. Собственно возникли проблемы.

модуль формы:

&НаКлиенте
Процедура НажатиеКнопки(Кнопка)
ОбщийМодуль1.ОткрытьФорму(); // вот здесь возникает проблема..что же должно быть в скобках..   
КонецПроцедуры

общий модуль:

Процедура ОткрытьФорму(ФормаПодбора) Экспорт   
   Перем ГлГр;   
ФормаПодбора = Справочники.Счетчик.ПолучитьФормуВыбора();                               
  ФормаПодбора.ЗакрыватьПриВыборе = Ложь;
  ФормаПодбора.Открыть();
     ГлГр = 1;   
КонецПроцедуры

Не удивлюсь если у меня весь код не правильный..не судите строго..


Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Как-то так
&НаКлиенте
Процедура НажатиеКнопки(Кнопка)
   ФормаПодбора = ПолучитьФорму("Справочник.Счетчик.ФормаВыбора");
   ФормаПодбора.ЗакрыватьПриВыборе = Ложь;
   ФормаПодбора.Открыть();
КонецПроцедуры

Оффлайн Keiichiro

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-10-26
  • Сайт: 
  • Профессия: Программист 1С
Огромное спасибо..никак не могу найти нормальную литературу и примеры..при чтении уже просто залипается..

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
166 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
36 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
28 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 447
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal