Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Янв 2018, 10:43
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: проверка на повтор?  (Прочитано 7959 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн надюшка

  • чайник
  • **
  • Сообщений: 96
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2011-02-25
  • Сайт: 
  • Профессия: Консультант 1С
Документ создается на основании другого, в первом документе номенклатура может повторятся несколько раз, во втором документе только раз.
При переносе по документу основании сейчас столбец с номенклатурой переноситься без изменений. (идентичен в обоих документах)
необходимо при переносе во второй документ делать проверку, чтобы номенклатура не дублировалась????
что имеем сейчас:
Для каждого СтрокаТ из ПараметрОснование.Товары цикл
Нов = ТаблицаЦен.Добавить();
Нов.Номенклатура = СтрокаТ.Номенклатура;
КонецЦикла;
С каждого по мысле, мне на программу


Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Выполните запрос к табличной части документа основания и сгруппируйте по номенклатуре

Оффлайн надюшка

  • чайник
  • **
  • Сообщений: 96
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2011-02-25
  • Сайт: 
  • Профессия: Консультант 1С
у меня с запросами совсем туго, можно более подробное описание процесса?? :trhregerhg:
С каждого по мысле, мне на программу

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
у меня с запросами совсем туго, можно более подробное описание процесса?? :trhregerhg:
Документы какие используются?

Оффлайн надюшка

  • чайник
  • **
  • Сообщений: 96
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2011-02-25
  • Сайт: 
  • Профессия: Консультант 1С
Документ Основание -РегистрацияПравилФормированияЦен
Документ Создается - УстановкаЦенНоменклатуры
С каждого по мысле, мне на программу

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Не знаю какие там реквизиты табличной части нужны, но примерно так
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
|Регистрация.Номенклатура,
|Сумма(Регистрация.Количество)
|ИЗ
|Документ.РегистрацияПравилФормированияЦен.Товары КАК Регистрация
|ГДЕ РегистрацияПравилФормированияЦен.Товары.Ссылка = &Основание
|СГРУППИРОВАТЬ ПО
|Регистрация.Номенклатура";

Запрос.УстановитьЗначениеПараметра("Основание", ПараметрОснование);
Выборка = Запрос.Выполнить.Выбрать();
Пока Выборка.Следующий() Цикл
   Нов = ТаблицаЦен.Добавить();
   Нов.Номенклатура = Выборка.Номенклатура;
   //тут дальше заполняем, если необходимо
КонецЦикла;

Оффлайн надюшка

  • чайник
  • **
  • Сообщений: 96
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2011-02-25
  • Сайт: 
  • Профессия: Консультант 1С
вот такая ошибка -Метод объекта не обнаружен (УстановитьЗначениеПараметра)
                      Запрос.УстановитьЗначениеПараметра("Основание", ПараметрОснование);
С каждого по мысле, мне на программу

Оффлайн надюшка

  • чайник
  • **
  • Сообщений: 96
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2011-02-25
  • Сайт: 
  • Профессия: Консультант 1С
ТипЗнч(ПараметрОснование) = Тип("ДокументСсылка.РегистрацияПравилФормированияЦен")
С каждого по мысле, мне на программу

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Запроса нет значит, я же не знаю как Вы скопировали этот код. Либо покажите скрин модуля, куда вставляете запрос

Оффлайн надюшка

  • чайник
  • **
  • Сообщений: 96
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2011-02-25
  • Сайт: 
  • Профессия: Консультант 1С
Имеем вот такой код:
ИначеЕсли ТипЗнч(ПараметрОснование) = Тип("ДокументСсылка.РегистрацияПравилФормированияЦен") Тогда
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
|Регистрация.Номенклатура,
|Сумма(Регистрация.Количество)
|ИЗ
|Документ.РегистрацияПравилФормированияЦен.Товары КАК Регистрация
|ГДЕ РегистрацияПравилФормированияЦен.Товары.Ссылка = &Основание
|СГРУППИРОВАТЬ ПО
|Регистрация.Номенклатура";
Запрос.УстановитьПараметр("Основание", ПараметрОснование.Товары);
Выборка = Запрос.Выполнить().Выбрать();
Пока Выборка.Следующий() Цикл
Нов = ТаблицаЦен.Добавить();
Нов.Номенклатура = Выборка.Номенклатура;
КонецЦикла;
КонецЕсли;
и вот такую ошибку
{Документ.УстановкаЦенНоменклатуры.Форма.ФормаДокумента(1352)}:
Ошибка при вызове метода контекста (Выполнить)
   РезультатЗапроса = Запрос.Выполнить();
по причине:

по причине:
{(6, 5)}: Поле не найдено "РегистрацияПравилФормированияЦен.Товары.Ссылка"
ГДЕ <<?>>РегистрацияПравилФормированияЦен.Товары.Ссылка = &Основание
С каждого по мысле, мне на программу


Теги:
 

Отчет "Экспресс проверка"

Автор МаксиРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 461
Последний ответ 10 Май 2017, 09:06
от Макси
Проверка на "новую" запись в рег. сведений

Автор nomer13Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 14605
Последний ответ 11 Янв 2011, 10:04
от nomer13
"Проверка мутабельных значений на заполненность не поддерживается"

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 21133
Последний ответ 13 Фев 2011, 17:36
от proofet
Часть вторая: переход на «1С ЗУП» версии «3.0». Работа с «Параметрами учета» и проверка всех настроек программы после транспортировки из предыдущей редакции

Автор 1cwikiРаздел Зарплата и управление персоналом

Ответов: 0
Просмотров: 4366
Последний ответ 16 Мар 2015, 16:19
от 1cwiki
ФНС во время выездной проверки может доначислить земельный налог, вне зависимости от того, как прошла камеральная проверка

Автор topicsРаздел Статьи

Ответов: 0
Просмотров: 1191
Последний ответ 24 Сен 2014, 14:48
от topics

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
106 Сообщений
AIFrame
105 Сообщений
alex0402
28 Сообщений
alexandr_ll
17 Сообщений
kiksi
17 Сообщений
andron81_81
16 Сообщений
pavl_vs
13 Сообщений
LexaK
13 Сообщений
BuhRust
13 Сообщений
Artibon
12 Сообщений

* Кто онлайн

  • Точка Гостей: 935
  • Точка Скрытых: 0
  • Точка Пользователей: 15
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal