Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
25 сен 2021, 00:04

Передача параметров в открываемую форму

Автор Konstatine, 25 окт 2011, 08:07

0 Пользователей и 1 гость просматривают эту тему.

Konstatine

Доброго времени суток.
Я новичок в 1С 8.2. Уже неделю бьюсь с одним вопросом...
Как мне передать значения табличной части документа (например, поля "Сотрудник", "Начислено", "Выплачено" и т.д.) в точно такую же табличную часть открываемого по кнопке нового документа?   :dfbsdfbsdf:
Напишите, пожалуйста, пример. Буду признателен.

has

Управляемый интерфейс или обычный?

Konstatine


has

Заполняйте программно. Т.е. допустим Вы создали документ, затем заполняете его табличную часть Сотрудники

ДокОбъект = Документы.ВашДок.СоздатьДокумент();
Для Каждого СтрокаТЧ Из Сотрудники Цикл
  НоваяСтрока = ДокОбъект.Сотрудники .Добавить();
  НоваяСтрока.Сотрудник = СтрокаТЧ.Сотрудник;
  ............
КонецЦикла;

Вася Новенький

а как же ввод на основании?
можно же использовать этот метод.

Konstatine

Поясните, пожалуйста, как это сделать с помощью ввода на основании?

Konstatine

Подскажите, а если делать с помощью передачи параметров дочерней форме..так можно?

has

Зачем форме? Делайте ввод на основании. В новом документе процедура ОбработкаЗаполнения, там и заполняйте реквизиты из документа основания. Рекомендую прочитать литературу.

Konstatine


Konstatine

Подскажите, что я делаю неправильно при ввобде на основании?
Создал табличную часть с реквизитами, перенес ее на панель формы. Далее заполнил параметры ввода на основании другого документа. Получился код:

Процедура ОбработкаЗаполнения(ДанныеЗаполнения, СтандартнаяОбработка)
   //{{__КОНСТРУКТОР_ВВОД_НА_ОСНОВАНИИ
   // Данный фрагмент построен конструктором.
   // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
   Если ТипЗнч(ДанныеЗаполнения) = Тип("ДокументСсылка.ЗарплатаКВыплатеОрганизаций") Тогда
      // Заполнение шапки
      Для Каждого ТекСтрокаЗарплата Из ДанныеЗаполнения.Зарплата Цикл
         НоваяСтрока = Таблица.Добавить();
         НоваяСтрока.Сумма = ТекСтрокаЗарплата.ВыплаченностьЗарплаты;
         НоваяСтрока.Сотрудник = ТекСтрокаЗарплата.Физлицо;
      КонецЦикла;
   КонецЕсли;
   //}}__КОНСТРУКТОР_ВВОД_НА_ОСНОВАНИИ
КонецПроцедуры

Но не работает, т.к. ТипЗнч(ДанныеЗаполнения) = "Не определено".
Что я сделал не так?
Помогите.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск