Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 09:43
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как установить источник данных для поля ввода  (Прочитано 5077 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн valeriyp

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-06-16
  • Сайт: 
  • Профессия: Разработчик 1С
Добрый день.

Недавно начал изучать 1с, возникла такая проблема:

Есть ПолеВвода1, связанное со справочником НалоговыйПреиод, который имеет два значения - Месяц и Квартал.
Нужно чтобы в ПолеВвода2 в зависимости от выбора в ПолеВвода1 осуществлялся выбор значений из Справочника Месяца или Квартала.

Заранее спасибо.


Оффлайн Андрей Федотов

  • ***
  • Сообщений: 212
  • РЕПУТАЦИЯ: 36
  • КПД: 17%
  • Регистрация: 2011-07-07
  • Компания: Future IT Solutions
  • Профессия: Разработчик 1С
1) Делаете ПолеВвода2 составным (на справочники Месяца и Квартал).
2) Делаете обработчик события "ОкончаниеВыбора" на ПолеВвода1, в котором устанавливаете из какого справочника будет выбираться значение в ПолеВвода2 в зависимости от выбранных данных в ПолеВвода1.
С уважением,
Андрей Федотов
Future IT Solutions

Оффлайн valeriyp

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-06-16
  • Сайт: 
  • Профессия: Разработчик 1С
Пожалуйста скажите подробнее момент присвоения полю нужного справочника

Оффлайн Андрей Федотов

  • ***
  • Сообщений: 212
  • РЕПУТАЦИЯ: 36
  • КПД: 17%
  • Регистрация: 2011-07-07
  • Компания: Future IT Solutions
  • Профессия: Разработчик 1С
Используйте свойство
ОграничениеТипа 
элемента формы

Массив=Новый Массив(); 
Массив.Добавить("СправочникСсылка.Месяц");
ЭлементыФормы.ПолеВвода2.ОграничениеТипа=Новый ОписаниеТипов(Массив);


Код примерно такой. Добавьте его в нужные проверки и используйте.
С уважением,
Андрей Федотов
Future IT Solutions

Оффлайн valeriyp

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-06-16
  • Сайт: 
  • Профессия: Разработчик 1С
При таком обработчике:

Процедура НалоговыйПериодОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
      Если ВыбранноеЗначение.Наименование="Месяц" Тогда
         Массив = Новый Массив();
         Массив.Добавить(Тип("СправочникСсылка.Месяца"));
         ЭлементыФормы.НомерМесяца.ОграничениеТипа = Новый ОписаниеТипов(Массив);      
      Иначе
         Массив = Новый Массив();
         Массив.Добавить(Тип("СправочникСсылка.Квартала"));
         ЭлементыФормы.НомерМесяца.ОграничениеТипа = Новый ОписаниеТипов Массив);      
      КонецЕсли;
КонецПроцедуры

при первом выборе значения в поле НалоговыйПериод все нормально, но если затем изменить на другое значение источник данных в поле месяца не изменяется.

Оффлайн Андрей Федотов

  • ***
  • Сообщений: 212
  • РЕПУТАЦИЯ: 36
  • КПД: 17%
  • Регистрация: 2011-07-07
  • Компания: Future IT Solutions
  • Профессия: Разработчик 1С
Вам при обработке выбора сначала нужно снять ограничение типа, а затем уже устанавливать.
Иначе работать будет некорректно
С уважением,
Андрей Федотов
Future IT Solutions

Оффлайн valeriyp

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-06-16
  • Сайт: 
  • Профессия: Разработчик 1С
Спасибо за помощь, направили в нужном русле. Нашел пример вот получился нормальный обработчик:

Если ВыбранноеЗначение.Наименование="Месяц" Тогда
         ТипСтр = "СправочникСсылка.Месяца";
         ЭлементыФормы.НомерМесяца.ОграничениеТипа = Новый ОписаниеТипов(ТипСтр);
         Значение = ЭлементыФормы.НомерМесяца.Значение;
         ЭлементыФормы.НомерМесяца.Значение = ЭлементыФормы.НомерМесяца.ОграничениеТипа.ПривестиЗначение(Значение);
         ЭлементыФормы.НомерМесяца.ВыбиратьТип = Ложь;
         Иначе          
         ТипСтр = "СправочникСсылка.Квартала";
         ЭлементыФормы.НомерМесяца.ОграничениеТипа = Новый ОписаниеТипов(ТипСтр);
         Значение = ЭлементыФормы.НомерМесяца.Значение;
         ЭлементыФормы.НомерМесяца.Значение = ЭлементыФормы.НомерМесяца.ОграничениеТипа.ПривестиЗначение(Значение);
         ЭлементыФормы.НомерМесяца.ВыбиратьТип = Ложь;         
КонецЕсли;


Теги:
 

Перенос данных из 1с 82 БП (базовая) в 1с 82 БГУ (базовая)

Автор Владимир87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7430
Последний ответ 06 Дек 2014, 17:40
от дфтын
Поиск по бае данных,(полнотекстовый поиск)

Автор kot_ooРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3881
Последний ответ 19 Май 2014, 15:40
от kot_oo
Как исправить при обновлении ИБ: Ошибка в запросе набора данных по причине: {(58, 2)}: Несовместимые типы "ВЫБОР" <<?>>ВЫБОР

Автор dollРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2111
Последний ответ 01 Янв 2017, 20:27
от Геннадий ОбьГЭС
"Задваивание" данных в отчете

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 7319
Последний ответ 15 Окт 2015, 11:21
от Mari_beginner
Куда сохраняются данные в режиме работы клиент при выгрузке данных обработкой "Универсальный обмен данными в формате XML"

Автор xDDРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 6947
Последний ответ 13 Ноя 2014, 08:23
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
168 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 706
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal