Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
20 Май 2018, 22:13
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Текущий остаток отпуска  (Прочитано 5215 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн KudesNick

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-10-17
  • Сайт: 
  • Профессия: Ученик 1С
Доброго времени суток уважаемые форумчане! Прошу вас оказать мне помощь в решении следующей задачи. Необходимо создать внешний отчет, который бы выводил бы следующие данные по каждому работнику: ФИО, Дата приема на работу, Текущий остаток отпуска.
ФИО, Дата приема на работу я вывел, при помощи следующего кода:
Процедура Сформировать()
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Сформировать");
Таб.ВывестиСекцию("Шапка");
Таб.Опции(0,0,Таб.ВысотаТаблицы(),0);
Сотрудник=СоздатьОбъект("Справочник.Сотрудники");
Сотрудник.ВыбратьЭлементы();
Пока Сотрудник.ПолучитьЭлемент()>0 Цикл
Если Сотрудник.ЭтоГруппа() = 0 Тогда

Таб.ВывестиСекцию("Строка_1");
КонецЕсли
КонецЦикла;       
Таб.ТолькоПросмотр(1);
Таб.Показать;
КонецПроцедуры
Как  мне посчитать текущий остаток отпуска (количество неиспользованных дней отпуска)? Какие данные использовать при этом? Я правильно понимаю, что текущий остаток отпуска -  это 28 – количество использованных дней отпуска? Как в таком случае получить количество использованных дней отпуска, где взять эти данные? Я правильно понимаю, что количество использованных дней отпуска – это ДатаОкончанияОтпуска1-ДатаНачалаОтпуска1+ ДатаОкончанияОтпуска2-ДатаНачалаОтпуска2+…?


Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Озвучь конфигурацию. Зарплата и Кадры?
Кнопочка Спасибо - слева!

Оффлайн KudesNick

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-10-17
  • Сайт: 
  • Профессия: Ученик 1С
Камин

Оффлайн Андрей Федотов

  • ***
  • Сообщений: 231
  • РЕПУТАЦИЯ: 37
  • КПД: 16%
  • Регистрация: 2011-07-07
  • Компания: Future IT Solutions
  • Профессия: Разработчик 1С
Самый простой способ будет узнать у пользователей как они учитывают отпуск сотрудников в 1С.
А далее посмотреть документ, какие он делает движения.
Если у Вас будет регистр, то из него данные собрать - не проблема. Иначе - по документам
С уважением,
Андрей Федотов
Future IT Solutions

Оффлайн KudesNick

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-10-17
  • Сайт: 
  • Профессия: Ученик 1С
Создается документ «начисление по среднему», данные по отпускам из которого учитываются системой


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
156 Сообщений
oleg-x
65 Сообщений
alex0402
62 Сообщений
AIFrame AIFrame
52 Сообщений
wise wise
38 Сообщений
KOI8-R
33 Сообщений
buketov.av buketov.av
28 Сообщений
Alter
21 Сообщений
alexandr_ll
19 Сообщений
Анюта17
19 Сообщений

* Кто онлайн

  • Точка Гостей: 252
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal