Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 06:02
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Текущий остаток отпуска  (Прочитано 4816 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн KudesNick

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-10-17
  • Сайт: 
  • Профессия: Ученик 1С
Доброго времени суток уважаемые форумчане! Прошу вас оказать мне помощь в решении следующей задачи. Необходимо создать внешний отчет, который бы выводил бы следующие данные по каждому работнику: ФИО, Дата приема на работу, Текущий остаток отпуска.
ФИО, Дата приема на работу я вывел, при помощи следующего кода:
Процедура Сформировать()
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Сформировать");
Таб.ВывестиСекцию("Шапка");
Таб.Опции(0,0,Таб.ВысотаТаблицы(),0);
Сотрудник=СоздатьОбъект("Справочник.Сотрудники");
Сотрудник.ВыбратьЭлементы();
Пока Сотрудник.ПолучитьЭлемент()>0 Цикл
Если Сотрудник.ЭтоГруппа() = 0 Тогда

Таб.ВывестиСекцию("Строка_1");
КонецЕсли
КонецЦикла;       
Таб.ТолькоПросмотр(1);
Таб.Показать;
КонецПроцедуры
Как  мне посчитать текущий остаток отпуска (количество неиспользованных дней отпуска)? Какие данные использовать при этом? Я правильно понимаю, что текущий остаток отпуска -  это 28 – количество использованных дней отпуска? Как в таком случае получить количество использованных дней отпуска, где взять эти данные? Я правильно понимаю, что количество использованных дней отпуска – это ДатаОкончанияОтпуска1-ДатаНачалаОтпуска1+ ДатаОкончанияОтпуска2-ДатаНачалаОтпуска2+…?


Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Озвучь конфигурацию. Зарплата и Кадры?
Кнопочка Спасибо - слева!

Оффлайн KudesNick

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-10-17
  • Сайт: 
  • Профессия: Ученик 1С
Камин

Оффлайн Андрей Федотов

  • ***
  • Сообщений: 212
  • РЕПУТАЦИЯ: 36
  • КПД: 17%
  • Регистрация: 2011-07-07
  • Компания: Future IT Solutions
  • Профессия: Разработчик 1С
Самый простой способ будет узнать у пользователей как они учитывают отпуск сотрудников в 1С.
А далее посмотреть документ, какие он делает движения.
Если у Вас будет регистр, то из него данные собрать - не проблема. Иначе - по документам
С уважением,
Андрей Федотов
Future IT Solutions

Оффлайн KudesNick

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-10-17
  • Сайт: 
  • Профессия: Ученик 1С
Создается документ «начисление по среднему», данные по отпускам из которого учитываются системой


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
167 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 260
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal