Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 07:29
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите пожалуйста с табличным полем формы!  (Прочитано 2054 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн MKozzlik

  • *
  • Сообщений: 45
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2011-08-04
  • Сайт: 
Здравствуйте! Уже несколько дней мучаюсь, не могу заполнить программно форму элемента характеристики номенклатуры, а именно табличное поле СвойстваИЗначения, оно не связано с табличной частью. Изображения этой формы в конфигураторе приложено к теме. Свойство заполняется из ПлановВидоХарактеристик, а значение должно заполнятся программно и так чтобы соотвествовало свойству но ни как не получается, пробовала примерно так:

ФормаЭлемента = ЭлементХарактеристики.ПолучитьФорму();
ТаблПоле = ФормаЭлемента.ЭлементыФормы.СвойстваИЗначения.Значение.Добавить();

         Для каждого СтрТабл Из ТаблПоле  Цикл
            Если СтрТабл.Свойство = "Длина" Тогда
            СтрТабл.Значение = Длина;
            КонецЕсли;
                 Если СтрТабл.Свойство = "Ширина" Тогда
            СтрТабл.Значение = Ширина;
            КонецЕсли;
            Если СтрТабл.Свойство = "Параметр" Тогда
            СтрТабл.Значение = Параметр;
            КонецЕсли;
            КонецЦикла;



Оффлайн MKozzlik

  • *
  • Сообщений: 45
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2011-08-04
  • Сайт: 
Вот так выглядит в режиме 1С предприятия, свойства заполнены, а значения нет( надо как раз заполнить значения

Оффлайн MKozzlik

  • *
  • Сообщений: 45
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2011-08-04
  • Сайт: 
Тип Длины, Ширины, Кода - число, а Параметра - строка

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Там добавлять надо через обработку. Посмотрите в самой обработке есть процедура установки значений. В типовых конфигурациях можно посмотреть еще.


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4302
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5558
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5898
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4386
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1985
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
50 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 118
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal