Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 00:35
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Куда обращаться с ошибками?  (Прочитано 5492 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Валентиныч

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-03-30
  • Сайт: 
  • Профессия: Бухгалтер
Поставил обновление. После этого, при запуске 1С 8.2 вылезает табличка с ошибкой, а после перехода в конфигуратор открывается окно с сообщением ...
{ОбщийМодуль.УправлениеПользователями.Модуль(89)}: Значение не является значением объектного типа (ПривестиЗначение)
   ПустоеЗначение = ПланыВидовХарактеристик.НастройкиПользователей[Настройка].ТипЗначения.ПривестиЗначение();

И открывается окно с модулем с развернутой функцией
Функция ПолучитьЗначениеПоУмолчаниюПользователя(Пользователь, Настройка)

   Запрос = Новый Запрос;
   Запрос.УстановитьПараметр("Пользователь", Пользователь);
   Запрос.УстановитьПараметр("Настройка"   , ПланыВидовХарактеристик.НастройкиПользователей[Настройка]);
   Запрос.Текст = "
   |ВЫБРАТЬ
   |   Значение
   |ИЗ
   |   РегистрСведений.НастройкиПользователей КАК РегистрЗначениеПрав
   |
   |ГДЕ
   |   Пользователь = &Пользователь
   | И Настройка    = &Настройка";

   Выборка = Запрос.Выполнить().Выбрать();

   ПустоеЗначение = ПланыВидовХарактеристик.НастройкиПользователей[Настройка].ТипЗначения.ПривестиЗначение();

   Если Выборка.Количество() = 0 Тогда
      
      Если Настройка = "ОткрыватьПриЗапускеПанельФункций" Тогда
         Возврат Истина;
      
      ИначеЕсли Настройка = "ПоказыватьОписанияПанелиФункций" Тогда
         Возврат Ложь;
         
      КонецЕсли;
      
      Возврат ПустоеЗначение;

   ИначеЕсли Выборка.Следующий() Тогда

      Если НЕ ЗначениеЗаполнено(Выборка.Значение) Тогда
         Возврат ПустоеЗначение;
      Иначе
         Возврат Выборка.Значение;
      КонецЕсли;

   Иначе
      Возврат ПустоеЗначение;

   КонецЕсли;

КонецФункции // ПолучитьЗначениеПоУмолчанию()

Куда обращаться? Наверняка есть служба техподдержки какая-то?


Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1376
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
А копию базы делалил перед обновлением?

Оффлайн AntonB

  • Модератор
  • *****
  • Сообщений: 402
  • РЕПУТАЦИЯ: 74
  • КПД: 18%
  • Регистрация: 2011-05-26
  • Сайт: 
  • Профессия: Программист 8.1
http://1c.ru/rus/support/support.htm
как я понимаю, только при наличии подписки ИТС
Предлагаю полный ИТ сервис небольшой организации в Москве (приходящий сисадмин+1С7.7,1С8.x)

Оффлайн Валентиныч

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-03-30
  • Сайт: 
  • Профессия: Бухгалтер
А копию базы делалил перед обновлением?
Не в этот раз. Всегда обновлялся с выгрузкой базы через конфигуратор. А тут что-то, забыл). У меня база пока пустая кроме сведений о фирме.

Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1376
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
Тогда ставим новую базу и больше к этому вопросу не возращаемся.
А вообще заведите приходящего программиста, который делал бы Вам обновления. Тогда таких проблем точно не будет или по крайней мере их можно будет на кого-то свалить. )))

Оффлайн Валентиныч

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-03-30
  • Сайт: 
  • Профессия: Бухгалтер
Тогда ставим новую базу и больше к этому вопросу не возращаемся.
А вообще заведите приходящего программиста, который делал бы Вам обновления. Тогда таких проблем точно не будет или по крайней мере их можно будет на кого-то свалить. )))
Это понятно. Но зачем платить деньги, если у меня бесплатное обновление через интернет? 

Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1376
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
Мы тут уже все увидели, как Вы наобновляли!)))

Только подумайте чтобы было, если такое случилось бы на "живой" базу с реальными данными за полгода работы фирмы?

Оффлайн AntonB

  • Модератор
  • *****
  • Сообщений: 402
  • РЕПУТАЦИЯ: 74
  • КПД: 18%
  • Регистрация: 2011-05-26
  • Сайт: 
  • Профессия: Программист 8.1
А что, я тоже примерно так попал один раз.
Обновлял Розницу. Похоже, 1С тогда как раз что-то поменял с правами пользователей.
При запуске базы даже админу 1С сказал, что нет прав на вход в базу:)
Там, конечно, была предусмотрена обработка ("Обновление базы"), которая при первом входе запускается и все права переделывает. Только чтобы ее запустить, надо было еще в базу как-то войти:)
Пришлось, фактически, через конфигуратор сначала свою же базу взламывать:)
Предлагаю полный ИТ сервис небольшой организации в Москве (приходящий сисадмин+1С7.7,1С8.x)


Теги:
 

Добрый вечер! Прошу помочь, кто знает, подскажите пож. В счете не выводит грузоотправителя и грузополучаетля. Куда их внести ? Как сделать что бы выводило ? У меня 1с 8.3 редакция 11.1 управление торговлей Спасибо!

Автор Farid GasimliРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1972
Последний ответ 07 Фев 2016, 14:34
от pavl_vs
Куда сохраняются данные в режиме работы клиент при выгрузке данных обработкой "Универсальный обмен данными в формате XML"

Автор xDDРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 6961
Последний ответ 13 Ноя 2014, 08:23
от cska-fanat-kz
Не отображаются "Свойства номенклатуры" куда тыкнуть?

Автор limrikРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3215
Последний ответ 16 Янв 2012, 18:25
от limrik
Куда делась кнопка "Загрузить документы" в форме Входящие ТТН ЕГАИС?

Автор Елена1234Раздел Пользователям "1С - Предприятие 8"

Ответов: 5
Просмотров: 354
Последний ответ 12 Сен 2017, 12:26
от Елена1234
Номенклатура ЕГАИС в 1С Розница(модератор, поместите, пожалуйста,куда положено,не могу найти)

Автор Вероника1984Раздел Беседка

Ответов: 1
Просмотров: 71
Последний ответ 15 Дек 2017, 02:50
от Геннадий ОбьГЭС

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
BuhRust
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 166
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal