Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 04:45
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: ПолеВыбора  (Прочитано 1564 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн cannabis_86

  • ***
  • Сообщений: 168
  • РЕПУТАЦИЯ: 19
  • КПД: 11%
  • Регистрация: 2010-08-26
  • Сайт: 
Здравствуйте, 1с 8.2, управляемые формы, конфа своя. Подскажите как правильно нужно сделать, раньше помню как-то делал, но щас не получается. Вот код:
&НаКлиенте
Процедура НаименованиеНачалоВыбораИзСписка(Элемент, СтандартнаяОбработка)
Фам = Фамилия;
Им = Имя;
Отч = Отчество;

СписокВозможныхНаименований = Новый СписокЗначений;
Если ЗначениеЗаполнено(Фам) Тогда
СписокВозможныхНаименований.Добавить(Фам);
Если ЗначениеЗаполнено(Им) Тогда
СписокВозможныхНаименований.Добавить(СокрЛП(Фам) + " " + СокрЛП(Им));
СписокВозможныхНаименований.Добавить(СокрЛП(Фам) + " " + Лев(Им,1) + ".");
Если ЗначениеЗаполнено(Отчество) Тогда
СписокВозможныхНаименований.Добавить(СокрЛП(Фам) + " " + СокрЛП(Им) + " " + СокрЛП(Отч));
СписокВозможныхНаименований.Добавить(СокрЛП(Фам) + " " + Лев(Им,1) + ". " + Лев(Отч,1)+ ".");
КонецЕсли;
КонецЕсли;
Иначе
Если ЗначениеЗаполнено(Им) Тогда
СписокВозможныхНаименований.Добавить(Им);
Если ЗначениеЗаполнено(Отч) Тогда
СписокВозможныхНаименований.Добавить(СокрЛП(Им) + " " + СокрЛП(Отч));
СписокВозможныхНаименований.Добавить(СокрЛП(Им) + ". " + Лев(Отч,1)+ ".");
КонецЕсли;
Иначе
Если ЗначениеЗаполнено(Отч) Тогда
СписокВозможныхНаименований.Добавить(Отч);
КонецЕсли;
КонецЕсли;
КонецЕсли;
         
Элемент.СписокВыбора = СписокВозможныхНаименований;
КонецПроцедуры
Ругается на Элемент.СписокВыбора = СписокВозможныхНаименований; Не может присвоить ему значение.


Оффлайн cannabis_86

  • ***
  • Сообщений: 168
  • РЕПУТАЦИЯ: 19
  • КПД: 11%
  • Регистрация: 2010-08-26
  • Сайт: 
Re: ПолеВыбора
« Ответ #1: 13 Окт 2011, 10:53 »
Не уже ли нужно делать только так? :
	Для Каждого Значение Из СписокВозможныхНаименований Цикл
Элемент.СписокВыбора.Добавить(Значение);
КонецЦикла;


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 129
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal