Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 18:21
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: заменить шрихкоды  (Прочитано 3829 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн xDee

  • *
  • Сообщений: 35
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-09
  • Сайт: 
  • Профессия: Программист 7.7
Доброго времени суток все! Подскажите пожалуйста как реализовать данную задачу: ТиС, номенклатура имеет штрихкоды начинающиеся на 20, нужно найти их все и заменить на 26(свой внутренний). Никак не могу найти решение как спозиционироваться на 20 штрихкоде (или туплю чтоли).


Оффлайн volodya1122

  • ***
  • Сообщений: 215
  • РЕПУТАЦИЯ: 31
  • КПД: 14%
  • Регистрация: 2011-01-24
  • Сайт: 
  • Профессия: Программист 7.7
перебрать весь справочник "Номенклатура" в цикле. И проверять первых два символа в штрихкоде (Лев(ШтрихКод,2)).
Потом записать Штрихкод= "26"+Прав(ШтрихКод,(СтрДлина(ШтрихКод)-2))
думаю достаточно...

Или полностю за Вас написать процедуру,

Оффлайн xDee

  • *
  • Сообщений: 35
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-09
  • Сайт: 
  • Профессия: Программист 7.7
Ном=СоздатьОбъект("Справочник.Номенклатура");
 Штрих=СоздатьОбъект("Справочник.Единицы");
 Ном.ВыбратьЭлементы();
 Пока Ном.ПолучитьЭлемент()=1 цикл
    // Сообщить("Номенклатура "+Ном.Наименование);
     Штрих.ИспользоватьВладельца(Ном.ТекущийЭлемент());
     Штрих.ВыбратьЭлементы();
     Пока Штрих.ПолучитьЭлемент()=1 цикл
 _ШтрихКод = Лев(ШтрихКод,2));
Если ....
 конецЦикла;

Я встал на элемент Штрих , а вот дальше никак.

Оффлайн volodya1122

  • ***
  • Сообщений: 215
  • РЕПУТАЦИЯ: 31
  • КПД: 14%
  • Регистрация: 2011-01-24
  • Сайт: 
  • Профессия: Программист 7.7
а у тебя что Штрихкод это подчиненный справочник "Еденицы"? не уверен.....

Оффлайн xDee

  • *
  • Сообщений: 35
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-09
  • Сайт: 
  • Профессия: Программист 7.7
1C 7.7 Торговля и Склад 7.70.963
справочник "Единицы реквизит ШтрихКод подчинен Номенклатуре

Оффлайн volodya1122

  • ***
  • Сообщений: 215
  • РЕПУТАЦИЯ: 31
  • КПД: 14%
  • Регистрация: 2011-01-24
  • Сайт: 
  • Профессия: Программист 7.7
_ШтрихКод = Лев(Штрих.ШтрихКод,2));  // или как там в справочнике точно он называется
Если _ШтрихКод="20" тогда
Штрих.ШтрихКод= "26"+Прав(Штрих.ШтрихКод,(СтрДлина(Штрих.ШтрихКод)-2));
Штрих.Записать();
КонецЕсли;
КонецЦикла;

КонецЦикла;

//Может понадобится Записать в виде
// Лев(Строка(Штрих.ШтрихКод,2)))


Оффлайн xDee

  • *
  • Сообщений: 35
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-09
  • Сайт: 
  • Профессия: Программист 7.7
Выполняется обработка, забыл вывести что делает, видимо пошло, вот одно только а контрольная цифра последняя сканеру то все равно или все таки генерировать нужно и перезаписывать 20 кода ?

Оффлайн volodya1122

  • ***
  • Сообщений: 215
  • РЕПУТАЦИЯ: 31
  • КПД: 14%
  • Регистрация: 2011-01-24
  • Сайт: 
  • Профессия: Программист 7.7
а этого уже не скажу. Со сканером не работал

Оффлайн xDee

  • *
  • Сообщений: 35
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-09
  • Сайт: 
  • Профессия: Программист 7.7
Спасибо большое.

Оффлайн volodya1122

  • ***
  • Сообщений: 215
  • РЕПУТАЦИЯ: 31
  • КПД: 14%
  • Регистрация: 2011-01-24
  • Сайт: 
  • Профессия: Программист 7.7
Кстати не мешало бы создать какой то тестовый товар и поэксперементировать с разными значениями штрихкода...


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
163 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 494
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal