Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 13:24
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: процедура РассчтатьСумму()  (Прочитано 5882 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн RitaMurka

  • *
  • Сообщений: 18
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-10-10
  • Сайт: 
  • Профессия: Ученик 1С
Рассчитать сумму табличной части документа по строке, где ошибка, не могу рассчитать :fdbsdfbsd: :fdbsdfbsd:

Процедура РассчитатьСумму()
  ТекущаяСтрока = ЭлементыФормы.Склад.ТекущиеДанные;
  ТекущиеДанные = ТекущиеДанные.Цена*ТекущиеДанные.Количество
;         
КонецПроцедуры     
                                         
Процедура СкладКоличествоПриИзменении()
   РассчитатьСумму()
   
КонецПроцедуры

Процедура СкладЦенаПриИзменении()
   РассчитатьСумму()

КонецПроцедуры


Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
ТекущиеДанные.Сумма = ТекущиеДанные.Цена*ТекущиеДанные.Количество;
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн RitaMurka

  • *
  • Сообщений: 18
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-10-10
  • Сайт: 
  • Профессия: Ученик 1С
Все равно не считает((((

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Все равно не считает((((
Процедура РассчитатьСумму()
  ТекущаяСтрока = ЭлементыФормы.Склад.ТекущиеДанные;
  ТекущаяСтрока.Сумма = ТекущаяСтрока.Цена*ТекущаяСтрока.Количество;         
КонецПроцедуры     

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Да, кстати, ТекущаяСтрока
А вообще, подозреваю, что оно не просто не считало, а выдавало некие ошибки. Автор, мог бы и удосужиться их прочитать...
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн RitaMurka

  • *
  • Сообщений: 18
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-10-10
  • Сайт: 
  • Профессия: Ученик 1С
Да, кстати, ТекущаяСтрока
А вообще, подозреваю, что оно не просто не считало, а выдавало некие ошибки. Автор, мог бы и удосужиться их прочитать...
Вот именно что копируя Вашу процедуру ошибки не выдает, и считать НЕ считает....

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Да, кстати, ТекущаяСтрока
А вообще, подозреваю, что оно не просто не считало, а выдавало некие ошибки. Автор, мог бы и удосужиться их прочитать...
Вот именно что копируя Вашу процедуру ошибки не выдает, и считать НЕ считает....
Процедура РассчитатьСумму()
  ТекущаяСтрока = ЭлементыФормы.Склад.ТекущиеДанные;
  ТекущаяСтрока.Сумма = ТекущаяСтрока.Цена*ТекущаяСтрока.Количество;         
КонецПроцедуры   

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Обработчики привязаны к событиям?
Поставьте точки останова во всех трех событиях, и проследите, что куда заходит и как считает.
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн RitaMurka

  • *
  • Сообщений: 18
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-10-10
  • Сайт: 
  • Профессия: Ученик 1С
Вроде все привязано...

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Скрин формы покажите и табличной части


Теги:
 

Процедура "ОбработкаПроведения"

Автор demon3Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 1272
Последний ответ 22 Июн 2016, 14:46
от demon3
Процедура "Подсчет площади"

Автор Seregin63Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 2618
Последний ответ 28 Ноя 2013, 13:00
от Seregin63
1c 8.2: как называется процедура/функция, которая вызывается при вводе значения в поле на форме?

Автор jhd235Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1570
Последний ответ 08 Сен 2014, 08:28
от cska-fanat-kz
Процедура госрегистрации ИП и юрлиц будет проходить в течение трех дней

Автор newsРаздел Новости

Ответов: 0
Просмотров: 750
Последний ответ 03 Апр 2014, 15:16
от news
Процедура Инициализации при создании внешней обработки таб. частей

Автор crow1983Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 11696
Последний ответ 23 Авг 2010, 16:51
от crow1983

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
177 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
alex0402
46 Сообщений
andron81_81
41 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal