Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 17:11
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Свойства Элемента номенклатуры в печатной форме ценника.  (Прочитано 9299 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн boir

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-09-24
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день.
Забили номенклатуру. Для менеджеров заполнили характеристики товара на вкладке свойства, предварительно создав эти свойства. Теперь хотим вывести этиже свойства на ценник. Но ничего не выходит. С программированием не дружим, обработки не писали. Знаем только основы и то что печатные формы можно редактировать.

Что нужно подставить в ячейку при редактировании печатной формы ценника, чтобы в ячейке отразилось значение необходимого свойства?


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Нужно поставить значение этого свойства который необходимо подставить в ячейку этого самого свойства
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Ну что касается кода, то он будет примерно такой
Запрос = Новый Запрос;
            Запрос.Текст = "ВЫБРАТЬ
                           |   ЗначенияСвойствОбъектов.Свойство,
                           |   ЗначенияСвойствОбъектов.Значение
                           |ИЗ
                           |   РегистрСведений.ЗначенияСвойствОбъектов КАК ЗначенияСвойствОбъектов
                           |ГДЕ
                           |   ЗначенияСвойствОбъектов.Объект = &Объект";
            Запрос.УстановитьПараметр("Объект", СтрокаТаблицы.Номенклатура);
            Выборка = Запрос.Выполнить().Выбрать();
            Пока Выборка.Следующий() Цикл
               ОбластьСвойств = Макет.ПолучитьОбласть("Свойства");
               ОбластьСвойств.Параметры.Заполнить(Выборка);
               ТабДокумент.Вывести(ОбластьСвойств);
            КонецЦикла;

Я написал по памяти. В зависимости от кода в самой обработке печати, думаю нужно будет немного изменить вывод областей свойств.
В данном случае, выводятся все свойства.
Ну и само собой нужно добавить на макете необходимые параметры.

Оффлайн boir

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-09-24
  • Сайт: 
  • Профессия: Ученик 1С
Спасибо а ответы. Но я полный ноль в коде. Может поможете, рассказав подробнее?

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
А какая у вас конфигурация? (бухгалтерия, УПП) и платформа 1С (8.1, 8.2)?

Оффлайн boir

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-09-24
  • Сайт: 
  • Профессия: Ученик 1С
А какая у вас конфигурация? (бухгалтерия, УПП) и платформа 1С (8.1, 8.2)?
Платформа 8.2 Конфигурация Управление торговлей 10.3

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Сейчас под рукой УТ-шки нет, завтра посмотрю. И еще вопрос: а как быть с количеством свойств? Их у вас сколько? Просто это будет сказываться на самом размере ценника.

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Спасибо а ответы. Но я полный ноль в коде. Может поможете, рассказав подробнее?

Функцию печати ценников выпоняет обработка "ПечатьЦенников".
Для экспериментов лучше сохранить ее как внешнюю обработку. В этой обработке есть модуль объекта, в котором есть функция "ПечатьЦенника". Вот это то, что нам нужно.
Если возможно, запостите код, который над которым вы работаете.

Оффлайн boir

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-09-24
  • Сайт: 
  • Профессия: Ученик 1С
// Производит заполнение переданными из формы подбора данными.
//
// Параметры:
//  ЗначениеВыбора - структура, содержащая параметры подбора.
//
Процедура ОбработкаПодбора(ЗначениеВыбора)

Перем Номенклатура, ЕдиницаИзмерения, Количество, ХарактеристикаНоменклатуры;

// Получим параметры подбора из структуры подбора.
ЗначениеВыбора.Свойство("Номенклатура"    , Номенклатура);
ЗначениеВыбора.Свойство("ЕдиницаИзмерения", ЕдиницаИзмерения);
ЗначениеВыбора.Свойство("Количество"      , Количество);
ЗначениеВыбора.Свойство("Характеристика"  , ХарактеристикаНоменклатуры);

// Ищем выбранную позицию в таблице подобранной номенклатуры.
//  Если найдем - увеличим количество; не найдем - добавим новую строку.
СтруктураОтбора = Новый Структура;
СтруктураОтбора.Вставить("Номенклатура"              , Номенклатура);
СтруктураОтбора.Вставить("ЕдиницаИзмерения"          , ЕдиницаИзмерения);
СтруктураОтбора.Вставить("ХарактеристикаНоменклатуры", ХарактеристикаНоменклатуры);

СтрокаТабличнойЧасти = ОбработкаТабличныхЧастей.НайтиСтрокуТабЧасти(Товары, СтруктураОтбора);
Если СтрокаТабличнойЧасти <> Неопределено Тогда

// Нашли, увеличиваем количество в первой найденной строке.
СтрокаТабличнойЧасти.Количество = СтрокаТабличнойЧасти.Количество + Количество;
Иначе // не нашли - добавляем новую строку
СтрокаТабличнойЧасти = Товары.Добавить();
СтрокаТабличнойЧасти.Номенклатура               = Номенклатура;
СтрокаТабличнойЧасти.ЕдиницаИзмерения           = ЕдиницаИзмерения;
СтрокаТабличнойЧасти.ХарактеристикаНоменклатуры = ХарактеристикаНоменклатуры;
СтрокаТабличнойЧасти.Количество                 = Количество;
СтрокаТабличнойЧасти.Печать                     = Истина;
КонецЕсли;

ЭлементыФормы.Товары.ТекущаяСтрока = СтрокаТабличнойЧасти;
ЭлементыФормы.Товары.ТекущаяКолонка = ЭлементыФормы.Товары.Колонки.Количество;

КонецПроцедуры // ОбработкаПодбора()

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Не очень понял, почему подбор?


Теги:
 

Группа "СписокКомпоновщикНастроекПользовательскиеНастройки" в форме "Перечисления"

Автор Азамат ХубиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1762
Последний ответ 12 Ноя 2016, 18:08
от Азамат Хубиев
Изменение цвета при подборе сотрудника в форме списка справочника "Сотрудники организации" для документа "Зарплата к выплате организаций" ЗУП 2.5

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 270
Последний ответ 12 Окт 2017, 14:02
от wise
Как настроить отображение на форме "группа плательщика единого налога" при выборе системы налогообложения "Единый налог"?

Автор Nicolayci91Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2279
Последний ответ 17 Авг 2015, 07:48
от cska-fanat-kz
"фильтрация" номенклатуры

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 12
Просмотров: 7961
Последний ответ 11 Мар 2014, 16:09
от mashencev_anton
Добавление строки и заполнение строки в ТЗ на форме

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 302
Последний ответ 25 Сен 2017, 09:00
от Св Ч

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
179 Сообщений
ilyay ilyay
69 Сообщений
alex0402
54 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 574
  • Точка Скрытых: 1
  • Точка Пользователей: 11
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal