Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 18:34
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Создание собственного отчета  (Прочитано 3603 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн goonia91

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-10-05
  • Сайт: 
  • Профессия: Ученик 1С
Здраствуйте.

Я недавно начал изучать 1с предприятие 8.
Я прохожу практику в организации которая занимается 1с. Мой руководитель дал мне задание сделать собственный отчет. Дал мне базу которая шла вместе с книгой бухгалтерия для беларуси (редакция 1.6).
Я создал макет, в форме надо указывать: дату начала и конца, склад, тип цены. Я это сделал.

Но никак не могу разобраться что писать в коде. Мне надо сделать остаток материалов на складе с определенного времени по определенное(указывается на форме). В отчете есть колонки: документ(номер договора); товар(цена товара); товар с наценкой(кол-во * на цену).

В модуле я написал только это:


 Процедура КоманднаяПанель1Сформировать(Кнопка)

   ОбновитьОтчет();

КонецПроцедуры // КоманднаяПанель1Сформировать()


Процедура ОбновитьОтчет()
   Если НЕ ЗначениеЗаполнено(ДатаНач) Или НЕ ЗначениеЗаполнено(ДатаКон) Тогда
      Предупреждение("Не выбран период!");
      Возврат;
   КонецЕсли;
   
   Если НЕ ЗначениеЗаполнено(Склад) Тогда
      Предупреждение("Не выбран склад!");
      Возврат;
   КонецЕсли;

   Если НЕ ЗначениеЗаполнено(ТипЦены) Тогда
      Предупреждение("Не выбрано тип цены!");
      Возврат;
   КонецЕсли;
   

КонецПроцедуры



Дорогие форумчани помогите пожалуйста. Очень надо.

Заранее благодарен


Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Наверное не остаток, а движения номенклатуры по складу в разрезе документа?

Оффлайн goonia91

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-10-05
  • Сайт: 
  • Профессия: Ученик 1С
Наверное не остаток, а движения номенклатуры по складу в разрезе документа?

я ща спросил, вы правы.

Поможете мне, хоть немного

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Нет у меня конфигурации этой, поэтому буду говорить про свои ощущения))))

Начать нужно с определения того места (источника данных), откуда мы это все брать будем.
Скорее всего, это будет некий регистр. Предположу, что регистр бухгалтерии.
Посмотрите, в каком из регистров есть эта информация.

Оффлайн goonia91

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-10-05
  • Сайт: 
  • Профессия: Ученик 1С
Нет у меня конфигурации этой, поэтому буду говорить про свои ощущения))))

Начать нужно с определения того места (источника данных), откуда мы это все брать будем.
Скорее всего, это будет некий регистр. Предположу, что регистр бухгалтерии.

Посмотрите, в каком из регистров есть эта информация.

в регистрах бухгалтерии есть: налоговый, хозрасчетный и налоговыйУСН

Последний раз редактировалось: progmikon; 05 Окт 2011, 12:23

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Нет у меня конфигурации этой, поэтому буду говорить про свои ощущения))))

Начать нужно с определения того места (источника данных), откуда мы это все брать будем.
Скорее всего, это будет некий регистр. Предположу, что регистр бухгалтерии.

Посмотрите, в каком из регистров есть эта информация.

в регистрах бухгалтерии есть: налоговый, хозрасчетный и налоговыйУСН

Понятно. Посмотрите, нет ли какого-то регистра накопления для этой цели?

Оффлайн Андрей Федотов

  • ***
  • Сообщений: 212
  • РЕПУТАЦИЯ: 36
  • КПД: 17%
  • Регистрация: 2011-07-07
  • Компания: Future IT Solutions
  • Профессия: Разработчик 1С
Вам необходимо:
0) Сделать проверки заполненности входных параметров (вы уже сделали)
1) Получить макет
2) Получить области макета
3) Выполнить запрос для последующего получения результатов
4) Обработать выборку по алгоритму (если необходимо)
5) Присвоить параметрам областей значения из выборки.
6) Вывести области макета в необходимом порядке
7) Показать макет на экране

Все действия, за исключением п. 3 и 4 вы можете найти в любом отчете с параметрами.
Посмотрите какой-нибудь из отчетов в вашей конфигурации.
С уважением,
Андрей Федотов
Future IT Solutions


Теги:
 

Печатная форма "ЧекККМ" для "Отчета о розничных продажах"

Автор Игорь ПолищукРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 7074
Последний ответ 01 Июн 2011, 20:39
от Шурыгин Иван Сергеевич
Формирование отчёта "Задолженость по контрагентам" 1С:Предприятие 8.2 "Торговля для частных предпринимателей базовая", редакция 1.0

Автор casper009Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 3009
Последний ответ 27 Май 2015, 10:02
от casper009
Программное создание документа на основании документа

Автор GolickoffРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4516
Последний ответ 23 Апр 2015, 08:45
от Golickoff
Ошибка при выгрузке отчета "Прибыль"

Автор VasilРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4105
Последний ответ 28 Апр 2011, 14:34
от MaryaAlbertovna
Программирование отчета "Движения на складах"

Автор ЛунатикРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1970
Последний ответ 05 Апр 2016, 10:15
от vitasw

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
140 Сообщений
AIFrame
70 Сообщений
ilyay ilyay
65 Сообщений
alex0402
51 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
BuhRust
31 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 395
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal