Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Янв 2018, 05:44
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Заполнение табличной части документа на основании другой табличной части  (Прочитано 6572 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн gorelchik

  • **
  • Сообщений: 76
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-06-30
  • Сайт: 
  • Профессия: Программист 7.7
Народ помогите, не могу понять почему не заполняется табличная часть одного документа на основании другого документа. Точнее наименование не заполняется, т.е. количество цена и т.д. заполняется, а наименование нет. Что в одном и в другом документе наименование привязано  к справочнику номенклатуры, единственное что в одном документе этот реквизит называется ТОВАР, а в другом УСЛУГА. вот код:
Функция ЗаполнитьНаОсновании()
Если
   Вопрос("Документ будет  заполнен на основании
          |выбранного документа. Продолжить?", "Да+Нет" ) <> "Да" Тогда
      Возврат 0;
   КонецЕсли;
   УдалитьСтроки();
   ТаблицаДокумента = СоздатьОбъект("ТаблицаЗначений");
   Если ДокументПоступления.Вид() = "ПоступлениеТоваров" Тогда
   ДокументПоступления.ВыгрузитьТабличнуюЧасть(ТаблицаДокумента, "Товар, Количество, Цена, Сумма, НДС, НП, Всего, ГТД");
   Услуга = ТаблицаДокумента.Товар;
   КонецЕсли;
   ЗагрузитьТабличнуюЧасть(ТаблицаДокумента);   
КонецФункции

Подскажите что не так


Оффлайн TORN

  • *
  • Сообщений: 35
  • РЕПУТАЦИЯ: 3
  • КПД: 9%
  • Регистрация: 2011-09-03
  • Сайт: 
  • Профессия: Бухгалтер
Либо переименуй в тз колонку товар, или перебором тз с добавлением строки в документе

Оффлайн gorelchik

  • **
  • Сообщений: 76
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-06-30
  • Сайт: 
  • Профессия: Программист 7.7
А новую строку в табличной части создавать, это какой алгоритм?

Оффлайн gorelchik

  • **
  • Сообщений: 76
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-06-30
  • Сайт: 
  • Профессия: Программист 7.7


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
99 Сообщений
AIFrame
65 Сообщений
alex0402
32 Сообщений
kiksi
26 Сообщений
pavl_vs
24 Сообщений
alexandr_ll
17 Сообщений
andron81_81
16 Сообщений
Norfolk
15 Сообщений
KOI8-R
14 Сообщений
MuI_I_Ika MuI_I_Ika
13 Сообщений

* Кто онлайн

  • Точка Гостей: 118
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal