Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Май 2018, 06:24
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: получение списка значений по условию  (Прочитано 6248 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн primus

  • **
  • Сообщений: 71
  • РЕПУТАЦИЯ: 2
  • КПД: 3%
  • Регистрация: 2011-08-01
  • Сайт: 
  • Профессия: Программист 1С
Есть документ, среди прочих у него есть реквизит СельскаяТерритория типа Перечисление.СельскаяТерритория и еще один реквизит Село тип Ссылка.Справочник.СелаПоСельскимТерриториям, в котором у меня связаны села и сельские поселения.
Идея такая: в форме документа при выборе сельского поселения получать в поле Село список из сел, которые входят в это поселение.
Печатную форму я получаю, а вот каким образом получить список для поля - не понимаю покамест.


Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1310
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Если я правильно понял, то при выборе сельского поселения необходимо открывать форму списка сел, с отбором по выбранному сельскому поселению.

Оффлайн primus

  • **
  • Сообщений: 71
  • РЕПУТАЦИЯ: 2
  • КПД: 3%
  • Регистрация: 2011-08-01
  • Сайт: 
  • Профессия: Программист 1С
выбираем сельское поселение, а в процедуре
НачалоВыбораИзСписка поля Село выдавать эту самую форму списка с отбором по выбраному сельскому поселению.

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1310
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
А, т.е. открывается список, а не форма списка. Ну тогда в чем проблема то?

Оффлайн primus

  • **
  • Сообщений: 71
  • РЕПУТАЦИЯ: 2
  • КПД: 3%
  • Регистрация: 2011-08-01
  • Сайт: 
  • Профессия: Программист 1С
проблема организовать отбор

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1310
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Просто тебе список для выбора придется строить динамически. Т.е. как выбрал сельское поселение, запросом получаешь села по этому поселению и вставляешь их в список выбора

Оффлайн primus

  • **
  • Сообщений: 71
  • РЕПУТАЦИЯ: 2
  • КПД: 3%
  • Регистрация: 2011-08-01
  • Сайт: 
  • Профессия: Программист 1С
список я составляю, все отлично. Еще сейчас вот додумаю обработку выбора, чтобы присваивалось значение полю при выборе значения из списка. Если подскажешь, как сделать, буду благодарен.

Процедура формирования списка значений.
Процедура СелоНачалоВыбораИзСписка(Элемент, СтандартнаяОбработка)
   Список = Новый СписокЗначений;
   ВыборСела = Справочники.СелаПоСельскимТерриториям.Выбрать();
   Пока ВыборСела.Следующий() Цикл
      Объект = ВыборСела.ПолучитьОбъект();
      Если Объект.СельскаяТерритория = СельскаяТерритория Тогда
         Список.Добавить(Объект.Наименование);
      КонецЕсли;
   КонецЦикла;
   Вид = ВыбратьИзСписка(Список, Элемент);
КонецПроцедуры

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1310
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Формируй список запросом, объект не надо получать, в список добавляй ссылку на элемент, а не обьект. Чтобы присвоилось значение, то типы должны быть одинаковы.

Оффлайн ivanov660

  • *
  • Сообщений: 18
  • РЕПУТАЦИЯ: 1
  • КПД: 6%
  • Регистрация: 2011-09-05
  • Компания: Орион XL
  • Профессия: Программист 1С
Если не нравится запрос (произвольный запрос), используй свойство "отбор" для формы списка.

Оффлайн primus

  • **
  • Сообщений: 71
  • РЕПУТАЦИЯ: 2
  • КПД: 3%
  • Регистрация: 2011-08-01
  • Сайт: 
  • Профессия: Программист 1С
сделал вот так. Работает вполне неплохо, правда без выпадающего списка, а с окошком. При этом реквизит Село сделал типом "Строка".
Процедура СелоНачалоВыбора(Элемент, СтандартнаяОбработка)
   Список = Новый СписокЗначений;
      ВыборСела = Справочники.СелаПоСельскимТерриториям.Выбрать();
      Пока ВыборСела.Следующий() Цикл
         Объект = ВыборСела.ПолучитьОбъект();
         Если Объект.СельскаяТерритория = СельскаяТерритория Тогда
            Список.Добавить(Объект.Наименование);
         КонецЕсли;
      КонецЦикла;
    ВыбЭлемент = Список.НайтиПоЗначению(Село);
   ВыбЭлемент = Список.ВыбратьЭлемент("Выберите село", ВыбЭлемент);
   Если ВыбЭлемент = Неопределено Тогда
      Сообщить("Село не выбрано");
   Иначе
      Село = ВыбЭлемент.Значение;
   КонецЕсли;
КонецПроцедуры



Теги:
 

Обнаружено дублирование ключевых значений в колонке ссылка ["обнаружено дублирование ключевых з

Автор lianinfoРаздел Пользователям "1С - Предприятие 8"

Ответов: 10
Просмотров: 680
Последний ответ 20 Мар 2018, 16:54
от alex0402
Изменение цвета при подборе сотрудника в форме списка справочника "Сотрудники организации" для документа "Зарплата к выплате организаций" ЗУП 2.5

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 517
Последний ответ 12 Окт 2017, 14:02
от wise
"Таблица значений" в результате запроса - 1С

Автор mvk843Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 1285
Последний ответ 15 Июн 2017, 07:53
от mvk843
Ошибка - Обнаружено дублирование ключевых значений в колонке "Ссылка". Отображение данных в списке не возможно.

Автор welldoneРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 5453
Последний ответ 24 Ноя 2015, 15:38
от welldone
"Проверка мутабельных значений на заполненность не поддерживается"

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 22851
Последний ответ 13 Фев 2011, 17:36
от proofet

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
152 Сообщений
oleg-x
64 Сообщений
alex0402
60 Сообщений
AIFrame AIFrame
52 Сообщений
wise wise
37 Сообщений
KOI8-R
33 Сообщений
buketov.av buketov.av
28 Сообщений
Alter
22 Сообщений
alexandr_ll
20 Сообщений
BuhRust
19 Сообщений

* Кто онлайн

  • Точка Гостей: 244
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal